cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
728
Views
0
Helpful
6
Replies
ptaabbodi
Beginner

Problem With ASR 1002-x

Hello

We have a Cisco ASR1002-x in our network as BRAS and PPPOE Server.

It used IOS "asr1002x-universalk9_noli.03.10.01.S.153-3.S1-ext.SPA.bin" and it worked very well until we need to upgrade our links to Telecommunication Company, from 1G to 10G.

So we purchased an "SPA-1X10GE-L-V2 " module with one XFP but the ASR 1002-x Couldn`t Detect it (Because it`s old IOS didn`t Support it).

So we download IOS "asr1002x-universalk9.03.13.03.S.154-3.S3-ext.SPA.bin " from Cisco Website and upgrade our Router IOS, after that ASR detect new card and we change our links to 10G.

But after all upgrade processes we find out that our ADSL Customers that connect to our BRAS have problem with taking DNS configuration from BRAS, if they connect to us by setting their ADSL modems to Bridge mode (RFC 1483) and Creating a Broadband connection on their PCs they don`t receive any DNS Server IP Address! Also after authentication they need about 50 Seconds to register to our network while we didn`t have these problems before IOS upgrading.

Now to fix their problems we need to disable "LCP Extensions " or set at least one DNS Server IP Address on their Broadband connection settings Manually that is really bad for us…

At the end I should say that if they configure their modems as PPPOE client, the modem easily receive all settings include DNS configuration (that we set them in profile template in our ASR1002-x) and connect soon without any problems….

please help us...

6 REPLIES 6
Manuel Rodriguez
Cisco Employee

Hi,

It would be good to have a configuration of the device as reference and perhaps outputs of "debug ppp negotiation" for a session affected by the issue so some analysis can be performed.

Also, when you say: "after authentication they need about 50 Seconds to register to our network ", what does this mean? Does this mean PPP negotiation takes 50 seconds? Is authentication to radius taking 50 seconds? Where exactly in the session bring up is the delay happening? How are you able to see it?

Regards.

Hi

Thanks for your Attention

1- Exactly witch part of my ASR configuration you need?

2- This is PPP Negotiation Debugging Log:

Apr 20 09:50:48.223: ppp15557 LCP: I CONFREQ [Stopped] id 126 len 20

Apr 20 09:50:48.223: ppp15557 LCP:    MRU 1492 (0x010405D4)

Apr 20 09:50:48.223: ppp15557 LCP:    ACCM 0x00000000 (0x020600000000)

Apr 20 09:50:48.223: ppp15557 LCP:    MagicNumber 0x00243E18 (0x050600243E18)

Apr 20 09:50:48.223: ppp15557 LCP: O CONFREQ [Stopped] id 1 len 18

Apr 20 09:50:48.223: ppp15557 LCP:    MRU 1492 (0x010405D4)

Apr 20 09:50:48.223: ppp15557 LCP:    AuthProto PAP (0x0304C023)

Apr 20 09:50:48.223: ppp15557 LCP:    MagicNumber 0x850341ED (0x0506850341ED)

Apr 20 09:50:48.223: ppp15557 LCP: O CONFACK [Stopped] id 126 len 20

Apr 20 09:50:48.223: ppp15557 LCP:    MRU 1492 (0x010405D4)

Apr 20 09:50:48.223: ppp15557 LCP:    ACCM 0x00000000 (0x020600000000)

Apr 20 09:50:48.223: ppp15557 LCP:    MagicNumber 0x00243E18 (0x050600243E18)

Apr 20 09:50:48.223: ppp15557 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]

Apr 20 09:50:48.224: ppp11398 LCP: I CONFACK [ACKsent] id 1 len 18

Apr 20 09:50:48.224: ppp11398 LCP:    MRU 1492 (0x010405D4)

Apr 20 09:50:48.224: ppp11398 LCP:    AuthProto PAP (0x0304C023)

Apr 20 09:50:48.224: ppp11398 LCP:    MagicNumber 0x850341DC (0x0506850341DC)

Apr 20 09:50:48.224: ppp11398 LCP: Event[Receive ConfAck] State[ACKsent to Open]

Apr 20 09:50:48.225: ppp63 PAP: O AUTH-NAK id 246 len 29 msg is "Your account has expired"

Apr 20 09:50:48.225: ppp63 PPP DISC: User failed PAP authentication

Apr 20 09:50:48.225: ppp63 PPP: Sending Acct Event[Down] id[79A533]

Apr 20 09:50:48.225: PPP: NET STOP send to AAA.

Apr 20 09:50:48.225: ppp63 LCP: O TERMREQ [Open] id 2 len 4

Apr 20 09:50:48.225: ppp63 LCP: Event[CLOSE] State[Open to Closing]

Apr 20 09:50:48.225: ppp63 PPP: Phase is TERMINATING

Apr 20 09:50:48.226: ppp11398 PPP: Queue PAP code[1] id[174]

Apr 20 09:50:48.227: ppp15557 LCP: I CONFACK [ACKsent] id 1 len 18

Apr 20 09:50:48.227: ppp15557 LCP:    MRU 1492 (0x010405D4)

Apr 20 09:50:48.227: ppp15557 LCP:    AuthProto PAP (0x0304C023)

Apr 20 09:50:48.227: ppp15557 LCP:    MagicNumber 0x850341ED (0x0506850341ED)

Apr 20 09:50:48.227: ppp15557 LCP: Event[Receive ConfAck] State[ACKsent to Open]

Apr 20 09:50:48.228: ppp15557 PPP: Queue PAP code[1] id[253]

----------------

3-After Authentication and when connection display the message of "Registering your computer on the network" i should wait for about 50 Seconds... see the attachment picture(it`s show for 50 Second and after that user connect to internet without DNS configuration).

Hi,

1- Exactly witch part of my ASR configuration you need?

All if possible. If you are not comfortable sharing that here, I would suggest to open a TAC case.

2- This is PPP Negotiation Debugging Log:

I don't see 50 seconds  of PPP negotiation here for a single PPP session. The number after "ppp" in the output is an ID for the session, we can see there there is no complete PPP negotiation for any of those sessions. This data is not useful. Please provide those debug outputs. Perhaps 'debug radius' would also be useful.

3-After Authentication and when connection display the message of "Registering your computer on the network" i should wait for about 50 Seconds... see the attachment picture(it`s show for 50 Second and after that user connect to internet without DNS configuration).

I'm afraid I cannot really tell what is the PPPoE windows client doing there. I'm not an expert in windows PPPoE client. I could only help you looking at the BRAS side for which I need the mentioned debugs.

Regards.

Dear Manuel Rodriguez

I am really appreciating for your supporting...

I finally fix it by downgrading our Router IOS from

" asr1002x-universalk9.03.13.03.S.154-3.S3-ext.SPA.bin"

 to

"asr1002x-universalk9.03.11.00.S.154-1.S-std.SPA.bin "

Thanks again

Bye

 

 

Nasser Heidari
Beginner

Hi,

I have faced with this issue before. Its because of a change in default PPP Packet throttle value in this version.

My problem solved after I have increased Throttle threshold:

ppp packet throttle 20 1 30

Note:

As far as I noticed, this is the change history:

before CSCuo88855
the defaults are 10000 packets in 3600 sec with no blocking (ppp packet throttle 10000 3600 0)

after CSCuo88855
the defaults are 10 packets in 1 sec with 30 seconds blocking (ppp packet throttle 10 1 30)

Regards,

Nasser

Hi Nasser,

Thant is a possible cause. If it is indeed the cause, the debugs mentioned in this thread would show something like:

PPP: Packet throttled, Dropping packet

Regards.

Content for Community-Ad