cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1583
Views
0
Helpful
9
Replies
promise kumalo
Beginner

QinQ packets

Hello

I want to use qinq tunnelling in my network. I have 2 cisco 3750 on the edge terminating the qinq tunnels, but in between i have cisco 2960.

My question is does cisco 2960 pass qinq traffic

Thank u

Sent from Cisco Technical Support iPhone App

9 REPLIES 9
Fredrik Lönnman
Beginner

Sure, as long as you configure the proper MTU to cope with the extra tag, 1504 would probably suffice.

Hi there

I tried to configure the system mtu to 1998 and the routing mtu to 1998, but still it wouldnt come up.

Sent from Cisco Technical Support iPhone App

You wont be needing the routing MTU just to pass QinQ frames. Try the mtu system jumbo command: http://www.cisco.com/en/US/products/hw/switches/ps700/products_configuration_example09186a008010edab.shtml#c4a

promise kumalo
Beginner

I also treid that. It ddnt work. The funny thing is if you substitute the cisco switch for a huawei switch with default configs it works.

Whats on huawei switch thats not on cisco switch.

Sent from Cisco Technical Support iPhone App

Can you pastebin the configurations? Maybe there's something else other than MTU that's in the way. Generally this should work.

the setup is like this SW1<>SW2<>SW3. SW1 and SW3 are the ones terminating the QinQ tunnels. SW2 is just forwardingn the QinQ vlan

configs for SW1 - Huawei CX 300A

interface Ethernet2/0/4

description XXX

port link-type dot1q-tunnel

port default vlan 106

trust 8021p

qos queue be cir 80 pir 90

qos queue af1 cir 80 pir 90

qos queue af2 cir 80 pir 90

qos queue af3 cir 80 pir 90

qos queue af4 cir 80 pir 90

qos queue ef cir 90 pir 100

qos queue cs6 cir 80 pir 90

qos queue cs7 cir 80 pir 90

interface Ethernet2/0/5

description to-cisco-2960

port link-type trunk

port trunk allow-pass vlan 106

trust 8021p

qos queue be cir 80 pir 90

qos queue af1 cir 80 pir 90

qos queue af2 cir 80 pir 90

qos queue af3 cir 80 pir 90

qos queue af4 cir 80 pir 90

qos queue ef cir 90 pir 100

qos queue cs6 cir 80 pir 90

qos queue cs7 cir 80 pir 90

##########################################################

SW2 configs - cisco 2960

SSC_2960#sh system mtu

System MTU size is 1998 bytes

System Jumbo MTU size is 9000 bytes

Routing MTU size is 1998 bytes

interface FastEthernet0/4

description QinQ_Vlan_to_huawei-CX-300A-Ethernet2/0/5

switchport trunk allowed vlan 106

switchport mode trunk

interface FastEthernet0/6

description QinQ_Vlan_to_huawei-CX-300A-Ethernet3/0/7

switchport trunk allowed vlan 106

switchport mode trunk

#####################################################################

SW3 configs - Huawei CX300A

interface Ethernet1/0/10

description XXX

port link-type dot1q-tunnel

port default vlan 106

trust 8021p

qos queue be cir 80 pir 90

qos queue af1 cir 80 pir 90

qos queue af2 cir 80 pir 90

qos queue af3 cir 80 pir 90

qos queue af4 cir 80 pir 90

qos queue ef cir 90 pir 100

qos queue cs6 cir 80 pir 90

qos queue cs7 cir 80 pir 90

interface Ethernet3/0/7

description to-cisco-2960

port link-type trunk

port trunk allow-pass vlan 106

trust 8021p

qos queue be cir 80 pir 90

qos queue af1 cir 80 pir 90

qos queue af2 cir 80 pir 90

qos queue af3 cir 80 pir 90

qos queue af4 cir 80 pir 90

qos queue ef cir 90 pir 100

qos queue cs6 cir 80 pir 90

qos queue cs7 cir 80 pir 90

Looks fairly straight forward. What exactly isnt working? Do you see mac addresses in the 2960 and in the remote Huawei?

promise kumalo
Beginner

Yes i can see macs on all devices. What is not working is that if i connect 2 laptops on my qinq ports on the huawei switches i cant ping end to end. If i sustitute the cisco switch with a huawei cx300A it works.

Sent from Cisco Technical Support iPhone App

can you span fa0/4 and fa0/6 on the cat2960 (making sure you capture vlan tags) while you ping end to end from your laptops?  so we can sure that the double tag imposed by huaweii switch is compliant with specs.

Riccardo

Content for Community-Ad

This widget could not be displayed.