cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

626
Views
0
Helpful
9
Replies
Beginner

AIR-CAP1532I-E-K9 wlc 5508 registration problem

Hi,

I've a WLC 5508 running the 8.2.151.0 software version and I try to register Cisco AIR-CAP1532I-E-K9 in FlexConnect AP mode with the port of the switch configured in trunk mode. In this situation the AP doesn't register into the WLC. If i configure the AP like local AP and connected the AP into the ethernet of the switch configured in access mode, it works find.

in the WLC there are 44 AP registered in local and FlexConnect modes and They work find. The models are:

AIR-CAP2702I-E-K9

AIR-CAP2702E-E-K9

AIR-CAP2602I-E-K9

Is it a bug ?

Kind Regards

Michele Rossi

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

I have tested with a 1532 in

I have tested with a 1532 in FlexConnect mode and did not experience any issue (tested with 8.3.112.0 code)

Here is the switchport config

interface GigabitEthernet1/0/12
switchport trunk native vlan 1611
switchport mode trunk

AP in FlexConnect mode got an IP from vlan 1611 & registered to WLC

1532-AP1#sh ip int bri | ex un
Interface IP-Address OK? Method Status Protocol
BVI1 10.161.35.2 YES DHCP up up
1532-AP1#sh capwap client rcb 
AdminState : ADMIN_ENABLED
SwVer : 8.3.112.0
NumFilledSlots : 2
Name : 1532-AP1
ApMode : FlexConnect
ApSubMode : Not Configured
Flex-group name : default-flex-group

I would suggest you to try assign IP statically (via CLI as below and see if that helpls)

1532-AP1#capwap ap ip address 10.161.35.254 255.255.254.0

If needed point it to WLC as well

1532-AP1#capwap ap controller ip address ?
A.B.C.D Controller IP address

HTH

Rasika

*** Pls rate all useful responses ***

9 REPLIES 9
VIP Mentor

Did you check that AP

Did you check that AP management IP is on the native vlan of trunk between SW & 1532 ?  

Once configured as trunk port, make sure AP IP can reach WLC first.

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

yes,

yes,

this is the configuration port of the switch for AP:

switchport trunk native vlan 12
switchport mode trunk
switchport nonegotiate
spanning-tree portfast trunk
spanning-tree bpduguard enable

where vlan 12 is the management Vlan of the WLC.

the problem is that once configured as trunk port, the AP doesn't has an IP address because it can't reach the wlc:

*Jul  5 09:48:04.563: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.

Beginner

As Rasika mentioned the

As Rasika mentioned the native VLAN should be AP management VLAN, not the management VLAN of your WLC unless you use the same VLAN for AP and WLC management.

Beginner

Yes the Vlan is te same for

Yes the Vlan is the same for AP and WLC management, like the others 46 AP's correctly registered with the same procedure and configuration step.

Beginner

Is it a brand new AP?

Is it a brand new AP?

As far as I know 1500 APs are shipped in a bridge mode by default - this means that you need to add MAC address of the AP to the controller MAC filter list, otherwise the AP won't be able to join.

Beginner

No it isn't. I've just

No it isn't. I've just regitered like local Ap into the WLC and its mac address is already in the WLC Security AP Policies and not in the Mac filter list

VIP Mentor

I have tested with a 1532 in

I have tested with a 1532 in FlexConnect mode and did not experience any issue (tested with 8.3.112.0 code)

Here is the switchport config

interface GigabitEthernet1/0/12
switchport trunk native vlan 1611
switchport mode trunk

AP in FlexConnect mode got an IP from vlan 1611 & registered to WLC

1532-AP1#sh ip int bri | ex un
Interface IP-Address OK? Method Status Protocol
BVI1 10.161.35.2 YES DHCP up up
1532-AP1#sh capwap client rcb 
AdminState : ADMIN_ENABLED
SwVer : 8.3.112.0
NumFilledSlots : 2
Name : 1532-AP1
ApMode : FlexConnect
ApSubMode : Not Configured
Flex-group name : default-flex-group

I would suggest you to try assign IP statically (via CLI as below and see if that helpls)

1532-AP1#capwap ap ip address 10.161.35.254 255.255.254.0

If needed point it to WLC as well

1532-AP1#capwap ap controller ip address ?
A.B.C.D Controller IP address

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

Thanks Rasika,

Thanks Rasika,

I resolve the problem with this command

capwap ap controller ip address 

With show capwap ip config I saw that there was another ip management set up....

I manually correct it and now the AP works find.

Thanks a lot

Michele

VIP Mentor

Glad to hear that your issues

Glad to hear that your issues get resolved. 

Thanks for rating our responses as well

Rasika

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards