cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
2170
Views
10
Helpful
3
Replies
Beginner

AP 1231 vlan problem multiple ssid

Hi all,

I have troubles configuring the AP. This is what i want:

1 wireless network SSID WORTEL (vlan 1, my internal network)

1 wireless network SSID GUEST_NETWORK (vlan 10, for guests and user2)

With this config only the GUEST_NETWORK have internet access. WORTEL don't even get an ip address from the dhcp server.

See below for the config of the devices.

Thanks in advance for your replies!

ROTER CONFIG (CISCO871-SEC-K9):

Building configuration...

Current configuration : 2824 bytes

!

! Last configuration change at 11:33:23 UTC Wed Jun 15 2011 by x

! NVRAM config last updated at 11:37:26 UTC Wed Jun 15 2011 by x

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname x

!

boot-start-marker

boot system flash:c870-advipservicesk9-mz.124-24.T2.bin

boot-end-marker

!

logging message-counter syslog

!

aaa new-model

!

!

aaa authentication login default local

!

!

aaa session-id common

!

!

dot11 syslog

ip source-route

!

!

ip dhcp excluded-address 172.16.1.1 172.16.1.49

ip dhcp excluded-address 172.16.1.100 172.16.1.255

!

ip dhcp pool user1

   network 172.16.1.0 255.255.255.0

   default-router 172.16.1.1

   dns-server 213.46.228.196 62.179.104.196

!

ip dhcp pool user2

   network 172.16.10.0 255.255.255.0

   default-router 172.16.10.1

   dns-server 213.46.228.196 62.179.104.196

!

ip dhcp pool user3

   network 172.16.20.0 255.255.255.0

   default-router 172.16.20.1

   dns-server 213.46.228.196 62.179.104.196

!

ip dhcp pool user4

   network 172.16.30.0 255.255.255.0

   default-router 172.16.30.1

   dns-server 213.46.228.196 62.179.104.196

!

!

ip cef

no ip domain lookup

ip domain name x

no ipv6 cef

!

multilink bundle-name authenticated

!

!

!

username x privilege 15 password 7 x

!

!

!

archive

log config

  hidekeys

!

!

ip ssh version 2

!

!

!

interface FastEthernet0

description LINK TO user1

switchport mode trunk

!

interface FastEthernet1

description LINK TO user2

switchport access vlan 10

!

interface FastEthernet2

description LINK TO user3

switchport access vlan 20

!

interface FastEthernet3

description LINK TO user4

switchport access vlan 30

!

interface FastEthernet4

description WAN INTERFACE

ip address dhcp

ip nat outside

ip virtual-reassembly

duplex auto

speed auto

!

interface Vlan1

ip address 172.16.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan10

description user2

ip address 172.16.10.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan20

description user3

ip address 172.16.20.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Vlan30

description user4

ip address 172.16.30.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet4

ip http server

no ip http secure-server

!

!

ip nat inside source list NAT interface FastEthernet4 overload

!

ip access-list extended NAT

permit ip 172.16.0.0 0.0.255.255 any log ACCESS-GRANTED

deny   ip any any log ACCESS-DENIED

!

!

!

!

!

!

control-plane

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

no modem enable

line aux 0

line vty 0 4

exec-timeout 0 0

privilege level 15

logging synchronous

!

scheduler max-task-time 5000

end

SWITCH CONFIG (WS-C2960-8TC-L):

Building configuration...

Current configuration : 1536 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname x

!

!

username x privilege 15 password 7 x

aaa new-model

aaa authentication login default local

!

aaa session-id common

system mtu routing 1500

ip subnet-zero

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

description LINK TO PC1

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

interface FastEthernet0/2

description LINK TO ACCESS POINT

switchport trunk native vlan 10

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet0/3

description LINK TO LAB

!

interface FastEthernet0/4

description LINK TO PC2

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

interface FastEthernet0/5

description LINK TO LAPTOP

switchport mode access

switchport nonegotiate

spanning-tree portfast

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface GigabitEthernet0/1

description LINK TO ROUTER

switchport mode trunk

switchport nonegotiate

!

interface Vlan1

ip address 172.16.1.2 255.255.255.0

no ip route-cache

!

ip http server

radius-server source-ports 1645-1646

!

control-plane

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 5 15

!

end

ACCESS POINT CONFIG (AIR-AP1231G-E-K9):

Building configuration...

Current configuration : 2267 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname x

!

!

ip subnet-zero

!

!

aaa new-model

!

!

aaa authentication login default local

aaa session-id common

dot11 vlan-name GUEST_NETWORK vlan 10

dot11 vlan-name WORTEL vlan 1

!

dot11 ssid GUEST_NETWORK

   vlan 10

   authentication open

   authentication key-management wpa

   mbssid guest-mode

   wpa-psk ascii 7 x

!

dot11 ssid WORTEL

   vlan 1

   authentication open

   authentication key-management wpa

   mbssid guest-mode

   wpa-psk ascii 7 x

!

!

!

username x privilege 15 password 7 x

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption mode ciphers aes-ccm

!

encryption vlan 10 mode ciphers aes-ccm

!

encryption vlan 1 mode ciphers aes-ccm

!

ssid GUEST_NETWORK

!

ssid WORTEL

!

mbssid

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1

no ip route-cache

!

interface Dot11Radio0.10

encapsulation dot1Q 10 native

no ip route-cache

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

bridge-group 10 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

speed auto

full-duplex

hold-queue 160 in

!

interface FastEthernet0.1

encapsulation dot1Q 1

no ip route-cache

!

interface FastEthernet0.10

encapsulation dot1Q 10 native

no ip route-cache

bridge-group 10

no bridge-group 10 source-learning

bridge-group 10 spanning-disabled

!

interface BVI1

mtu 1514

ip address 172.16.1.3 255.255.255.0

no ip route-cache

!

ip default-gateway 172.16.1.1

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

!

!

control-plane

!

bridge 1 route ip

!

!

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

exec-timeout 0 0

privilege level 15

logging synchronous

!

end

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Community Legend

AP 1231 vlan problem multiple ssid

Try this:

interface Dot11Radio0.1

bridge-group 1

3 REPLIES 3
Highlighted
Hall of Fame Community Legend

AP 1231 vlan problem multiple ssid

Try this:

interface Dot11Radio0.1

bridge-group 1

Beginner

AP 1231 vlan problem multiple ssid

Thanks this did the job.

I think I'd lost the overview..

Hall of Fame Community Legend

AP 1231 vlan problem multiple ssid

Thanks for the ratings. 

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards