cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

517
Views
5
Helpful
7
Replies

Can't access to Autonomous AP

Hi everyone,

I am trying to connect to a Cisco AP AIR-SAP2602E-E-K9 but there's nothing that I've tried that works. The only access I have is through the CLI: pinging 192.168.0.1 always fails, and connecting via HTTP fails too.

 

This is the running configuration:

 

ap#show running-config
Building configuration...

Current configuration : 1573 bytes
!
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
!
logging rate-limit console 9
enable secret 5 $1$KmpT$Xjpkb1719F4Sh6c45lDm/.
!
no aaa new-model
no ip source-route
no ip cef
!
!
!
!
dot11 syslog
!
!
no ipv6 cef
!
!
username Cisco password 7 00271A150754
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
shutdown
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
shutdown
antenna gain 0
peakdetect
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
mac-address 885a.9270.3205
ip address 192.168.0.1 255.255.255.0
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
mac-address 885a.9270.3205
ip address dhcp client-id GigabitEthernet0
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
transport input all
!
end

 

Can anyone help me with this? Thank you very much!

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Mentor

Re: Can't access to Autonomous AP

try these:

 

1. Run this command "ip http secure-server"

2. Conifugre IP on BVI interface:(example)

Int BVI1
Ip address 192.168.0.25 255.255.255.0
!
Ip default-gateway 192.168.0.1

 

Regards

Dont forget to rate helpful posts

View solution in original post

7 REPLIES 7
VIP Collaborator

Re: Can't access to Autonomous AP

 

 - Try removing no ip http secure-server , check if this helps either for http or https.

 M.

Beginner

Re: Can't access to Autonomous AP

You've configured static IP on Gig0 and DHCP IP on BVI1. I can only guess (never tried that before) that the DHCP IP is probably replacing the static IP so it will never use 192.168.0.1.
Normally you'll have "no ip address" on Gig0 and the static IP on the BVI - try that?
RR

Re: Can't access to Autonomous AP

Hi marce1000, rrudling,

 

I have tried both your suggestions, unfortunately without success. The AP was still unaccessible via browser and pinging it yielded no reply.

 

However, then I saw te reply from Sandeep. I reset the AP to default via CLI, and applied once again the ip http secure-server command. Once done, I was able to connect to the AP via browser. I am not exactly sure what happened, but now it is working.

 

Thanks everyone!

Beginner

Re: Can't access to Autonomous AP

Well Sandeep's suggestion included ip default-gateway.
If you were trying to access from somewhere not on the local subnet (192.168.0.x) that would make a world of difference (you didn't mention that but obviously you need routing if you are not local to the device)!
So if you compare the config you have now to the config you posted originally what are the difference(s) (we already know default gateway will be one)?

Re: Can't access to Autonomous AP

Hi,

This is the final configuration I ended up with. Sandeep's comment did include the ip default-gateway command which I used, however since it didn't make sense in my network topology (the AP is directly connected and wired to my laptop, without any other device on the network itself) I then issued a no ip default-gateway command. As you can see, there is no indication of gateway in the configuration.

 


ap#show running-config
Building configuration...

Current configuration : 3133 bytes
!
version 15.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
!
logging rate-limit console 9
enable secret 5 $1$KmpT$Xjpkb1719F4Sh6c45lDm/.
!
no aaa new-model
no ip source-route
no ip cef
!
!
!
!
dot11 syslog
!
!
no ipv6 cef
!
crypto pki trustpoint TP-self-signed-2456826373
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2456826373
revocation-check none
rsakeypair TP-self-signed-2456826373
!
!
crypto pki certificate chain TP-self-signed-2456826373
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32343536 38323633 3733301E 170D3133 31313036 30353432
34355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34353638
32363337 3330819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100CF64 97707B45 DDE85279 4B133B2A BD985BFD BC6A8255 52D58525 CCD6E456
9975FDE3 C15B184B 35A71DC0 87AD185D B291F29E F861BC2C 92917B89 F55B2E85
0B47159F 1D3F6EA0 F331A991 F16D59EF 86F102B9 4490F151 5134A46F AA020EF1
756B2D40 C672E7FF 8F16EF7C 4D0117D7 DD377A78 5C53DAEC 11D2E7BB F161840E
1C3B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14E23325 5EE35301 4327547B 3E5ACE38 7078DFBF ED301D06
03551D0E 04160414 E233255E E3530143 27547B3E 5ACE3870 78DFBFED 300D0609
2A864886 F70D0101 05050003 818100B3 901EB1A6 5CA42A0E C31CFDB8 35C3CA92
650F826F 20096E72 ACAE9DA2 00390CE4 3F9682AD 7F406726 B15EB29F 5E4386A5
8E813146 01D3B142 8FE22DDA 8D88F72C AC269395 5B2D7F8C 68F4D8FF E0250FB3
2B50E897 70923151 6E7F763E BD8B6F46 FA4C6994 3D06D8E3 89E93CC4 A6602812
7EF73859 10EAECBC 44B9224C 31A357
quit
username Cisco password 7 00271A150754
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
shutdown
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
shutdown
antenna gain 0
peakdetect
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
mac-address 885a.9270.3205
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
mac-address 885a.9270.3205
ip address 192.168.0.1 255.255.255.0
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
transport input all
!
end

 

I am still unsure on why it didn't work at first, since this situation is the one you suggested first (no ip on gig0, static ip on bvi1), though now everything works correctly (I can access the AP via browser both in http and https modes).

Highlighted
Beginner

Re: Can't access to Autonomous AP

So the interface IP configuration was almost certainly the original problem, and it likely needed a reboot to get the new config properly applied. It shouldn't have needed a reboot, but that sometimes happens with IOS when it gets itself in a state :)
VIP Mentor

Re: Can't access to Autonomous AP

try these:

 

1. Run this command "ip http secure-server"

2. Conifugre IP on BVI interface:(example)

Int BVI1
Ip address 192.168.0.25 255.255.255.0
!
Ip default-gateway 192.168.0.1

 

Regards

Dont forget to rate helpful posts

View solution in original post

CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards