cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3569
Views
0
Helpful
10
Replies
Highlighted
Beginner

Can't receive IP from DHCP when use Workgroup Bridge connect via WLC

Hi all, Hoping you can help and share idea with this. Now I'm configuring Workgroup Bridge on AP type autonomous connect to lightweight AP. On Wireless Lan Controller, I configured like this link http://www.cisco.com/en/US/products/ps6366/products_configuration_example09186a0080905cea.shtml#hw and I configured autonomus AP for workgroup bridge see below :

ap#sh run

Building configuration...

Current configuration : 1490 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$3psF$9d9aCiTuvhQ.Ke26nTrol1

!

no aaa new-model

!

!

dot11 syslog

dot11 vlan-name VLAN620 vlan 620

!

dot11 ssid test

   vlan 620

   authentication open

!

!        

!

username Cisco password 7 0802455D0A16

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 620 key 1 size 128bit 7 D04856427E9C105764B8D4382450 transmit-key

encryption vlan 620 mode wep mandatory

!

ssid test

!

antenna gain 5

power local 2

power client 2

station-role workgroup-bridge

infrastructure-client

bridge-group 1

!

interface Dot11Radio0.620

encapsulation dot1Q 620

no ip route-cache

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

bridge-group 1

!

interface BVI1

ip address dhcp client-id Dot11Radio0

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

!

end

By WEP authentication key. I use same key with this link : http://www.cisco.com/en/US/products/ps6366/products_configuration_example09186a0080905cea.shtml#hw

My issue is i connect LAN interface from AP (WGB) to PC but I don't receive DHCP. From this configuration. How can I fix this issue.

Thank you for every idea. 

10 REPLIES 10
Highlighted
Enthusiast

Hi

Although you did not mention it, I will assume that the Workgroup bridge AP successfully connected to the Lightweight AP? If the WGB successfully connected to the Lightweight AP, it would've received a DHCP assigned IP address.

For the PC's, you would have to ensure that they do not have a static IP configured on the LAN adapter. So please verify this is the case.

Highlighted

The configuration is incorrect. Remove the references to VLAN 620 under the SSID and the encryption statement.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

so just erase it and add this...

wr erase

reload

######################

conf t

dot11 ssid test

authentication open

interface D0

encryption key 1 size 128bit 7 D04856427E9C105764B8D4382450 transmit-key

encryption mode wep mandatory

ssid test

station-role workgroup-bridge

infrastructure-client

no shut

Highlighted

That would be the fastest way.

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Hi all and Thank you all for every suggestion but it not work. Now I can't receive ip from dhcp.

From configuration of rdvorak , it still not work for me.

Explain about WLC. I have many SSID for each department so each SSID have interface vlan bond with SSID for receive DHCP from external server. From configuration of rdvorak and suggestion of Steve when I remove vlan under SSID test and the encryption statement. AP can't form WGB until I fill vlan under dot11 ssid test.

Have you any idea for fix this...

Nontawat

Highlighted

Dear all, Sorry for you suggestion and configuration that you provide. Configuration of rdvorak that is work. I'm so sorry again.

Although configuration is work but I still can't receive IP from DHCP. It just AP can form WGB state with WLC. I think it may be command on WLC causes for this case. If you have any advice please share to us.

Sorry again, Thank you

Nontawat

Highlighted

There is one more thing you can try:

config network mac-ip-binding disable.

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Highlighted

Hi

Can you confirm that you erased the config and typed in the new config as suggested above? Can you also confirm that the WGB was able to associate with the Lightweight AP and receive an IP? This is the first step. You can type show dot11 associations on the WGB CLI to confirm this.

Alternatively you can go to the WLC GUI and under the Monitor tab, click on clients. You will see WGB status = Yes.

Click on the Client and confirm that it has the right IP address that you expect to see.

If the above is as it should be, then the wired devices will definitely pick up an IP address if no static IP is configured.

You should understand that the WGB and the wired devices are just clients to the LWAPP. The difference being that the WGB is a wireless client while the wired PCs are connected via ethernet. So if the WGB received an IP, then there is no stopping the Wired clients getting an IP, unless you DHCP scope is filled up. Hence, I would suggest that you check your DHCP scope.

Lastly, if you used a switch to connect the WGB and the Wired PCs, the ports should have no VLAN configuration. Just the basic switchport host command is enough on the ports.

Highlighted

Hi all

Now this my configuration. it work now :

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

enable secret 5 $1$3psF$9d9aCiTuvhQ.Ke26nTrol1

!

no aaa new-model

!

!

dot11 syslog

!

dot11 ssid test

   authentication open

   guest-mode

!

!

!        

username Cisco password 7 0802455D0A16

!

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

!

ssid test

!

antenna gain 5

power local 2

power client 2

station-role workgroup-bridge

bridge-group 1

bridge-group 1 spanning-disabled

!        

!

interface Dot11Radio1

no ip address

no ip route-cache

shutdown

antenna gain 0

no dfs band block

channel dfs

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

no keepalive

bridge-group 1

bridge-group 1 spanning-disabled

!

!

interface BVI1

ip address dhcp

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!        

line con 0

line vty 0 4

login local

!

I'm remove WEP authentication out because although AP can connect to WLC but when I show client at WLC (WLC ->Monitor->Client) I see that AP can't receive IP address. I think it may be cause from WEP authen that show log on AP when associated with WLC below :

*Mar  1 22:05:26.258: %DOT11-4-UPLINK_DOWN: Interface Dot11Radio0, parent lost: Received deauthenticate (1) failure

*Mar  1 22:05:26.541: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP SI_SiPH_AP_1_14 64ae.0c56.eb53 [None]

*Mar  1 22:07:46.452: %DOT11-4-UPLINK_DOWN: Interface Dot11Radio0, parent lost: Received deauthenticate (1) failure

*Mar  1 22:07:46.728: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP SI_SiPH_AP_2_1 64ae.0c57.a1e4 [None]

*Mar  1 22:07:48.719: %DOT11-4-ENCRYPT_MISMATCH: Possible encryption key mismatch between interface Dot11Radio0 and station 64ae.0c5

I will try to test about static WEP authentication again.

Osita Njokubi, Many thank for your advice. it make me back to check configuration both AP and WLC again and again on weekend.

Thank You So Much Everyone,

Nontawat

Highlighted

Hi

Just remember that if wireless clients can obtain an IP through the AP, then there is no reason why the WGB would not get an IP address, as long as the WEP key matches and Layer 2 authentication passes.

Content for Community-Ad