cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1864
Views
0
Helpful
9
Replies
Highlighted
Beginner

H-REAP LWAPs losing VLAN mapping when fail to secondary WLC's

Hello,

I have three 5508 WLCs, running code 7.0.98.0 supporting 100+ LWAPs in H-REAP mode. The LWAPs are servicing 2-3 WLANs each. Some are using central authentication and local switching, some are configured for central authentication and central switching. When the LWAPs fail from one WLC to another WLC, the LWAP's lose all of their VLAN mappings and pick up the VLAN of the management interface on the new WLC.

All WLANs are configured to use the management interface on the WLC and the VLAN mappings are configured per LWAP on the H-REAP properties  tab.  The WLAN ID numbers and all the WLAN settings are the same across all 3 WLC's. I have created AP groups on all 3 WLC's and the AP group config matches across the 3 WLCs.

I can get the LWAPs to keep their VLAN mapping by creating an interface on the WLC with the VLAN ID of the locally switched/remote site VLAN and then setting the interface for the WLAN to the new interface. However, then the WLAN doesn't work, because the centrally located WLC doesn't have the remote site VLAN. It also seems to keep the VLAN mapping if I create the locally switched/remote site VLAN interface on the WLC , and point the WLAN to the management interface. This shouldn't be a necessary step though... In H-REAP with local switching, the LWAPs aren't using the interface on the WLC.

I found a note in the 7.0 WLC config guide that explains why the VLANs are picking up the management interface VLAN, but that same note says the VLAN mappings can be changed per LWAP/WLAN!

From config guide:

For hybrid-REAP access points, the interface mapping at the controller for WLANs that is configured for H-REAP Local Switching is inherited at the access point as the default VLAN tagging. This mapping can be easily changed per SSID, per hybrid-REAP access point

Anyone using H-REAP and been able to get the LWAPs to keep the VLAN mapping when failing from one WLC to another?

Thanks!

9 REPLIES 9
Highlighted
Enthusiast

hmmm I think I have heard that behavior before...

Why dont you try with WCS maybe? using templates... perhaps..

Highlighted

We are using WCS. I don't think templates would help this issue, but thanks anyway.

Spoke with TAC and they said there is a bug in the code I am running. Going to upgrade my 3 WLC's this weekend to see if that fixes it.

Highlighted

dont forget to post here the bug id too...

Highlighted

Might be this bug: CSCtc87690

Doesn't exactly describe the issue I am seeing, but I'll see what happens after the upgrade.

Highlighted

Hi,

I have the same problem with my controller in 6.0.196.0

The upgrade had it solved your problem?

Thanks!

Highlighted
Beginner

Yes, the upgrade did fix the issue. I am running software version 7.0.116.0 and it has been very stable. No issues with it.

Highlighted

My setup is very similar to this. I'm running ver 7.0.230.0 code. I have the same problem. I loose the office vlan's on a failover from the primary to backup controller and gain in the other direction.

Highlighted

I'm still at version 7.0.116.0, and it is still working for me. I seem to remember having this issue if the config between the WLC's wasn't exactly the same. Same WLAN ID for WLANs, same WLANs in AP groups, etc. If that is all the same... please let me know what the fix is. I was thinking about updating the code on my WLCs soon, but I don't want to reintroduce this bug.

Thanks.

Highlighted

Shawn,

I went back and reviewed everything and everything was duplicated , Except... WLAN_ID. The Wlan ID tags were different. I created a test and failled my two test AP's and they both came up on the backup controller with the proper vlan ID. now I know. When it was working for everyone else I was begining to wonder if I found a new bug or it was my config. This is one I wont forget ..

Thank you

Content for Community-Ad