cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2166
Views
5
Helpful
5
Replies

How to limit Wireless Users Bandwidth using Nexus 7000 and WLC

michaeldodd98
Level 1
Level 1

Hi guys,

I used the following commands to limit users on my wireless network (WLC 5500) and a Nexus 7000.  The previous cisco doc only covers the 6500 and some commands have changed.  Tested and working except the PIR gives an error, post up if you know why, otherwise enjoy!

Note Wireless Network assumed to be 172.21.0.0/16.

Note This will limit each wireless user to 1 Mbps
Note The PIR (Peak Infomation rate, also know as burst) is ignored in following commands, unknown at this time why.

Create ACLs:


ip access-list acl-wireless-downstream
  10 permit ip any 172.21.0.0/16
ip access-list acl-wireless-upstream
  10 permit ip 172.21.0.0/16 any
class-map type qos match-all class-wireless-upstream
  match access-group name acl-wireless-upstream
class-map type qos match-all class-wireless-downstream
  match access-group name acl-wireless-downstream
policy-map type qos police-wireless-upstream
  class class-wireless-upstream
    police cir 1 mbps bc 200 ms pir 1536 kbps be 200 ms conform transmit exceed drop violate drop
policy-map type qos police-wireless-downstream
  class class-wireless-downstream
    police cir 1 mbps bc 200 ms pir 1536 kbps be 200 ms conform transmit exceed drop violate drop

1.Apply police-wireless-upstream on the incoming port from the controller.

interface port-channel130
  description *** LAG for WLC1 ***
  switchport mode trunk
  switchport trunk allowed vlan 80,130,255,600
  service-policy type qos input police-wireless-upstream

2.Apply policy-wireless-downstream on the uplink LAN/WAN ports.

interface port-channel101
  description *** L3 Port Channel to Core VDC ***
  no switchport
  service-policy type qos input police-wireless-downstream
  ip address 10.70.10.18/30
  ip router eigrp 10

5 Replies 5

Leo Laohoo
Hall of Fame
Hall of Fame
Note This will limit each wireless user to 1 Mbps

This 1 Mbps per user, PER SSID?

I mean, let's say you have 3 SSIDs and you want all users of SSID 1 to have 1 Mbps?

If this is so, then you can configure QoS on the WLC-side.

this would cause everyone on the 172.21.0.0/16 network to be limited to 1 Mbps, I setup one SSID per IP network.

If you could post up how to achieve the same using just the WLC I would apprecaite it.

Wireless > QoS > Profiles > click on a profile to edit and change the rates as required of the "Average Data Rate".

Go to WLAN > choose the SSID to edit > QoS tab > and choose the QoS you desire to use.

Saravanan Lakshmanan
Cisco Employee
Cisco Employee

i've a ref from 6500 for WLC guest rate limiting not sure it is useful here.

http://www.cisco.com/en/US/products/ps10315/products_tech_note09186a0080baf502.shtml

liveshell
Level 1
Level 1

I want to limit bandwidth for particular IP. I can do this using proper configuratio of IP ACL. But what if I dont have information on interface?  Can I apply bandwidth control for particular IP without knowing the interface?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: