cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3638
Views
0
Helpful
18
Replies
Highlighted
Beginner

How-To Troubleshoot Audio Problems on 7925g

I've read numerous best practices posts, guides, etc. but am still struggling with resolving wireless audio issues at one of my smaller sites.

Some background:

- The site has (5) AP's - all 1142N's and a fast 10

- I've tried the newest firmware for the 7925g's (1.4.3SR1.2) as well as our current approved "standard" firmware - 1.4.2 but the users claim there is no noticeable improvement.

- The site runs off the same controller as other remote sites I manage - and none of them are complaining of any issues.

- I'm forcing the phones to run 5ghz and have disabled data rates 6 & 9mbps.

- I'm not able to reproduce the issue after several test calls to both internal and external phones, but the users insist the problem occurs with "about half" the phone calls" and even if they are standing still.

I have run the site survey tool on the 7925g and the only warnings it provides is that my beacon value is not 100 and that I don't have Spectrum management enabled/supported by the AP's.  I'm seeing adequate AP coverage (signal levels greater than -67 from at least one AP at a given time).  I'm not certain why the report is telling me my beacon value is 102 - I've double-checked in NCS and the controller and it is set @ 100 as recommended...

From what I've read - one way audio is usually due to power level mismatches between the devices and the AP's - however unless I'm missing something I believe I have DTPC enabled...

I do know the code I'm running on my controller(s) is outdated and am in the process of scheduling that - however as I said before this is the only site that is complaining of issues with the 7925g's and I have over 300 of them deployed at various locations.  Any insight as to what I'm missing would be much appreciated.

I may just open a TAC case but wanted to post here first!  Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Understood, which is why I am giving you the heads up so you can go ahead and get the process going asap. 

CSCtz19309 is the defect I was referring to, but there are some other significant fixes in 7.0.235.0 as well.

http://www.cisco.com/en/US/docs/wireless/controller/release/notes/crn7_0_235_0.html#wp786573

CSCtz19309

PMK cache entry for a CCKM client after a valid fast roam is set to zero.

CSCtx03676

Radio core dump. Transmission stops. Off-channel deauthentication frames are stuck.

CSCtc12426

Wireless packets wedge radio interface input queue.

CSCto02968

Memory leak issue.

View solution in original post

18 REPLIES 18
Highlighted
Hall of Fame Master

I'm guessing you have read this:

https://supportforums.cisco.com/docs/DOC-26863

How is your wireless setup? H-REAP, 802.1x?

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***
Highlighted

Figured you would be the first to respond Scott - man you're fast!

1. Have solid coverage in 5GHz - and lock your phones to 802.11a

Yes the phones are locked for 802.11a only.

2. Every spot in the coverage area is serviced by at least two viable 5GHz access points, at -67dBm or stronger.

You can easily validate the necessary coverage by setting your phone into site survey mode, and walking throughout your coverage area.  Additionally, AP placement, antenna selection, building construction, etc. must be such that multipath distortion is kept to a minumum.  To ensure gap-free roaming, a moving phone must be able to hear each roamed-to AP at least 5 seconds before it needs to roam to it - so place all APs in the middle of halls, at corridor junctions, etc., rather than in blind spots.

While I'm certain not every area of the facility constantly has two AP's available at -67dBm or stronger at all times - I can say the coverage is the same as my other facilities and should be adequate - especially considering they claim the issue occurs when they are standing still and mere feet from a given access point.  Doing a site survey with a couple of the phones it appeared I was always connected to at least one AP with a -67dBm signal or better.

2. Run 1.4.3 or above - nothing earlier

I did upgrade one of the two most "troubled" phones in question to 1.4.3SR1.2 but am being told this did not make a noticeable difference.

3. Access points in local mode, not Flexconnect (H-REAP) local switching

Forgot to mention that - all AP's are in local mode.

4. Use WPA2/AES EAP/CCKM or static WEP - never PSK

Unfortunately the corporate standard is AKM-PSK.

5. Optimize channels, power, and data rates

I have not optimized channels, nor power levels at this time.  I have power levels set to auto at this time and set the minimum power level for -11dBm per our standards.  I have disabled the lower data rates on 802.11a as I mentioned.  You recommend setting each of the (5) AP's in this facility to it's own channel?  I've read several conflicting points on how to setup channels - could you point me a doc you recommend?

6. Enable continuous scan mode (in CUCM)

I thought Continuous scan mode was enabled on all wireless phones in CUCM as that is our standard - but upon closer inspection it was set to "Auto" on phones @ this facility only (go figure).  I have corrected this - thank you.

7. Configure all QoS, and everything else, exactly as documented in the 7925 DG

I admittedly have not gone through line by line by from a high level most of the settings on the WLC's do follow the guidelines listed in that document.  My next step is essentially to go through line by line and double-check all settings.

Highlighted

Okay... well depending on the code you are running on the wlc, psk will have issues no mater what.  What I would do is test... you can create and use local eap on the WLC and create a new ssid for testing using 802.1x +cckm.  Also at least set the 802.1p tag on the voice QoS profile.  Depending on how much traffic there is on your network, it can be an issue.  

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
Highlighted

5. Optimize channels, power, and data rates

I have not optimized channels, nor power levels at this time. I have power levels set to auto at this time and set the minimum power level for -11dBm per our standards. I have disabled the lower data rates on 802.11a as I mentioned. You recommend setting each of the (5) AP's in this facility to it's own channel? I've read several conflicting points on how to setup channels - could you point me a doc you recommend?

You are running RRM?

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
Highlighted

The WLAN these phones utilize is already configured for "Platinum" QoS - I assume that is what you mean?  WMM Policy is also allowed as well as 7920 AP CAC.

If the PSK were an issue I would think others would be complaining at other sites - but I am more than happy creating a test SSID as well to see if that improves the situation - thank you for the suggestion.

The circuit from the location where the AP's are to the WLC is 1gbps.

Current code on the WLC's is 7.0.116.0 and the controllers are 5508's.

Highlighted

Have you set this up:

Thanks,

Scott

Help out other by using the rating system and marking answered questions as "Answered"

-Scott
*** Please rate helpful posts ***
Highlighted

7.0.116.0 had some pretty major issues including no way audio issues, etc. and should be considered a deferred release.

You should be running 7.0.220.0 or 7.0.235.3 if wanting to remain on 7.0.

I know that may be easier said than done though.

Highlighted

I'm being told 7.0.230.0 is what has been approved for our facility.  I will schedule the upgrading of my controllers to this version as soon as possible.

Highlighted

Excellent!  It will only be better.  Hope the upgrade resolves all of your issues.

Highlighted

Well before you jump the gun and start to change authentication methods, would first find out if issues are occuring during roam time or not.

You stated that 1140s are used, which you need 1.4(3) or later if using UNII-1 channels due to the fix for CSCtz75601.

But you didn't state what WLC version you are using; which is a critical piece of information.

Recommend 7.0.235.3, 7.2.110.0 or 7.3.101.0.

For PSK, we have had some customers that have had intermittent issues with that method where they had audio gaps from 1-5 seconds, but when ready to debug the issue, they were either unable to reproduce the issue or they were not willing to troubleshoot further as they were satisfied with EAP-FAST + CCKM.

We are also unable to reproduce these "PSK issues" in our labs as well.

If willing to troubleshoot this PSK issue assuming this is PSK related, please open a TAC case and we can provide a debug image, which you can then collect some logs where we can look into this further.

For the beacon period, the Cisco 11n APs will be increments of 102 ms.

Aaron's checklist is based on our experiences and my 7925G Deployment Guide and outlines some of the key items to follow / implement.

Continuous scanning is always utilized when on call.  Setting the scan mode to continuous in CUCM also enables continuous scanning when in idle mode regardless of the current RSSI.  With auto scan mode, the 7925 will start to scan when the current RSSI reaches -75 dBm.

7925G Deployment Guide has all the detailed info.

http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7925g/7_0/english/deployment/guide/7925dply.pdf

Thanks.

Highlighted

Scott - see attached your screen looks different than the one on my WLC but the 802.1p tag is set for wired QoS and in thw WLAN itself that the phones use I have Platinum set (see attached screenshots) hope that helps clear it up.

migilles - thanks for the response.  As I mentioned the users are claiming the issue occurs even if they are standing still - so I'm not certain it is a roaming issue at all to be honest.  I've stood still, and walked quickly around the entire facility for 5 minutes on a call (both internal and external destinations) and am not able to recreate the issue.

One of the users just sent me this message:

"Not sure if you need this info regarding the wireless phone, but just had a situation where I called xxx-xxx-xxxx (external number). I could hear it ringing fine, then when someone picked up, I heard nothing. Just thought I'd let you know of a specific example, if it helps..."

I didn't initially report what firwmare my WLC's were running but did in a subsequent post - current code on the WLC's is 7.0.116.0 and the controllers are 5508's.

[edit]

Helps if I remember to actually attach the files...

Highlighted

Hi John,

I have the same audio problems as you.

I have opened an case support on TAC, by the moment the enginner ask me next:

dissable low rates on 802.11a and 802.11b/g

enable CAC.

Enable QoS on Platinium Profile CoS 802.1p tag 6.

But the problem persist.

If we changed the 1142N APs for the 1242AP, the audio works fine.

So, i think that the problem could be on 1142N AP.

My scenario:

2x 5508 WLC running the 7.0.235.0 firmware version.

7925 and 7921 Phones with 1.4.2 firmware.

Have you already solved your problem?

Thanks for your help.

Regards.

Highlighted

Ruben,

You should upgrade your phones to the latest firmware 1.4.3(SR1), this has bug fixes integrated that can cause issues with the 1142 series AP.

I would also recommend using only UNII-1 and UNII-3 channels, enabling the 6 and 9 Mb rates but leave them as supported, setting 12Mb as the only mandatory rate. Configure all the 792x phones for 802.11a only, do not use auto-a unless absolutely necessary. And as stated earlier in the thread, setting the phone to continous scan in CUCM.

Highlighted

Update:

I've upgraded the WLC to 7.0.230.0

I've ensured all phones at this location have continuous scanning enabled.

CAC is enabled.

Phones are running 1.4.3SR1.2 code.

6mbps has been set as mandatory, 9mbps disabled, and 12 & 24mbps set to supported.  All phones have been locked to 802.11a.

Each of the 5 AP's at this location have global power setting enabled (which changed all their power levels to "1").

Global channel management is enabled which has assigned each AP its own channel: 161, 153, 64, 157, and 36).

Will check with user after tomorrow to see if there is any improvement.