cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1554
Views
0
Helpful
3
Replies
Highlighted
Beginner

Issue in configuring MSE High Availability - (Failed to retrieve status from MSE error thrown)

Hi Team, 

I am trying to configure MSE HA from Prime infrastructure as per the configuration guide . I added the primary server in Prime infra and clicked on 'Click here' in the Secondary MSE column.

Issue:

As soon as i do this, i am getting the error pop up 

"Failed to retrieve status from MSE server. Make sure the server is up and running" But the server is running fine .

Please find the attachment <-----------------------

MSE Type : Virtual Machine

Version : 8.0.130.0 downloaded from CCO

Primary MSE License : Evaluation 

I have an Activation license ready for secondary MSE with me . But this error is blocking me to enter the details of secondary MSE for pairing.

The Primary is configured with Virtual IP as well. Please find the 'getserverinfo' and 'gethainfo' output from the primary MSE.:

[root@mseprimary ~]# getserverinfo

Health Monitor is running

Retrieving MSE Services status.

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - CiscoJ configured for FIPS mode

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - CiscoJCE turning on FIPS...

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - CiscoJCEProvider version 2.0520150519 loading...

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - Executing Java version = 1.7.0_45

 

MSE services are up, getting the status

 

 

-------------

Server Config

-------------

 

Product name: Cisco Mobility Service Engine

Version: 8.0.130.0

Health Monitor Ip Address: 172.20.x.x

High Availability Role: 1

Hw Version: V01

Hw Product Identifier: AIR-MSE-VA-K9

Hw Serial Number: mseprimary_d

HTTPS: null

Legacy Port: 8001

Log Modules: -1

Log Level: INFO

Days to keep events: 2

Session timeout in mins: 30

DB backup in days: 2

 

-------------

Services

-------------

 

Service Name: Context Aware Service

Service Version: 8.0.1.108

Admin Status: Enabled

Operation Status: Up

 

Service Name: WIPS

Service Version: 3.0.8191.0

Admin Status: Disabled

Operation Status: Down

 

Service Name: Mobile Concierge Service

Service Version: 5.0.1.23

Admin Status: Disabled

Operation Status: Down

 

Service Name: CMX Analytics

Service Version: 3.0.1.73

Admin Status: Disabled

Operation Status: Down

 

Service Name: CMX Connect & Engage

Service Version: 1.0.0.32

Admin Status: Disabled

Operation Status: Down

 

Service Name: HTTP Proxy Service

Service Version: 1.0.0.1

Admin Status: Disabled

Operation Status: Down

 

--------------

Server Monitor

--------------

 

 

Server start time: Sat Apr 23 00:57:50 PDT 2016

Server current time: Sat Apr 23 10:25:16 PDT 2016

Server timezone: US/Pacific

Server timezone offset (mins): -480

Restarts: 4

Used Memory (MB): 178

Allocated Memory (MB): 2970

Max Memory (MB): 4454

DB disk size (MB): 5245

 

---------------

Active Sessions

---------------

 

Session ID: 2595

Session User ID: 1

Session IP Address: 172.20.x.x

Session start time: Sat Apr 23 01:01:20 PDT 2016

Session last access time: Sat Apr 23 10:23:06 PDT 2016

 

----------------------------

Default Trap Destinations

----------------------------

 

Trap Destination - 1

-----------------

IP Address: 172.20.x.x

Last Updated: Sat Apr 23 04:01:55 PDT 2016

 

 

-------------

Context Aware Service

-------------

 

Total Active Elements(Wireless Clients, Tags, Rogue APs, Rogue Clients, Interferers, Wired Clients): 0

Active Wireless Clients: 0

Active Tags: 0

Active Rogue APs: 0

Active Rogue Clients: 0

Active Interferers: 0

Active Wired Clients: 0

Active Elements(Wireless Clients, Rogue APs, Rogue Clients, Interferers, Wired Clients, Tags) Limit: 100

Active Sessions: 1

Wireless Clients Not Tracked due to the limiting: 0

Tags Not Tracked due to the limiting: 0

Rogue APs Not Tracked due to the limiting: 0

Rogue Clients Not Tracked due to the limiting: 0

Interferers Not Tracked due to the limiting: 0

Wired Clients Not Tracked due to the limiting: 0

Locally administered clients Not Tracked due to filtering: 0

Total Elements(Wireless Clients, Rogue APs, Rogue Clients, Interferers, Wired Clients) Not Tracked due to the limiting: 0

]0;

 

 

 [root@mseprimary ~]# gethainfo

  

Health Monitor is running. Retrieving HA related information

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - CiscoJ configured for FIPS mode

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - CiscoJCE turning on FIPS...

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - CiscoJCEProvider version 2.0520150519 loading...

[main] INFO com.cisco.ciscossl.provider.ciscojce.CiscoJCEProvider - Executing Java version = 1.7.0_45

 

 

----------------------------------------------------

Base high availability configuration for this server

----------------------------------------------------

 

Server role: Primary

Health Monitor IP Address: 172.20.x.x

Virtual IP Address: 172.20.x.x

Version: 8.0.130.0

UDI: AIR-MSE-VA-K9:V01:mseprimary_d

Number of paired peers: 0

Any help or solution at the earliest would be of great help..

Regards,

Mugilan S

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

You might be hitting

You might be hitting CSCux48283:

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCux48283/?referring_site=bugquickviewredir

Try the workaround in the bug.  In my case, I had PI and the MSE on the same subnet so there was no firewall issue.  I changed the password for PI in the MSE (even though I had the correct password and I was able to add the MSE to PI).  After that change and restarting the service, I was able to get into the HA config in PI.

View solution in original post

3 REPLIES 3
Highlighted
Cisco Employee

You might be hitting

You might be hitting CSCux48283:

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCux48283/?referring_site=bugquickviewredir

Try the workaround in the bug.  In my case, I had PI and the MSE on the same subnet so there was no firewall issue.  I changed the password for PI in the MSE (even though I had the correct password and I was able to add the MSE to PI).  After that change and restarting the service, I was able to get into the HA config in PI.

View solution in original post

Highlighted
Beginner

Re: You might be hitting

so what password you change ? pi or mse ?

and how restart the service ?

Highlighted
Beginner

Re: Issue in configuring MSE High Availability - (Failed to retrieve status from MSE error thrown)

Check the health monitor address on the secondary.  If that doesn't match the IP that you are wanting to use for the health monitor, for example it's defaulted at 1.1.1.1   If this is the case, re-run setup on the secondary, and revisiting the role.  Select secondary again, and when the information is reapplied, Prime will be able to configure the two to communicate as desired.

Content for Community-Ad