cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1824
Views
0
Helpful
4
Replies
Highlighted
Beginner

Trunking Autonomous Cisco 1140 AP and ASA 5505

Hi,

I have an Autonomous Cisco 1140 AP running  12.4(21a)JA1. It has two SSIDs in vlan 1 and vlan3. The configs are below:

!
dot11 ssid A
   vlan 1
!
dot11 ssid B
   vlan 3
!

interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.3
encapsulation dot1Q 3
no ip route-cache
bridge-group 3
bridge-group 3 subscriber-loop-control
bridge-group 3 block-unknown-source
no bridge-group 3 source-learning
no bridge-group 3 unicast-flooding
bridge-group 3 spanning-disabled

interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
no keepalive
!
interface GigabitEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0.3
encapsulation dot1Q 3
no ip route-cache
!

The trunk interface on ASA is something like this:

!
interface Ethernet0/1
switchport trunk allowed vlan 1,3
switchport trunk native vlan 1
switchport mode trunk
!

interface Vlan1

nameif A

security-level 100

ip address 10.0.0.1 255.255.255.0

!

interface Vlan3

nameif B

security-level 10

ip address 192.168.1.1 255.255.255.0

!

dhcpd address 10.0.0.10-10.0.0.128 A
dhcpd enable A
!
dhcpd address 192.168.1.5-192.168.1.200 B
dhcpd enable B
!

As of now the vlan 1 is performing as desired but hosts on SSID B are getting nothing. Please help.

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Re: Trunking Autonomous Cisco 1140 AP and ASA 5505

interface GigabitEthernet0.3
encapsulation dot1Q 3
no ip route-cache


==> You forgot bridge-group 3 here

Hope this helps

View solution in original post

4 REPLIES 4
Highlighted
Cisco Employee

Re: Trunking Autonomous Cisco 1140 AP and ASA 5505

interface GigabitEthernet0.3
encapsulation dot1Q 3
no ip route-cache


==> You forgot bridge-group 3 here

Hope this helps

View solution in original post

Highlighted
Beginner

Re: Trunking Autonomous Cisco 1140 AP and ASA 5505

Thank you so much, Nicolas. I put that in the AP, now I have to wait for some users to try it.. I will know only monday morning.

Highlighted
Beginner

Re: Trunking Autonomous Cisco 1140 AP and ASA 5505

Hi Nicholas,

Just checked the status of the network. The Vlan  works perfectly fine. Thanks for the help. The devices on network B get  192.168.1.x addresses.

As a different issue, the devices cant access internet. Can you help me with this?

global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
nat (B) 1 192.168.1.0 255.255.255.0

There is no access list blocking or permitting at interface B

Highlighted
Beginner

Re: Trunking Autonomous Cisco 1140 AP and ASA 5505

I fixed it. It was the DNS. The DHCP server configured for the vlan B did not give out DNS addresses. Thanks

CreatePlease to create content
Content for Community-Ad

Cisco COVID-19 Survey