cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

749
Views
20
Helpful
8
Replies
Highlighted
Beginner

WLC HA Redundancy boot loop 8.5.120.0

Hello,

I recently made a change to the network that forced one of our 5508 WLCs to fail over to the secondary. The problem that caused the fail-over is no longer present, however the primary WLC went into a boot loop. It will boot, ask for credentials, and then say "exited switchdrvr" and reboot. It is running version 8.5.120.0.

 

It appears that there are a couple bugs documented that can cause this problem in this version; however, I have not been able to read workarounds as the bug that describes this exact problem (CSCvi81074) is labeled as a duplicate bug with no workaround.

 

I will need to update the firmware to the WLCs; but, I would like to get them paired again before I do that to prevent any problems. I have also been able to get the primary to stay booted by unplugging the "RP" link temporarily.

 

Has anyone ran into this problem, have any suggestions, or have the documentation for the bug CSCvi81074?

 

Thank you!

1 ACCEPTED SOLUTION

Accepted Solutions
Beginner

Re: WLC HA Redundancy boot loop 8.5.120.0

After rebooting both the primary and the secondary (with the RP connected) they re-established the pair. I then went through the standard update procedure and everything went as it should!

 

Updated to 8.5.135

 

Thank you everyone for your help!

8 REPLIES 8
VIP Mentor

Re: WLC HA Redundancy boot loop 8.5.120.0

Since it is same as  behavior of CSCvi38017, there may not be any additional info specific to CSCvi81074.

 

Once you remove RP connection, did both units able to boot individually ?

 

Go with 8.5.135.0 which got the fix for it.

 

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

Re: WLC HA Redundancy boot loop 8.5.120.0


@Rasika Nayanajith wrote:

Since it is same as  behavior of CSCvi38017, there may not be any additional info specific to CSCvi81074.

 

Once you remove RP connection, did both units able to boot individually ?

 

Go with 8.5.135.0 which got the fix for it.

 

HTH

Rasika

*** Pls rate all useful responses ***


That is correct. They both booted after RP connection was removed.

 

That is the firmware I was planning on going with.

 

Is there a way to get the RP back up prior to the firmware upgrade? If not, are there any specific steps that need to be followed to upgrade them individually and maintain the current HA configuration?

VIP Mentor

Re: WLC HA Redundancy boot loop 8.5.120.0

did you try connecting PR connection again ? if that does not trigger boot loop again, I would recommend upgrade while they are in HA pair.

 

If you do them individually, then better to break HA first & upgrade both units and make them HA afterward

https://community.cisco.com/t5/wireless-and-mobility/cisco-wlc-ap-sso-break/td-p/2466150

 

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

Re: WLC HA Redundancy boot loop 8.5.120.0


@Rasika Nayanajith wrote:

did you try connecting PR connection again ? if that does not trigger boot loop again, I would recommend upgrade while they are in HA pair.

 

If you do them individually, then better to break HA first & upgrade both units and make them HA afterward

https://community.cisco.com/t5/wireless-and-mobility/cisco-wlc-ap-sso-break/td-p/2466150

 

HTH

Rasika

*** Pls rate all useful responses ***


Last time I reconnected the RP it restarted the boot loop. I will definitely try that again before breaking the HA.

 

As for the current HA config, if I have to break the pair, all settings will remain correct? I will just need to re-enable SSO and we should be back up and going?

VIP Mentor

Re: WLC HA Redundancy boot loop 8.5.120.0

As for the current HA config, if I have to break the pair, all settings will remain correct? I will just need to re-enable SSO and we should be back up and going?

Yes, break HA should not wipe your configs.

 

HTH

Rasika

Beginner

Re: WLC HA Redundancy boot loop 8.5.120.0

Do I break this on both the primary and the secondary?

If so, will the APs connect to the primary once it is back up and he SSO is broke? I need to be sure to be able to pre-download the AP images prior to the reboot.

Hall of Fame Master

Re: WLC HA Redundancy boot loop 8.5.120.0

When you have different images and want or you are doing SSO, it’s best to keep the one controller as active. This one should be the one that is working and stable. When you break SSO, the secondary you will need OOB because the IP address will not change and you will have duplicate up address.

I don’t typically break SSO...

So when I have to do something like what you are doing, I shut down the port/port channel on the standby, I connect to the OOB console, I reboot the standby and then escape out during boot to clear the configuration. Once the controller is factory default, go through the startup wizard and do the basics settings to get the controller online with its own ip. Then you would upgrade the controller to that of the primary and configure your SSO configuration on the standby. The controller will reboot and will sync with the wireless controller that is primary.
-Scott
*** Please rate helpful posts ***
Beginner

Re: WLC HA Redundancy boot loop 8.5.120.0

After rebooting both the primary and the secondary (with the RP connected) they re-established the pair. I then went through the standard update procedure and everything went as it should!

 

Updated to 8.5.135

 

Thank you everyone for your help!

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards