cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

529
Views
5
Helpful
6
Replies
Highlighted
Beginner

WLC IOS vulnarability

Hi,

I have a Cisco WLC 5508 running on IOS version 8.0.140.0. As we are currently running security audits and want to ensure what we have installed does not come up with vulnerabilities. I do not prefer upgrading this IOS unless there is a reported/tested issue.

Do we have any reported bugs/vulnerabilities on this version?

If so, what would be the next recommended version for this WLC?

 

Everyone's tags (2)
6 REPLIES 6
VIP Mentor

Re: WLC IOS vulnarability

8.0.152.0 is the latest on 8.0.x code train. Pls check below release notes & see what vulnerabilities/bugs it addressed

https://www.cisco.com/c/en/us/td/docs/wireless/controller/release/notes/crn80mr5.html

 

If you have newer model APs, you may be able to upgrade to either 8.2.170.0 or 8.5.140.0 depend on your AP models supported in these codes. Pls check from below table & decide

https://www.cisco.com/c/en/us/td/docs/wireless/compatibility/matrix/compatibility-matrix.html#56735

 

Whatever code you go with, read release note beforehand of upgrading.

https://www.cisco.com/c/en/us/support/wireless/wireless-lan-controller-software/products-release-notes-list.html

 

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

Re: WLC IOS vulnarability

Thank you.

This is for the anchor WLC and we have 2500 model of WLCs anchoring to this 5508 WLC. These 2500 model of WLCs are running on old versions say 7.x.

SO, wanted to make sure if the  anchor WLC running on 8.0.140.0 has any bugs/issues.

Also need some suggestion on the IOS 8.0.152.0(MD). for this anchor WLC 5508 WLC

 

VIP Mentor

Re: WLC IOS vulnarability

If that is the case, I would upgrade 5508 Anchor to 8.0.152.0.

 

If you are still running 7.0.x on foreign controllers, I think those may have more vulnerabilities than your anchor WLC

 

HTH

Rasika

*** Pls rate all useful responses ***

Beginner

Re: WLC IOS vulnarability

yes. There is separate plan for foreign controllers. First we would focus on anchor WLCs.

So, I am looking for any reported issues on 8.0.140.0 on anchor wlc. If there is no vulnerability on 8.0.140.0, then I need not upgrade.

VIP Mentor

Re: WLC IOS vulnarability

You can read 8.0.140.0 release notes & it should list under "open caveats" any known issues at the time of releasing 8.0.140.0

 

Also check in 8.0.152.0 release notes for "resolved caveats" to see how many of those addressed in that code.

 

Recommended code in 8.0.x is 8.0.152.0 which is last code of that path.

 

HTH

Rasika 

Beginner

Re: WLC IOS vulnarability

And refer to https://www.cisco.com/c/en/us/support/wireless/wireless-lan-controller-software/products-security-advisories-list.html and https://tools.cisco.com/security/center/viewErp.x?alertId=ERP-70108 for Security Advisories issued *after* the 8.0.152.0 release.  Some of those are only fixed in 8.2.170.0 and later.

CreatePlease to create content
Content for Community-Ad

August's Community Spotlight Awards