cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2775
Views
5
Helpful
4
Replies
Deepak Ladha20
Beginner

Telemetry Subscription Not Working on Virtual Routers

Hi Team,

 

I am using a virtual router using Cisco ISO image (c8000v-universalk9.17.05.01a) deployed on a VM. The version information on the virtual router is as below -

 

#show version

Cisco IOS XE Software, Version 17.05.01a
Cisco IOS Software [Bengaluru], Virtual XE Software (X86_64_LINUX_IOSD-UNIVERSALK9-M), Version 17.5.1a, RELEASE SOFTWARE (fc3)

 

I created a few Telemetry subscriptions on it following the steps from the Cisco document

#enable
#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
(config)#telemetry ietf subscription 201
(config-mdt-subs)#stream yang-push
(config-mdt-subs)#filter xpath /process-cpu-ios-xe-oper:cpu-usage/cpu-utilization/five-seconds
(config-mdt-subs)#update-policy periodic 2000
(config-mdt-subs)#encoding encode-kvgpb
(config-mdt-subs)#source-address xx.xx.xx.xx
(config-mdt-subs)#receiver ip address xx.xx.xx.xx 57500 protocol grpc-tcp
(config-mdt-subs)#end

 

Unfortunately, the state for all subscriptions appear as Invalid

 

#show telemetry ietf subscription all
  Telemetry subscription brief

  ID               Type        State       Filter type
  --------------------------------------------------------
  101              Configured  Invalid     xpath
  201              Configured  Invalid     xpath
  301              Configured  Invalid     xpath

 

 

When I list subscription detail for anyone, it has Notes saying "Schema currently not available:" for the sensor path (xpath).

#show telemetry ietf subscription 201 detail
Telemetry subscription detail:

  Subscription ID: 201
  Type: Configured
  State: Invalid
  Stream: yang-push
  Filter:
    Filter type: xpath
    XPath: /process-cpu-ios-xe-oper:cpu-usage/cpu-utilization/five-seconds
  Update policy:
    Update Trigger: periodic
    Period: 2000
  Encoding: encode-kvgpb
  Source VRF:
  Source Address: xx.xx.xx.xx
  Notes: Schema currently not available: '/process-cpu-ios-xe-oper:cpu-usage/cpu-utilization/five-seconds'.

  Legacy Receivers:
    Address                                    Port     Protocol         Protocol Profile
    -----------------------------------------------------------------------------------------
    xx.xx.xx.xx                                57500    grpc-tcp

 

Any idea/input on what is going wrong here?

 

Thanks,

Deepak Ladha

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
bigevilbeard
Cisco Employee

@Deepak Ladha20 never seen this note error before. Is netconf-yang CLI enabled?

 

Show run | I netconf or con t > netconf-yang ?

View solution in original post

4 REPLIES 4
bigevilbeard
Cisco Employee

@Deepak Ladha20 never seen this note error before. Is netconf-yang CLI enabled?

 

Show run | I netconf or con t > netconf-yang ?

Thanks @bigevilbeard 

netconf-yang was not enabled and so I enabled it. Saved the configuration and created a new subscription but the result is the same. State is still Invalid.

I am just wondering if these schemas have any issue if run on virtual routers?

I gave it some time after enabling netconf-yang, and then it worked.

Not sure why it needed extra time though

@Deepak Ladha20 thanks for the update - I have seen some delays in tear down and re-enabling this. Glad this is now working for you!

Create
Recognize Your Peers
Content for Community-Ad