Showing results for 
Search instead for 
Did you mean: 


Camera and recording will not delete

Hello Community.  We relocated our MDF at one of our sites and when we ran cable, we missed one for one of my cameras.  This site was far away from my office, so I didn't get back to run another cable for a few weeks.  Well I finally ran another cable for it this week and got the camera connected.  It came back up with no issues.  I was able to ping it and web to it with no problems, but it didn't want to work in VSM.  There was no video feed.  For the record, the surveillance camera is a CIVS-IPC-2600 running firmware V4.4.2-2.  The VSM version is 7.12.0.  I have 2 cameras at this site that are exact same as far as model and firmware go.  The one that is working, we had a cable for originally, so it didn't have much down time. 

So the camera I'm having issues with, I decided to delete and try a fresh start, but now VSM won't even let me delete it.  Depending on what I do, I get different error messages.  When I try to delete the camera, I get the following:


Operation failed: Media server reported the error connect(addr='/usr/BWhttpd/run/device.4ffeac83-2e6f-42b9-8007-e33c0ddca1bc_socket', fd=8): Connection refused


If I try to make a configuration change for the camera and save it, I get the following:


Operation failed: These device(s) RSMS 1 have a collision in identities. If one of the colliding device is a camera, then please check the pending devices list as well.


This might be because I had tried multiple times to delete the camera and replace the camera, with itself.  Probably wasn't the best thing to do but I was getting desperate.  For fun, I checked the pending devices and there was nothing there.  Now, if I go to the management console of it's associated VSMS server, I see some things that might be helpful.  When I go to the pane on the left and select "Devices" it shows the camera as deleted.  When I select "Recordings" it shows the camera recording state as shelved and the Admin state as Disabled.  The rest of my cameras do not show that.  When I select "Streams" on the left page, I don't see the camera at all, which I think is expected at this point since it isn't working.  I feel like it's acting as though I had done a delete on the camera but retain recordings.  Every time I attempted to delete the camera, I always clicked on FULL DELETE.  So this shouldn't be the case.  Does anybody have any suggestions?

Frequent Contributor

Re: Camera and recording will not delete

Have you tried the more aggressive Options under:

Operations > Management > Troubleshoot > Cameras

... and delete using that method?

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:

Re: Camera and recording will not delete

Thank you for the response.  I actually got this resolved awhile back via Cisco TAC.  Here is the resolution summary from the Cisco engineer:


"we needed to change the IP address of the camera and do a replace camera."


Almost sounds too simple for what I went through.  


Re: Camera and recording will not delete

No, I haven't. I thought it was the same as Cameras>Bulk Actions. Why would it be more aggressive?
Frequent Contributor

Re: Camera and recording will not delete

I'm not 100% sure on that, and I base it only on some of my own observations.  We had several 'Camera Objects' that were significantly FUBAR and attempting to delete them via the regular methods (including Bulk Actions) simply would not succeed.


I was resigned to the idea that I'd have to probably muck around in the DB backend to get them cleaned up, but then located the 'Troubleshoot' section (which was/is relatively new to me), and decided to give it a try first.  Sure enough, it was able to clear up the entries where other attempts could not.



Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: