cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
834
Views
15
Helpful
8
Replies
burleyman
Collaborator

Camera stops sending traffic with CIVS-7030 IP cameras

I am very new to the IP camera side of networking so please forgive any mis-speak.

I have 3 cameras connected to a Cisco WS-C3560G-48PS running c3560-ipbasek9-mz.122-55.SE9.bin

I am being told the camera connected to Gi0/23 is the one having issues.

Here is the config on the ports:

interface GigabitEthernet0/15
switchport access vlan 803
switchport mode access
speed 100
duplex full
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device ip-camera
mls qos trust dscp
auto qos video ip-camera
spanning-tree portfast

interface GigabitEthernet0/16
switchport access vlan 803
switchport mode access
speed 100
duplex full
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device ip-camera
mls qos trust dscp
auto qos video ip-camera
spanning-tree portfast

interface GigabitEthernet0/23
description VideoCam
switchport access vlan 803
switchport mode access
srr-queue bandwidth share 1 30 35 5
priority-queue out
mls qos trust device ip-camera
mls qos trust dscp
auto qos video ip-camera
spanning-tree portfast

What they are reporting is pixelation and Ghosting.

Couple of odd things:

Port 23 is the only camera that when you run the command "show cdp nei" you see that it discovers the camera but the other two ports do not.

Interface Admin Oper Power Device Class Max
(Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Gi0/15 auto on 15.4 Ieee PD 0 15.4
Gi0/16 auto on 15.4 Ieee PD 0 15.4
Gi0/23 auto on 15.4 CIVS-IPC-7030 0 15.4
Gi0/35 auto off 0.0 n/a n/a 15.4

****************************************************

Device ID: 00:22:BD:FB:xx:xx
Entry address(es):
IP address: 10.64.3.24
IPv6 address: FE80::222:BDFF:FEFB:xxxx (link-local)
Platform: CIVS-IPC-7030, Capabilities: Host
Interface: GigabitEthernet0/23, Port ID (outgoing port): eth0
Holdtime : 164 sec

Version :
2.7.0-20

advertisement version: 2
Management address(es):

The two cameras just stop sending traffic after a few hours. I can see this based on looking at this from the output of the Command "show interface"

Here is what it looks like when we first bring the camera on line. This is what I would expect to see in the rxload when the camera is sending traffic.

reliability 255/255, txload 1/255, rxload 65/255

After a few hours it stops sending traffic and it looks like this.

reliability 255/255, txload 1/255, rxload 1/255

Any ideas or has anyone seen this before?

It does it on two cameras but two other cameras on the switch work fine. The other cameras are not Cisco.

Mike

8 REPLIES 8
Scott Olsen
Frequent Contributor

What version of Cisco VSM is being used?

How are these 7030s configured?  

What bitrate are they operating at?

Are there any errors accumulating on any switchports?

Once they 'stop sending traffic', do they stop responding entirely?  Are they accessible via their native web UI?

I believe these cameras are likely using a UDP transport.  Any packet loss greater than 1% is going to result in macro block corruptions and ghosting.  This may be occurring between the camera and VSMS instance, *or* between the VSMS instance and the operator workstation.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

Thank you for your response.

First, we decided to just RMA the cameras.

Now since I am new and I want to understand more and in case we put the replacements in place and the same thing happens I have a few questions on your questions.

*************************************************************

What version of Cisco VSM is being used? How would this prevent the camera from sending traffic at the switchport level?

How are these 7030s configured?  What in the configuration should I look for that would stop the camera from sending traffic all of a sudden?

What bitrate are they operating at? Could a high or low bitrate cause the camera to stop sending traffic? If yes what should I do to test that?

Are there any errors accumulating on any switchports? No there are not any errors on the interfaces with the cameras.

Once they 'stop sending traffic', do they stop responding entirely? No, you can ping the camera and the switchport still shows up.

 Are they accessible via their native web UI? Not sure on that.

I believe these cameras are likely using a UDP transport.  Any packet loss greater than 1% is going to result in macro block corruptions and ghosting.  This may be occurring between the camera and VSMS instance, *or* between the VSMS instance and the operator workstation.

We are not seeing and ghosting or video quality issues while the camera is working. It will just stop sending traffic.

Again thank you for your help.

Mike

Scott Olsen
Frequent Contributor

Well, based on the information you've provided it sounds as though the VMS is simply shutting down the stream.  This sounds like an issue that needs to be investigated on the VSM side of things, which is why those questions were asked.

Without that information, I cannot really offer any recommendations other than, log into the WebUI on the cameras and check the local logs.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

Ah..... What could cause VMS to shut down the cameras? What setting should I look at?

Because if that is the case the new cameras should also have the same issue, correct?

Mike

Also, please don't think I was questioning your questions, I just do not understand that side of things so I was trying to better understand. I am a network guy and being asked to troubleshoot IP cameras and related equipment.

Thank you for your help on this. If there is anything else I should look at please let me know.

Did you resolve your problem simply by RMAing the cameras?  What finally happened here??

ka

Scott Olsen
Frequent Contributor

Well, I'd check the IMS.log file from the Video Surveillance Management Console.  Also, the local log file on the camera itself.  Accessible via the native camera UI.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web: www.bulletproofsi.com

Thanks for the information. I will post when we get the new cameras in place and I can check the VMS setup.

Thanks for your help with this.

Mike