Showing results for 
Search instead for 
Did you mean: 
Yhya Akef

IP camera 2935 zoom problem with VSOM 7

Hi ,

I have VSOM 7 and IP camera 2935 ,

I can't zoom through the web interface of VSOM nor SASD .

The document says that zoom is by shift-click and move the mouse up & down to zoom in or out.

I've tried this method but with no success .

Any idea ?

Jason Rossi

I don't have any 2935's, but have had this same experience with VSM 7 and 3 supported PTZ models. Using the keyboard and mouse the best you will get is a digital zoom at this time. You need to hook up a joystick in order to use the cameras proper PTZ controls. This is true in both SASD and VSOM.

Scott Donahue


I am using VSOM 7 and have the 2930 PTZ cameras and I can confirm that the document instructions are correct. It is the same proceedure for both VSOM and SASD. First thing I'd ask is are you clicking on the PTZ icon in the upper right hand corner of the image when you are viewing the camera? If so it should change from gray to blue to indicate the PTZ controls are active. If not, you won't have any control of the camera other then to right click and digitally zoom which defeats the purpose. After you verify that the icon has changed to blue (Active control), using the left mouse button and holding down will allow you to Pan and Tilt the camera. To Zoom, you need to hold down the SHIFT key while also holding down the left mouse button. Then as you are holding both down you will see just a Zoom arrow indicatior on the screen and then move you mouse forward to zoom in and to zoom out move your mouse backwards.

Also note that when you are Panning or Tilting the camera it will start to slowly zoom in as you are moving the camera and you may need to zoom out to get back to where you started.

Hope this helps,


I've already tried all of this with no success

I can also confirm that mouse based PTZ zoom functionality is non-functional in VSM 7.2.  Joystick control works fine.

Going to spin this thread off into a TAC case.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:

Oops... appears I can't spin off into TAC case as I'm not the originator.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:

Scott what I had to do in 7.2  was  hold Left Mouse key down and use the scroll wheel on the mouse.

Very cumbersom  i have heard the USB joy stick works very nice.

Scott Olsen
Frequent Contributor

I've tried this as well, still no luck.  Unless I'm missing another step, I cannot get any of our PTZs to zoom with this method.

Unfortunately, it's low priority for myself at the moment.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:
Bulat Zakirov

First of all, check your firmware on camera (system settings/firmware management) or on camera. If version is 1.6.17, camera rotate, but not zoom. Download this firmware CIVS-IPC-2900- on and update it from VSOM.

I have attempted with numerous encoders (Cisco and Axis), as well as a new CIVS-IPC-6930 running most recent firmware,

I do not have a method of zoom via mouse control.

Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:

I said only about 2935 cameras.

I concur, it broke with the upgrade to 7.2.  I have a 2935 running that version of firmware and it broke after the 7.2 upgrade.  I don't think its a firmware issue anyway as the UI never changes to the correct up/down icon when the shift is selected. 

I'm actually thinking this isn't 'broken' so much as they changed the behavior.  If you look at all the 7.2 user guides, they make no mention of holding the shift key, rather just using the scroll wheel.  I can confirm that does work while holding the left mouse button, although its a little akward. 


Like Vance said, I also stumbled onto the solution to this. Forget the "shift click" referenced in the manual and on the VSOM page. Try this:

1) Left Click and continue to hold down the left mouse button

2) Scroll the mouse wheel forward while continueing to hold down the left mouse button. The camera will then start zooming in.

3) Let go of left click to make it stop zooming in.

4) Reverse procedure (scrolling wheel back this time) to zoom out.

5) The speed of the zoom depends upon how aggressively you spin the mouse wheel.

Little cumbersome, and sometimes has some latency, but after a few minutes I got used to it. Works on every PTZ model I have here, and wporks in both VSOM and SASD. Using a joystick is still a far superior experience though.

Message was edited by: Jason Rossi

I just want to add that the mouse zooming functionality still does not function for all of the encoder connected analogue cameras I have available in our lab.  I have an analogue PTZ on a supported AXIS encoder, as well as another on Cisco's own 4ch standalone encoder that does not respond to mouse-based zoom commands (Pan & Tilt do function).  All functionality (PTZ) is present when using a hardware joystick.

Just an update for anyone else searching the forums.


Scott Olsen Solutions Specialist Bulletproof Solutions Inc. Web:
Content for Community-Ad

This widget could not be displayed.