cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3873
Views
4
Helpful
10
Replies
Contributor

ACS 5.2 on vSphere ESX 4.1

We have a client that has the vmware image of Cisco ACS 5.2.  They installed in on a vSphere ESX 4.1 server and after it was done installing, the received a login prompt and not a prompt to continue setup.  They tried using the default login username and password and it did not work.  Cisco TAC told them that ACS 5.2 will not run on their version of vmware.  The client is threatening to return the product if this does not work.  Any suggestions or are they stuck?

Also, they have the proper amount of resources allocated as well and their entire environment is at ESX 4.1.

TIA,

Dan

10 REPLIES 10
Participant

Re: ACS 5.2 on vSphere ESX 4.1

We have two instances of ACS 5.2 running on our ESXi 4.1 VMware infrastructure.  Note that that's ESXi not ESX, but I just pinged my VMWare admin and he doesn't think that it shouldn't make a difference in your case.

Yeah, the ACS docs says only ESX 4.0 is 'officially' supported (http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.2/device_support/sdt52.html#wp75825) but I think your TAC guy is just playing it safe.

I've been plugging away on ACS 5.2 for a few weeks now, have Nexus 7000's, 5000's, 3945 routers, ASA's, etc all happily authenticating to it.  I'm about to add hundreds of 2821's, 3560's, 2100 WLCs, etc.  I'm not sure why you're getting the errors you're seeing, but I would suggest rereading this part of the ACS installation guide for VMware (http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.2/installation/guide/csacs_vmware.html) and then if it still doesn't work, escalate your TAC case and/or contact your Cisco rep.   I am so much happier with ACS 5.x than 4.x.  Don't give up!

Beginner

Re: ACS 5.2 on vSphere ESX 4.1

Its not working for us either. We have ESX4.1 running in our environment and it installs but ACS application would not start. Does anyone know of a work around how to get the ACS 5.2 running on ESX4.1

Cisco Employee

Re: ACS 5.2 on vSphere ESX 4.1

We say that it's not tested by cisco, You will be able to install ESX 4.1 just fine but there might be some issues with services/processes . In that case TAC won't support those issues. Vsphere is a Vmware  managment tool. ACs 5.x doesn't support/run on vspehere. ACS 5.3 should  officially support ESX 4.1

Virtual Machine Requirements

The minimum system requirements for the virtual machine must be similar  to the CSACS-1120 Series appliance hardware configuration.

Table 6-1 lists the minimum system requirements to install ACS 5.2 on a VMware virtual machine.

Table 6-1     Minimum System Requirements

Requirement Type
Minimum Requirements

CPU

Intel Core2; 2.13 GHz

Memory

4 GB RAM

Hard Disks

500 GB of disk storage

NIC

1 GB NIC interface

Hypervisor

VMware ESX 3.5 or 4.0



Note You  can use VMware Server 2.x only for an evaluation version of ACS 5.2.  For an evaluation version, the disk space must be between 60 GB and 500  GB.


Evaluating ACS 5.2

For evaluation, ACS 5.2 can be installed in a VMware Server 2.x virtual  machine or a VMware ESX virtual machine. When evaluating ACS 5.2, you  can configure less disk space in the virtual machine, but a minimum disk  space of 60 GB is required.

Rgds, Jatin

Do rate helpful posts~

~Jatin Katyal
Beginner

ACS 5.2 on vSphere ESX 4.1

I am having the EXACT SAME issue as the original poster.  Has anyone figured out a solution to this problem with ESXi? According to our summary we're running ESXi, 4.1.0, 348481.

***Exactly*** as the original poster states, we go through the installation process and after the reboot, we DO NOT get the "setup" banner, and when we DO type setup, instead of initiating the setup operation, we are prompted to enter a password and can never put an IP address on the system, which would allow us to at least meddle with the web interface.

This is very, very irritating since as a Cisco reseller, we'd prefer to bundle ACS with our wireless and .1x solutions as opposed to IAS.  Need experience with the product first though.

Where is the setup script located that it won't load on an ESXi VM???? are there some GRUB options I can pass to it to force it to run setup and what would the GRUB password be?

OUR VM has: 2CPUs, 4GB RAM, 70GB HD, LSI SAS Controller (the VM Para controller wouldn't work) so we allegedly meet all the minimum requirements, but are not getting prompted to type setup, nor is the setup utility running.

Beginner

Re: ACS 5.2 on vSphere ESX 4.1

It looks like the solution to the problem is to choose the parallel LSI drivers and NOT the SAS.  We got setup to run with that config. And we just successfully logged into the web interface.  Panic mode over. ***we also rebuilt the machine as a 32-bit Linux machine in accordance with the guide*** so I don't know what change was actually responsible for success.  This is the guide I'm referering to:

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.2/installation/guide/csacs_vmware.html

I don't recall seeing anything in the guide about the SCSI controller.

Cisco Employee

Re: ACS 5.2 on vSphere ESX 4.1

Hi everyone,

The symptoms that deyster94 described (seeing a username and password prompt at the CLI and hence not being able to get into the "setup" mode) is usually seen when the VM has been configured with the wrong guest operating system.

The correct guest operating system is "Other Linux (32-bit)".

Could we confirm that the correct guest operating system has been selected for the VM? If it hasn't the VM will need to be deleted and then a new one created. Changing the guest operatins system on an existing VM often doesn't work (hence deleting and recreating is required).

However, having said that, 3.5 or 4.0 are the officially supported versions of ESX. It doesn't mean that 4.1 can't be used but rather that the stability can't be guaranteed.

Best regards,

Dragana

Beginner

ACS 5.2 on vSphere ESX 4.1

We have 8 ACS servers in use currently, two appliances and 6 VM's. The VM's are running on ESX4.1. The key is to set the OS as "Other Linux (32-bit)" as mentioned by Dragana above.

Enthusiast

ACS 5.2 on vSphere ESX 4.1

Running fine on ESXi 4.1 now for about 2 months. 

If this posts answers your question or is helpful, please consider rating it and/or marking as answered.
Highlighted
Cisco Employee

ACS 5.2 on vSphere ESX 4.1

Based on the previous comments, it looks like we've got a few number of ACS 5 instances that are running on ESX 4.1 without any problems.

Can the other posters that are seeing problems with ACS 5 and ESX4.1 please confirm that the guest operating system on the VM has been set to"Other Linux (32-bit)"?

Best regards,

Dragana

Please rate helpful posts

Enthusiast

ACS 5.2 on vSphere ESX 4.1

We used "Other Linux (32 - bit)" on an ESXi 4.1 platform and have had no issues. Just make sure when you provision your resources you provision the supported amounts. 

If this posts answers your question or is helpful, please consider rating it and/or marking as answered.