cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3552
Views
0
Helpful
5
Replies
Highlighted

Migration Utility for ACS 5.2 - Fatal Error !! - cannot connect to ACS 4.x DB !!

Hello everybody!

If I try to export data from ACS 4.2 it allways fails with the following error massage: Fatal Error !! - cannot connect to ACS 4.x DB !!

  • The release is: 4.2(0) Build 124
  • I dont use RDP, I'm using VMware vShpere client console
  • I restarted the Windows Machine
  • I used the CreateReportFiles option. But the created csv files are empty (0 KB).

Please find attached the log files from ...\migration\bin

I provided a what_I_did.txt file where u can see what i entered in the migration utility dialog.

Thanks for your help!

1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

Re: Migration Utility for ACS 5.2 - Fatal Error !! - cannot conn

Hi,

Indeed, that is the problem.

You need to have a migration machine running ACS in the same version as the production ACS.

And run the MU on the migration machine.

Please follow in detail the Migration guide:

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.2/migration/guide/Migration_Install.html.

HTH,
Tiago

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

5 REPLIES 5
Cisco Employee

Re: Migration Utility for ACS 5.2 - Fatal Error !! - cannot conn

Hi,

Can you please confirm that you have saved the ACS dmp file from the Original ACS machine and imported it to the MIgration utility ACS?

Can you confirm that the Original ACS and the migration utility ACS are running exactly the same version?

On the migration utility ACS, when you restore the dmp file, does it restores it successfully?

Can you clarify which ACS is running on VMWare? The original ACS or the migration ACS?

HTH,
Tiago

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Re: Migration Utility for ACS 5.2 - Fatal Error !! - cannot conn

Hi Tiago,

I did not set up a Migration ACS. I tried to run the Migration Utility on the operative ACS. That must be the reason why the Migration Utiliy could not connect to the DB.

Thanks,

Andy

Cisco Employee

Re: Migration Utility for ACS 5.2 - Fatal Error !! - cannot conn

Hi,

Indeed, that is the problem.

You need to have a migration machine running ACS in the same version as the production ACS.

And run the MU on the migration machine.

Please follow in detail the Migration guide:

http://www.cisco.com/en/US/docs/net_mgmt/cisco_secure_access_control_system/5.2/migration/guide/Migration_Install.html.

HTH,
Tiago

--

If  this helps you and/or answers your question please mark the question as  "answered" and/or rate it, so other users can easily find it.

Beginner

Migration Utility for ACS 5.2 - Fatal Error !! - cannot connect

I'm having the same problem however we are running on a migration machine.

Any ideas?

You need to be running on

You need to be running on Windows 2003 for migration tool to work or change ODBC drivers , although ACS 4.x works on windows 2008 32 the migration tool does not