cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Who Me Too'd this topic

Create trunkports on Catalyst 2960

Ulf Larsson
Beginner
Beginner

Hi.

I'm trying to create trunkports on our Catalyst 2960.

I'm following this guide to configure interface fa0/1



Command

Purpose

Step 1 


configure terminal


Enter global configuration mode.


Step 2 


interface interface-id


Specify the port to be configured, and enter interface configuration mode.


Step 3 


Switchport mode trunk


Configure the interface as a VLAN trunk port.


Step 4 


switchport trunk allowed vlan {add | all | except | remove} vlan-list
In my case, switchport trunk allowed vlan add 1-2


(Optional) Configure the list of VLANs allowed on the trunk.


For explanations about using the add, all, except, and remove keywords, see the command reference for this release.


The vlan-list parameter is either a single  VLAN number from 1 to 4094 or a range of VLANs described by two VLAN  numbers, the lower one first, separated by a hyphen. Do not enter any  spaces between comma-separated VLAN parameters or in hyphen-specified  ranges.


All VLANs are allowed by default.


Step 5 


end


Return to privileged EXEC mode.


Step 6 


show interfaces interface-id switchport


Verify your entries in the Trunking VLANs Enabled field of the display.


Step 7 


copy running-config startup-config


(Optional) Save your entries in the configuration file.

When I run the command show interfaces fa0/1 trunk, I got this result

Port        Mode             Encapsulation  Status        Native vlan

Fa0/1       on               802.1q         other         500

Port        Vlans allowed on trunk

Fa0/1       none

Port        Vlans allowed and active in management domain

Fa0/1       none

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/1       none

I'm expecting that my vlans that I have allowed, should be listed like this

show interfaces fa0/24 trunk

Port        Mode             Encapsulation  Status        Native vlan

Fa0/24      on               802.1q         trunking      500

Port        Vlans allowed on trunk

Fa0/24      90-95

Port        Vlans allowed and active in management domain

Fa0/24      90

Port        Vlans in spanning tree forwarding state and not pruned

Fa0/24      90

So why doesn't it work on interface 1 (and 2-4) when it working on interface 24?

Who Me Too'd this topic