cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Who Me Too'd this topic

Nightmare with unprimed Access Points

In the middle of total boredome we spent hours with the new unprimed universal access points (AIR-AP3702I-UXK9) combined with some of the attractively priced mobility bundles...

SCENARIO:

If you just use the unprimed AP and connect it, it joins the controller, but flashes red and green. This means that only the 2,4GHz band is working. To get the 5GHz online, you need to prime it. After reading the almost 20 pages of documentation found at http://www.cisco.com/c/en/us/td/docs/wireless/access_point/ux-ap/guide/uxap-mobapp-g.html the honored reader will find out that the only way to do this is with the Smartphone and the Cisco AirProvision App.

But this App simply does not work in the current version. As soon as you access an AP the app crashes (Android, V1.7, Samsung Galaxy Note 4, but also tried 3 other makes). On some Smartphone OS Versions it is also not offered in the Google Play Store... (5.0.1) - by the way, getting only 1.x stars in the reviews is really hard to achive these days...

With a lot of approaches and celestial superpower we finally got it working with an old ICS based Galaxy S4 with Version 1.5 downloaded here: https://apkpure.com/cisco-airprovision/com.cisco.airprovision ; (we might offer this so configured device on eBay for a fortune...)

But beware - if you are in the datacenter, having no location service (GPS) and no cellular (but WLAN) you should not even try...

After you got the first AP working, the others got primed via NDP - this worked.

One more thing...

After you reset (boot with button pressed) one of these universal AP's that have been joined (primed or unprimed), they will not join any WLC again. When you attach to the console you get the following lines over and over again:

*Nov 17 20:49:58.463: %CAPWAP-5-SENDJOIN: sending Join Request to 10.x.x.x
*Nov 17 20:50:16.607: %DTLS-5-SEND_ALERT: Send FATAL : Close notify Alert to 10.x.x.x:5246

In this case use the console to login with the default user (cisco/Cisco) and enter:

APa89d.21xx.xxxx#clear capwap private-config 
APa89d.21xx.xxxx#
*Nov 17 20:52:59.235:  factory_reset_universal_ap(): Revert back universal AP in -UX domain during factory reset
*Nov 17 20:52:59.235:  **************************** UNIVERSAL AP PRIMING ***********************

Then reload the AP and it should join again. If it was primed before, it is unprimed after the reset.

SUMMARY:

Who the f**k designed that process, made that incomplete factory reset code and developed that crashing smartphone app? How about a CLI command like "ap prime [country]" or just a simple dropdown or checkbox on the WLC admin pages? What about reading the already set country out of the WLC?

HTH and best regards!

Everyone's tags (1)
Who Me Too'd this topic