Showing results for 
Search instead for 
Did you mean: 

Port forwarding to a non-PC device that serves graphics


We have a site with a simple LAN behind a Cisco RVS4000 V2 router and a SMC Cable Modem Gateway.  The only device on this LAN is a controller that runs a non-windows operating system and serves graphics up on the default HTTP port 80.

We would like to set the RVS4000 to port forward any web traffic on the default web port (HTTP 80) to a static ip on the LAN.

I have been trying this for hours by modifying the Firewall settings to support Single Port Forwarding and/or Group Port Forwarding to no avail.  I can remotely administer the RV4000 device using port 8181 (arbitrarily selected to avoit cracers...) but I cannot view my graphics on port 80.  I have attached the CFG backup for those that know how to open it...

Any suggestions?


Ray L.

11 Replies 11


Hi Ray, thank you for using our forum, my name is Luis I am part of the Small business Support community. Did you try to create an access list after configured the Port forwarding rule? If not, I suggest you to create the Access rule, if the issue continues you could try to configure Range Port forwarding instead single port forwarding and just put the 80 port in the range.

I hope you find this answer useful


Luis Arias.

Cisco Network Support Engineer.

Thanks.  I had not tried an ACL but I will!   Had already tried Range Port Forwarding...


Ok, I tried adding an ACL.  I set the parameters as follows:

     Action:               Allow

     Service:               All or HTTP, tried both...

     Log:                    Enabled

     Log Prefix:          Access

     Source XFace:    Any

     Source IP:          Any or a spcecific IP (our wan ip...)

     Destination IP:    Single:

     Scheduling:        Any day, any time

Tried a number of variations, alternated between Single Port Forwarding and Group, etc.

No joy.

In talking to the ISP (Charter Communications) they adamantly state that there is nothing in the Cable Modem (SMC 8014) that would affect or hinder port forwarding...

Any other ideas?

Thanks in advance...

Hi Ray, actually configuring the Port Forwarding and the ACL should be working now, in this case could you please reach out to our Small Business Support Center and open a Service Request to address this issue? One of our Engineers may be able to work with you and diagnose the root cause. You can find the appropriate contact information for SBSC in the below link.

I hope you find this answer useful


Luis Arias.

Cisco Network Support Engineer.

I already tried that and was told no support as the Warranty on this unit had run out…

Hi Ray,

Do you have a service contract for the Cisco RVS4000? If you do, they SBSC agent should be able to help you.

Cindy Toy
Cisco Small Business Community Manager
for Cisco Small Business Products
twitter: CiscoSBsupport

Regards, Cindy If my response answered your question, please mark the response as answered. Thank you!

No contract.  I am a 'contractor' of sorts and the RVS4000 belongs to the client.  It appears they purchased a quantity of them to service some IP Cameras and passed one on to me to use in this application as well.   No contracts and the initial warranty has expired.

Hello Ray,

Have you tried the steps listed in the link below:

You may need to reset the configuration on the router to factory default and start afresh. Also, make sure that your ISP is not blocking port 80 traffic destined to your network.

Hope this helps.


That is the exact procedure I started with, and, the ISP claims they are not blocking anything...


Instead of messing with port forwarding, let's try putting the destination in the dmz and see what happens.  If this works, then something isn't working right on the port forwarding.  If this is a solid state machine that just serves out on port 80, you may be able to just leave in the dmz as well.

Huntsville's Premiere Car and Bike e-magazine:

Huntsville's Premiere Car and Bike e-magazine:

Well, the SMC cable gateway is a router of a such... I'd suspect that may be your problem. The RVS4000 is pretty solid for the basic services it has...

I would put money on the fact if you set up remote management to the RVS4000 as port 80 then tried to connect to your public IP over the internet, this would fail. If it doesn't fail, then you may want to try to telnet locally to that graphics box to see if you can establish a socket locally on port 80. This will at least prove TCP 80 works to the WAN and on the LAN.

If it still has some fits... I'd connect your graphics box directly to your modem device and see if you can hit it on port 80 over the internet.

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers