cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3298
Views
4
Helpful
24
Replies

PPPoE configuration - no PADI recieved

kolomja3
Level 1
Level 1

Hey guys,

I'm trying to setup my home internet on Cisco router. ISP is via PPPoE connection - NBN HFC (cable modem). Router gets stuck on sending PADI packet and it never gets reply from server. I've captured some packets with Wireshark (I've established direct Dial-up connection on my laptop) and there is Cisco router on ISP side (according to MAC address). 

Here is my configuration and debug:

interface GigabitEthernet1
no ip address

pppoe enable group 42
pppoe-client dial-pool-number 42

no shutdown


interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 42
dialer-group 42
ppp authentication chap callin
ppp chap hostname MY_ISP_NAME
ppp chap password MY_ISP_PASSWORD
!

dialer-list 42 protocol ip permit

ip route 0.0.0.0 0.0.0.0 Dialer1

I've enabled

debug pppoe packets

debug pppoe errors

debug pppoe events but 

*Feb 28 04:44:04.299: Sending PADI: Interface = GigabitEthernet1
*Feb 28 04:44:04.299: pppoe_send_padi:
contiguous pak, size 60
FF FF FF FF FF FF 64 3A EA 02 18 21 88 63 11 09
00 00 00 10 01 01 00 00 01 03 00 08 6A 00 00 01
00 00 1F 17 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00R800#sh pppoe session
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 0 0000.0000.0000 Gi1 Di1 N/A PADISNT
0000.0000.0000

IR800#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Feb 28 05:09:31.699: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:31.699: Di1 DDR: Cannot place call, no dialer string set.
*Feb 28 05:09:33.700: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:33.700: Di1 DDR: Cannot place call, no dialer string set.
*Feb 28 05:09:35.700: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:35.700: Di1 DDR: Cannot place call, no dialer string set.

It's sending PADI frame out of correct interface as broadcast message but it never gets reply from svr.

I've tried cloning int G1 MAC address on my TP-Link router and it works. It doesn't look like issue on ISP side. I've verified with ISP that I can use CHAP authentication as well.

 

Any ideas why the router never gets reply from the server? Do I need to include vpdn config.?

 

 

 

1 Accepted Solution

Accepted Solutions

Finally I found working configuration:

interface GigabitEthernet1
switchport mode trunk
no ip address
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
pppoe enable group global
pppoe-client dial-pool-number 1
!
i
interface Dialer1
mtu 1492
ip address negotiated
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname XXXX
ppp chap password  YYYYY
ppp ipcp dns request accept
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1

View solution in original post

24 Replies 24

balaji.bandi
Hall of Fame
Hall of Fame

check the dialer config :

https://screwlooseit.com.au/cisco-router-nbn-hfc

Do you also have another thread same issue posted and why not we follow same ? or is this different ?

https://community.cisco.com/t5/routing/pppoe-configuration/td-p/4783076

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

It's same thread. According to ISP website VLAN tagging is no longer required. If I try the config router itself says it's prefered to enable pppoe directly on the interface.

Result is the same.. no reply on PADI..

*Mar 4 01:33:01.725: padi timer expired
*Mar 4 01:33:01.725: Sending PADI: Interface = Vlan100
*Mar 4 01:33:01.725: pppoe_send_padi:
contiguous pak, size 60
FF FF FF FF FF FF 64 3A EA 02 18 20 88 63 11 09
00 00 00 10 01 01 00 00 01 03 00 08 3A 00 00 02
00 00 03 2B 00 00 00 00 00 00 00 00 00 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00go


Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 0 0000.0000.0000 Vl100 Di1 N/A PADISNT
0000.0000.0000

 

 

NO NEED VPDN since it only PPPoE client 

I dont have protocol pppoe option only l2tp

interface GigabitEthernet1
no ip address

pppoe enable group 42 <<- why you set this with 42 not global ??
pppoe-client dial-pool-number 42

no shutdown


interface Dialer1
mtu 1492
ip address negotiated
encapsulation ppp
dialer pool 42
dialer-group 42
ppp authentication chap callin
ppp chap hostname MY_ISP_NAME
ppp chap password MY_ISP_PASSWORD
!

dialer-list 42 protocol ip permit

""According to ISP website VLAN tagging is no longer required"" That totally right.
Sending PADI: Interface = Vlan100 <<- it can be that the PADI send tag frame, can you config port connect to SP with no switchport and try again

IR800#(conf-if)no switchport

Command rejected: Not a convertable port.

I've tried to set it back pppoe enable group global -- no difference

OK, try this 
interface x/x
switchport access vlan Z <<- vlan Z is the vlan that is native and send untag. 

 then config first global then group 42
 pppoe enable group global 

if I turn off trunking on G1, VLAN 100 goes down/down. Do you want me to revert config with no VLAN100? and then try?

Yes Sure 

No change, I'm running out of ideas why the router doesn't get a reply from the server.. I've included latest config.

*Mar 4 21:26:50.559: padi timer expired
*Mar 4 21:26:50.559: Sending PADI: Interface = GigabitEthernet1
IR800#sh pppoe ses
IR800#sh pppoe session
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 0 0000.0000.0000 Gi1 Di1 N/A PADISNT
0000.0000.0000
IR800#sh int di
IR800#sh int dialer 1
Dialer1 is up (spoofing), line protocol is up (spoofing)
Hardware is Unknown
Internet address will be negotiated using IPCP
MTU 1492 bytes, BW 56 Kbit/sec, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Closed, loopback not set
Keepalive set (10 sec)
DTR is pulsed for 1 seconds on reset
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:23:36
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
0 packets output, 0 bytes

you change the interface and remove VLAN100

now did you try group global ??

 dialer string "*99#" <<- why you add string under dialer interface that use PPPoE, as I know PPPoE only need userame/paswword 

yes I've tried group global

One of the early config did not have string configuration and I was getting this error:

*Feb 28 05:09:31.699: Di1 DDR: ip (s=127.1.3.2, d=8.8.8.8), 100 bytes, outgoing interesting (ip PERMIT)
*Feb 28 05:09:31.699: Di1 DDR: Cannot place call, no dialer string set.

no I've removed the string but I'm not getting this error

OK now the string is remove and error is disappear
still 
try one global group and other group 42  

yes I've tried: pppoe enable group 42 and  pppoe enable group global ... no difference

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: