Showing results for 
Search instead for 
Did you mean: 

RV 120W port forwarding problem


I created 5 firewall->port forwarding->rules...

What I wanted was to forward a particular port from the WAN to a particular LAN IP

All 5 showed up in the IPv4 Firewall rules, but only the first line that is enabled works.

If I disable the first line, the 2nd line works...

If I disable the first and 2nd line, then the 3rd line works...

I have tried cycling power and change...

Any ideas?

16 Replies 16

Te-Kai Liu
Rising star
Rising star

Would you provide a screenshot of your firewall rules?

Thanks for the quick response!  Screenshot attached.

The reason is that the Service parameter was set to ANY in the forwarding rules. It should be the specific service that you want to forward to the particular host in the LAN.


Thanks again for the quick is getting closer!!

The first line is a Windows remote desktop path.  I have not found any service that works except "any".

Right now if I disable the first line, the 2nd line (now HTTP) for the website works! and the final line "any" works!!

Is there a service that should work for windows remote desktop besides "any"?

Lines 3 and 4 are for the FTP server, I have not verified the FTP functionality yet.

Attached is the latest setup that almost works....

Next suggestion?

Is there a reason the "any" service type doesn't work? Let the port number decide destination?

i just tried the FTP port forwarding lines, and they do not work either.

we just replaced our old Linksys WRT54GX4 with this new RV 120W

all of these port forwarding rules worked prior to the RV switch...

so maybe it is just me trying to configure it properly...

I suggest removing the last rule that forward ANY Service to a specify LAN IP address. That rule could have caused all services forwarded to the given LAN IP address. You could define Custom Service under the Firewall>Access Control>Custom Services tab.

Thanks..., I will disable or delete the last rule and see if FTP is working.

Can you suggest a service type that I should select for Windows remote desktop?

Port 3389 is the default for Windows RDP.

I do not see a RDP service type in the rv 120w port forwarding rules.  How do you suggest fill out the port forwarding rule for RDP service?

Maybe this will help, I have attached a screenshot of the port forwarding screen from our old Linksys/Cisco WRT54GX4.

This setup worked.

On RV 120W, you could add a Custom Service for RDP under the Firewall>Access Control>Custom Services page,

Click on Add button, and define a RDP service as TCP Port 3389. Save it and you could see the RDP service when you go back to the Port Forwarding page.

Thanks, I did not know how the custom service worked.

I added 2 custom services as you suggested...attached file custom.jpg

Then I added them as the service type on the port forwarding page.

It looks nice, but now neither one works in any order..."rvcustomer.jpg"

What should I try next?

If forwarding TCP Port 3389 does not work as expected, please contact Small Business Support Center so they can offer additioanl help.

I see that this is the small business support community.

Can you point me to the small business support center?

I did not know there was a difference, sorry for wasting our time.

Maybe it's time to look at a Juniper solution.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers