Showing results for 
Search instead for 
Did you mean: 

RV042G WAN Bandwidth has only 100Mps?



I just got the RV042G today.  I found the router can only accept 100000 Kbit/sec as bandwith, which is 100Mps only.  According to the specification, it should have 1000Mps WAN.  I have a internet link of 1000Mps, which is now limited by this router.  Any idea if there is something wrong?



Wen-Li Huang

104 Replies 104


Any updates?  (I don't want to waste my time contacting SB TAC)  I know... this is a Small Business line product and need to realize caveats.

I just received my RV042G a couple days ago.  Will be using it at home, but tried it at work.  I chose the RV042G over ASA5505 due to cost and support.  SB more affordable than SmartNet 8x5xNBD.  Although I probably won't see ingress/egress over 50Mbps at home, the unit supports gig and supposedly higher than 100Mbps throughput with inspection.  (Univ of HI hosted on same AS)

Dell workstation through RV042G

115 down

97 up

Dell workstation through same datajack port RV042G used

445 down

275 up

Same workstation, browser, cabling, etc.  CommScope Systimax CAT6, all Cisco Enterprise beyond datajack.  Gig and 10Gig LAN/WAN links.  Speedtest server hosted on same AS within the University WAN.

I tried turning off the RV042G firewall with little change in performance.  Noticed the bandwidth throttling menu, but didn't think it applied if not active.  Set Wan1 to primary.  Wan2 is not connected.

I glanced over the GUI menu, but didn't see anything glaring.  Not sure if I need to look at anything specific.  Build date is sept 2012.  Latest firmware build, but just downloaded that latest from TAC support and re-flashed.  All same.

I haven't tried VPN, yet.  Hopefully, it works with the EoL VPN client.  Will need to deal with Anyconnect later.  Trying to avoid PPTP and multiple clients. 

Jury still out.  Need to test VPN, APPs, and SIP.  Is this as good as it gets?

Hello Lionel,

Have you tried disabling the SPI firewall? The speed listed 'NAT throughput' is the speed at which data travels while only using NAT. Please let us know if this gives better speed results.

In addition to testing without the firewall, it is important to note that tests are also done using packets of a max MTU (1500). On a normal network, packets range in size from 32 up to the 1500 and in some cases even further. This creates a situation where if you are sending mixed traffic you will see a lower overall throughput VS. when running software designed for speed testing.

I tried disabling firewall and switching between "Smartlink"/WAN1 primary and load balance yesterday. I glanced over all the sub-menus during my brief testing and GUI looked very basic. I used a simple web-based network test because I didn't want to invest time with NDT or iPerf. Advertised throughput of NAT 800 Mbps and 75Mbps IPSEC VPN was appealing. I read a review that indicated 500-600, but can't get close to this. I normally don't work with SB products, but considered this value product line instead of an ASA or ISR.

The limited VPN options may be a bigger issue than throughput. Trying to avoid $600+ for home, but need at least 100 Mbps WAN and multi-platform IPSEC VPN support.

Hi Lionel, to my best recollection there are some documented issues with the speeds that are able to be achieved with the RV042G. I would implore you to call the SBSC and try to get a case escalated. When calling in, the engineer you speak to should be able to locate a bug report for this.

Some very relevant information that would be required is-

  • ISP and type of service
  • Modem model number
  • Speedtest result connecting through the router and bypassing the router
  • Router configuration file
  • Firmware version
  • Network topology

You may also want to verify you're using a Cat5E or Cat6 since a normal Cat5 is 10/100.

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts

Tom, thanks for the suggestion.  I wanted to hear customer experience and this thread was high in my search result in term of date posted.  My local Cisco rep and SE said SB is different from Enterprise.  It's hit and miss even with Enterprise TAC and that's with P1.   Wondered if any updates or unofficial beta firmware.  Speed is not a deal breaker, but would like more VPN options.

Cisco Chat already gave me VPN misinformation about the product during my pre-sales chat.  I tried to go "cheap" and hoped the product lived up to the data sheet.  I am seriously re-considering an ISR or ASA5505.  Luckily, I bought it from a premier reseller so not gray market.  I know the ASA5505 will meet my current/future VPN needs, but guessing it is approaching EoL.  At $600, I hate to buy at tail end of roadmap.  Trying to justify ROI for personal use at home.

As our local Cisco SEs say, need to understand the limitations of the SB product line...

Lionel, look in to the newly release ISA500 series. It supports anyconnect and should scale well to an ASA5505.

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts


Thanks.  Didn't see the new ISA line.  Saw the older SAs.  Returned the RV042G to CDW.  Had to special order the ISA from CDWG.  Anyconnect support was the deciding factor.  I didn't expect a lot from the RV line, but still don't know how it did 500-600Mbps in a review.  The lack of VPN client support was the deal breaker.  I was misinformed on the supported VPN features.  Looked at all the docs for the ISA and it looks like a good, next gen SB product.



I am facing the same problem as the TS stated. I am using Cat 6 and my fiber speed is capable of more than 200mbps and a speed test done is nothing more than 130mbps. Besides this, user could not even change the value of the upstream and downstream of anything more than 100mbps. Could it be a firmware bug?

Frank, there are some documented issues with this. If you'd like to persue it, call the SBSC. Some important details which would be required include

-Who is the ISP

-Model of the modem

-Service level agreement (prove you have this service and what is expected)

-Speedtest bypassing the router (screen shot)

-Speedtest through the router (screen shot)

In the past I have escalated a couple cases for this problem since it is easily provable.

Please mark answered for helpful posts

-Tom Please mark answered for helpful posts


The thread is started by me.

I could not find any solution for my case.  Cables, ISP, other devices works great with other brand routers, but not with the RV042G.  Anyway, I am tried of troubleshooting.  Purchased another brand router, problem is fixed, with great VPN throughput.

Hi Wen Li Huanq,

I was thinking to buy the rv042G to replace my RV180 router (Too much problems with rv180), after read your post, I decided not to go for the rv042G. What is new router that you bought to solve you problem? I would like to see if it can fix my problem too.

Thank you,

I'm also interested in the replacement.  I need better VPN throughput.

Huntsville's Premiere Car and Bike e-magazine:

Huntsville's Premiere Car and Bike e-magazine:


What the hell this router is!  I bought it before seeing this comment!  I just found it's restricted to 100M!  My broadband is 500M but I can only use 100M now!  The configuration of up/down stream should be the key item to restrict it and it's not like what the Cisco guy claimed. 

Any feedback from Cisco?

Since everyone else already returned theirs, try this--put 0 in for the bandwidth and see what happens.

Huntsville's Premiere Car and Bike e-magazine:

Huntsville's Premiere Car and Bike e-magazine:


I would like to update this thread because I got couples of query about the status.

I already gave up this device for a long time, limited througput, unstable VPN link...many problems that cannot be fixed.  I am now using another device and happy with it.  Never need reboot except firmware update!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers