cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1059
Views
9
Helpful
6
Replies

RV082 Asterisk PBX

GlennStile
Level 1
Level 1

Evening all,

I'm having a real headache getting our asterisk based pbx to work correctly behind out new RV082.  If i have just one Wan connection up its fine but as soon as it is set in load balancing mode both connections up I get one way audio.

I've tried every method I can think of to bind the PBX IP to Wan2, (where i would like to keep the voip traffic) but nothing seems to work reliably

the RV082 is running in the latest v4.2.1.02 firmware, PBX is connected on port 8, priority is set to high, with a static ip of 192.168.1.65

both wan1 and wan2 have static ip address, setup with a pppoe connection, manual MTU of 1452 (ISP recommend).

the sip_nat in the PBX is set correctly to use the wan2 static ip with NAT enabled.

I have tried protocol binding the voip service ports to and from the pbx with the destination as wan2 ip, also with the destination as the trunk provider. I have tried binding all traffic from the PBX to wan2 in the firewall configuration, still it wont work.

It really shouldn't be this complicated, can anyone suggest anything i might be missing??

any suggestions gratefully received

1 Accepted Solution

Accepted Solutions

Tom Watts
VIP Alumni
VIP Alumni

Hi Glenn, the destination of the protocol bind should be 0.0.0.0 and also try to specify all services. Additionally, all telephones should also be bound to WAN 2 not just the server.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

View solution in original post

6 Replies 6

Tom Watts
VIP Alumni
VIP Alumni

Hi Glenn, the destination of the protocol bind should be 0.0.0.0 and also try to specify all services. Additionally, all telephones should also be bound to WAN 2 not just the server.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Thanks Tom,

That is the last method I had tried and was having some success (does this look correct)

however even with these settings I was still getting traffic from 1.65 on ppp1 (not just DNS querys), I'll go and bind the phones, hopefully that will fix it,

In your experiance is that all that should be required ??

Hi Glenn, the last rule should be sufficient. You can make a similar rule for every telephone you plan to have on the LAN.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Cheers Tom , Looks to be working well now,

One last thing...with regards to QOS for Voip is there any best pratice documentation for these routers?  I'm currently using 'Priority' based 'Upstream' for the Voip services and its working ok but traffic is low on a sunday.  I'm wondering if there is a better method you can suggest ?

Thanks again

Hi Glenn, what you have set up is fine. This will basically ensure the discriminated traffic has a priority for the amount of available bandwidth.

The biggest concept to grasp is you may only control your LAN. Once the traffic leaves the router interface all of the traffic is equal. So the best you can do for yourself is make sure the traffic leaving the WAN interface has enough space infront of everything else, anything more is beyond your control without paying a whole lot of money to the ISP.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Great , I'll leave as is for now then, Were using the G729 codec for the main external trunk which runs at 8kbit/s per call, I'm waiting for the wan2 ADSL interface to be changed to Annex M which should give plenty of bandwidth.

fingers crossed for monday moring

Thanks again Tom