cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3223
Views
0
Helpful
7
Replies

RV180W Hostname ping between VLANs & differents subnets

brunozoya
Level 1
Level 1

Hi,

I got an RV180w with 1.0.3.10 firm. Like the name post says, I'm not able to resolve hostnames between differents VLANs that have assigned differents subnets, for example, lets said that I have the next hosts:

CASA:

192.168.241.100/25 (Wired - VLAN 1)

Router: 192.168.241.1

DNS: 192.168.241.1

XBMC: 192.168.242.100/25 (Wi-FI - VLAN 2)

Router: 192.168.242.1

DNS: 192.168.242.1

If I try to ping from both sources to any of two destinations, the only that I get is an "unreachable" message.

An extra information, Allowed the routing between vlans & proxy DNS, and If I try to look the hostname under the "nslookup" command, I couldn't resolve the hostname but if I do a "ping -a 192.168.241.100" it says "Response from CASA (192.168.241.100) bla bla bla"

So what I'm missing here?

1 Accepted Solution

Accepted Solutions

Hi  Bruno, typically you cannot resolve host name from different subnet because the host does not know about the subnet which treats it as a security measure.

Disable the firewall capability on your computers and that should fix it, if not you'd probably need to modify the lmhost files.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

View solution in original post

7 Replies 7

brunozoya
Level 1
Level 1

Some help here please...

lariasqu
Level 1
Level 1

Hi Bruno, thank you for using our forum, my name is Luis I am part of the Small business Support community.

Please verify these important Steps.


1)      Check if the Intervlan box is enabled in Networking > LAN (Local Network) > VLAN Membership, also make sure the Vlans that you want to connect are selected.

You could see this article for more information http://www6.nohold.net/CiscoSB/Loginr.aspx?login=1&pid=2&app=search&vw=1&articleid=2152

2)       Check if the SSID from Vlan2 wireless Isolation is disabled in Wireless > Basic Settings.

You could see this article for more information http://www6.nohold.net/CiscoSB/Loginr.aspx?login=1&pid=2&app=search&vw=1&articleid=2877

I hope you find this answer useful

Greetings,

Luis Arias.

Cisco Network Support Engineer.

Hi Luis,

First at all, thank you so much for your time. Now I will give you a real example of what's happend on my RV180W:

Step 1: Configuration of LAN (Vlan 1) and WLAN (Vlan 2)

All they with intervlan enabled, and VLAN ID 2 as "Tagged"

Step 2: Configuration of SSID

Enabled on VLAN ID 2 without "Wireless Isolation"

Step 3: Checking all network hosts

See that Bruttus-desktop belongs to VLAN ID 1 because has a 192.168.241.x wired address and PC-Altillo has 192.168.242.x wireless address. So both may be reached with intervlan routing.

Step 4: Result of ping

As you can see, if I try to resolve the hostname nothing happened but if I do a "ping -a" resolves its hostname.

Do I'm missing something?

Once again thank you!

brunozoya
Level 1
Level 1

Someone who can test this issue?

Thanks.

UPDATE

HELP PLEASE!

lariasqu
Level 1
Level 1

Hi again Bruno, sorry for the delay.

Please, follow these steps:

1.Go to Network -> LAN (local Network) -> Vlan Membership

2.Check Vlan 1 (default) and Vlan you created.

3.Check intervlan and management

4.From vlan 1 dropdown box choose "Tagged" on a different port you are connected, and for vlan2 you created to "Untagged" on the port you want to assign the vlan

5. Click Save

That should fix this issue with your communication between Vlans.

I hope you find this answer useful

Greetings,

Luis Arias.

Cisco Network Support Engineer.

Hi  Bruno, typically you cannot resolve host name from different subnet because the host does not know about the subnet which treats it as a security measure.

Disable the firewall capability on your computers and that should fix it, if not you'd probably need to modify the lmhost files.

-Tom
Please mark answered for helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/