Showing results for 
Search instead for 
Did you mean: 

rv220w UPNP

Changelog for FW v does not address any issues with UPNP. UPNP was not working on my rv220w with the fw and is still not working with the fw. I have tried varrious advertisement intervals and durrations in the siscovery UPNP section of the setup with no progress. Does CISCO have a VPN router that UPNP works with? Why can't you get all of the advertised features of your products working over a year after the product has been released? I thought everything should work before it goes out the door and users who pay for products should get what is advertised?                  

4 Replies 4


We had issues with our RV220W not successfully starting UPnP after reboots.  In order to get UPnP to work we had to turn UPnP off then back on again in the GUI after each reboot.  We had to remove the RV220W for this very reason.

We moved on to the SA540.  We are currently running a Beta version of firmware ( which I was told is due out in mid-September.  We have no outstanding issues with except for the Verisign VIP trial not working.  It is a known issue, and they are working on getting it working in this release.

The SA540 has been a great router for us.  UPnP is solid.  You will not find UPnP in any higher end Cisco router.  UPnP is considered a security rish (for good reason), but we use it open/close passive FTP ports on the fly.  It's proprietary software and works great.  All other FTP server software I am familiar with leaves passive FTP ports open at all times.

Based on some of the reviews and comments on the SA5x0 routers they look like they have the same poor support from CISCO.

Thanks for your input though.


I also meant to comment on UPnP still not working on the RV220W with the latest firmware.  I had a discussion with another forum member regarding all this, and he said he had a Beta version of firmware that fixed UPnP.  That *fix* must have not made it in the latest release.  I don't know how it could have been *lost*. 

At first I thought that this issue was fixed because on the relevant configuration page the router does display the ports automatically opened by UPnP. However, after testing them I found out that they are not really open, they only appear to be! So, this indeed remains an issue for the latest firmware release.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: