Showing results for 
Search instead for 
Did you mean: 

RV325 Login Issue After Upgrading to


I am receiving a "403 Forbidden" error after upgrading my RV325 from firmware to It happens when I navigate to the admin web interface and enter the correct credentials to login. I have tried power cycling the router without success. The full error is:


You don't have permission to access /cgi-bin/ssi.cgi on this server.



50 Replies 50

Did you reset to factory defaults and configure from scratch after upgrading?

Yes, resetting the router to factory defaults fixed it (used paper clip to press "reset" button on the front of the device for ~10 seconds). I then had to setup the router from scratch which wasn't too difficult since it was a rather simple configuration. Luckily this was not a production environment. I will wait until Cisco fixes the issue before deploying it to any production environments. I've upgaded multiple RV325s to multiple newer firmware versions, but is the first time I've run into a problem.

As always:

  • Make sure you have a backup of the configuration saved before performing a firmware upgrade
  • Make sure you have a backup of the current firmware (the same version that you made the backup on) in case the firmware upgrade fails and you have to downgrade the firmware and import the configuration backup.


Same problem here after the update but on a RV320.

Able to connect from Safari only. IE11, Chrome and Edge, none of them able to reach the login page.

Entered with Safari and change the firewall to "enable https". Now I am able to connect from all devices but with the certificate error on it all the time.

I have this same problem as well. The firware broke the log-in capability.

Thanks for the tip about Safari working. I also upgraded from to and received the forbidden login message cited above. This was duplicated with IE, Edge and Chrome. I used Safari on my iPhone, which allowed me to login.


Yes, resetting to factory defaults will overcome this error, but I found a different work-around that may help someone else, especially if you don't want to go through the hassle of reconfiguration. I suspect that the breakage is because of the removal of the SSL VPN, which housed user groups in its settings. Just to try it, I went to User Management and changed the password of my administrator user. This cleared the error and I was able to login from any browser. No reset or reconfiguration necessary.

Same issue here with an upgraded RV320. Thing is that I cannot connect to the router from my iPhone's browser and as a consequence have no access at all to the router's GUI. Any idea on how to solve this without factory reset ?

New hint : this issue might be related to VLAN. If connected directly to the router (DHCP via LAN port), I can access the GUI. When on my office network (VLAN) I received the error message (You don't have permission to access /cgi-bin/ssi.cgi on this server.)

I can confirm that this issue arise if you configured some VLAN's on the router. I've 2 VLAN : id=1 & id=250. When my computer is connected to the 250 VLAN, I received the error message and have no access to the GUI. When my computer is connected to the 1 VLAN, it works fine and I've full access to the GUI. I enabled the inter VLAN routing on my 250 VLAN and now have access the the GIU. I dont know what are the security impact of this change but I'll live with it for the next coming weeks.

I hope this helps.

I too had VLAN's setup (5 of them, including VLAN1). That's interesting as I did not try this. However, making a change to the Administrator account under User Management, such as changing the password, allowed login from any VLAN without having to make any other changes.

Well, I'll try to change the password tomorrow, indeed and see if it gets better with the original configuration (no inter VLAN routing). But I couldn't do it as I has no access to the GUI…

Since I did another hard reset, I am not able to access the RV320 at all. With firefox, says something about a trusted certificate.

When I checked the changes in the new FW, I noticed something about including Romania into the list with certificates.

So, as long as I am from Romania, is it possible to have a relation between this change and the problem of not accessing the cgi.

No hard reset is able to solve the problem and, as long as I am not able to enter the router, I cannot perform any change.

Another stupid ideea from Cisco: when hard reset (Factory defaults), the SSH/Telnet is disabled by default, so no possible access with telnet or something similar on a bricked router.

No normal person is performing a hard reset for fun but only when in trouble so it is logic that after a hard reset to have a default access on Linux and not the contrary.

I don't use Firefox, but I imagine you can accept/bypass the certificate warning. Every other browser I've used allows you to do this, although they all have different methods. 

After several atempts, a skilled friend of mine managed to access the GUI through tftp but, even after re-installing the new FW, the GUI was not accessible from windows.

The only solution was to downgrade to previous FW ( He did this 3-4 times and, everytime when FW was installed, did the same. So now I am on old FW.

I checked the ceritifcates and seemed OK. Is the only original one.

I had this issue also. Changing the Administrator did not fix the issue for me.  I was able to login to the router using a VLAN with DHCP enabled.  (THANK YOU Gregu!).  I then enabled the inter VLAN routing.  I could then login using the GUI.  I then disabled the inter VLAN routing.  No issues after that.  I now disable the VLAN routing before updating the firmware.  

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers