cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2053
Views
0
Helpful
9
Replies

[RV340] Random disconnects with dual wan configuration

stroper
Level 1
Level 1

Hello there!

 

I have connected two ISPs to RV340.

  • ISP1 with PPPoE (Public Dynamic IP) to WAN1 and ISP2 with Static IP (via bridge mode on ONT) on WAN2.
  • WAN1 is set to receive DNS servers from ISP PPPoE DNS servers.
  • ISP1 refreshes public dynamic IP every 24 hours or so.
  • WAN2 is set to ISP2 provided DNS servers. DNS servers are responsive, but I haven't tested latency though.
  • Enabled network detection on both connection and configuration was successful.
  • Enabled load balancing by giving 50/50% to both WAN1 and WAN2.
  • Connected Wireless AP to LAN 1 for wireless coverage.
  • Firmware of RV340, Wireless AP, Surface Book 2, Surface Dock are up to date. Windows 10 is up to date.

ISSUE:

  • After enabling load balancing, I have observed frequent disconnects during web surfing. Web pages are not rendering and browser throws NXDOMAIN errors. After couple of refreshes, the page loads fine. For example: google.com failed to load in the browser and received NXDOMAIN error. Ping failed to google.com. After few seconds, both worked.
  • Wireless AP reported that it lost access to Wi-Fi during the time.
  • I haven't noticed the issue when the load balancing feature is disabled.

VLAN1 DNS settings are set to default.

Is this due to different DNS servers being set to each WAN connection?

Should I have to set same DNS servers for both WAN connections?

 

I thought of setitng up pi-hole or adguard home on Raspberry Pi and update both WAN connections with Raspberry Pi as DNS server. Befofe I go with that route, I would like to get expers suggestion.

 

Any further help/advise would be greatly appreciated.

 

Thank you.

9 Replies 9

nagrajk1969
Spotlight
Spotlight

Hi

 

>>>Enabled network detection on both connection and configuration was successful.

1. Just a point to Note for reference: If you had noticed/recalled, when you were configuring the network-service-detection (under WAN/Multiwan/ page) for WAN1 on which PPPoE-client is configured, you would have noticed that by default when pppoe-wan is configured on a wan interface, the NSD service is set to disable/unchecked....

- this is becos the pppoe-interface has its own built-in health-check of its link using lcp-echo-requests/lcp-echo-replies...and therefore NSD is not required and not enabled for pppoe-wan interfaces...becos it creates issues of link-flapping...

 

2. So my suggestion is you should immediately disable NSD services on BOTH wan1 and wan2 (eventhough its a static-ip wan) interfaces AND do a apply in both cases AND also do a permanent-save to starrtup-config AND reboot the router once

 

3. Also later, if you have a linux-host in the lan-network, enable the rsyslogd/syslog-server on it and in the RV34X enable and configure the offload/send logs to syslog-server feature. 

- then you may simply check the syslog/logs on the linux-host using the cat/vi commands...or better would be to use the "tail -f /var/log/syslog" 

 

So first do the above, and observe for any further issues...

 

 

 

Thank you so much for your prompt advise. Does disabling NSD impacts load balancing configuration as I have enabled load balancing with 50/50% setting?

nagrajk1969
Spotlight
Spotlight

>>>Does disabling NSD impacts load balancing configuration as I have enabled load balancing with 50/50% setting?

No. it wont have any impact on Load-Balancing traffic (especially since its a pppoe-wan interface and NSD is anyways supposed to be disabled for pppoe-wan interfaces by default and design)

 

 

I made changes and rebooted the router. However, I am still getting intermittent DNS failures.

 

I tried to access amazon.in from the browser and it throws NXDOMAIN error. I tried to nslookup and ping the domain and it's failed. After few seconds, I was able to do both successfully and able to load the amazon.in in browser as expected.

 

Microsoft Windows [Version 10.0.22000.258]
(c) Microsoft Corporation. All rights reserved.

C:\WINDOWS\system32>tracert superuser.com
Unable to resolve target system name superuser.com.

C:\WINDOWS\system32>tracert superuser.com

Tracing route to superuser.com [151.101.193.69]
over a maximum of 30 hops:

  1     2 ms     2 ms     2 ms  router91A24C.home.arpa [192.168.1.1]
  2    41 ms    47 ms    17 ms  abts-ap-static-1.16.230.223.airtelbroadband.in [223.230.16.1]
  3    18 ms    17 ms    18 ms  202.56.234.85
  4    32 ms    32 ms    32 ms  116.119.61.119
  5    42 ms    42 ms    42 ms  167.82.128.128
  6    37 ms    32 ms    31 ms  151.101.193.69

Trace complete.

C:\WINDOWS\system32>nslookup amazon.in
Server:  router91A24C.home.arpa
Address:  192.168.1.1

Non-authoritative answer:
Name:    amazon.in
Addresses:  52.95.116.115
          52.95.120.67
          54.239.33.92


C:\WINDOWS\system32>nslookup www.amazon.in
Server:  router91A24C.home.arpa
Address:  192.168.1.1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to router91A24C.home.arpa timed-out

C:\WINDOWS\system32>nslookup www.amazon.in
Server:  router91A24C.home.arpa
Address:  192.168.1.1

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to router91A24C.home.arpa timed-out

C:\WINDOWS\system32>ping www.amazon.in
Ping request could not find host www.amazon.in. Please check the name and try again.

C:\WINDOWS\system32>ping www.amazon.in

Pinging e15322.a.akamaiedge.net [23.45.165.66] with 32 bytes of data:
Reply from 23.45.165.66: bytes=32 time=7ms TTL=57
Reply from 23.45.165.66: bytes=32 time=6ms TTL=57
Reply from 23.45.165.66: bytes=32 time=8ms TTL=57
Reply from 23.45.165.66: bytes=32 time=11ms TTL=57

Ping statistics for 23.45.165.66:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 6ms, Maximum = 11ms, Average = 8ms

C:\WINDOWS\system32>nslookup www.amazon.in
Server:  router91A24C.home.arpa
Address:  192.168.1.1

Non-authoritative answer:
DNS request timed out.
    timeout was 2 seconds.
Name:    e15322.a.akamaiedge.net
Address:  23.45.165.66
Aliases:  www.amazon.in
          tp.c95e7e602-frontier.amazon.in
          www.amazon.in.edgekey.net


C:\WINDOWS\system32>

I have DDNS configured for both WAN1 (Dynamic public IP) and WAN2 (Static Public IP).

VPN is not configured.

Any recommendations?

I see the following in the logs:

 

2021-Oct-28, 05:09:46 IST
error
network
ddns: wan1p:unable to resolve xxxxxxx.dynns.com.

2021-Oct-28, 03:29:15 IST
error
system
asdclient: ASD Client failed to check updates.

2021-Oct-28, 03:29:15 IST
error
system
asdclient: ASD Client send request for Metadata failed.

2021-Oct-28, 03:18:24 IST
error
web-filter
Webfilter: Calling poller creation .

2021-Oct-28, 03:17:59 IST
critical
vpn
xl2tpd: setsockopt recvref[30]: Protocol not available

nagrajk1969
Spotlight
Spotlight

ok...

- the error log about ddns on wan1 is about the dyndns-client trying to connect to the dyndns-update-server (by its fqdn), but its unable to resolve the fqdn to the ipaddress becos the ISP1-dns server is not able to resolve it when dns-request is being sent to it from wan1...

 

 

 

can you do the below steps please?

 

1. edit both wan1 & wan2 AND in both set the 

dns1 statically as 8.8.8.8

dns2 statically as 8.8.4.4

 

- the above are Google's public dns servers

- do this on both wan interfaces

- apply and save

 

2. Next in the dhcp-server settings on lan interface/vlan1, set the dns to "Use Dns Proxy"

- apply & save

 

3. Lastly in SystemMnt/System, 

- the system name will already be present..either continue or change

- but the domain will be blank by default, so enter either your registered domain-name if you have any, OR give a value such as "test.local" or "myhome.local", dont leave it blank

- apply & do a permanent save too

 

---------------------------------------

Now ensure a dhcp-renewal on the windows/linux lan-hosts....and then try to browse the net...and check the net connection

 

Note:The ddns updation is independent & separate from your internet access

 

 

 

Sure.

1. Applied Google DNS servers for both WAN1 and WAN2 profiles.

2. Ensured that DNS Proxy was set for VLAN1 (it's already set to default settings).

3. Domain name is already set to "home.arpa' during setup.

I have attached screenshots of WAN configuration.

 

nagrajk1969
Spotlight
Spotlight

Hi

 

i forgot to mention in addition to above cobfigs to be applied...can you please post a screenshots of your configs in multiwan page?

 

i want to see the load-balancing settings that you have applied...

nagrajk1969
Spotlight
Spotlight

your configurations (posted by you) are absolutely correct

 

Cool. DNS request time out errors were reduced by around 90% since I made changes that you have recommended. I will monitor for another day and update this thread with result.

Thank you so much for your kind help!!