Showing results for 
Search instead for 
Did you mean: 

RVL 200 Unable to install Virtual Passage under Vista Business and Windows 7


We use RVL 200 to establish VPN connections. Now we have the problem that no VPN connection is established.

The same problem with Windows 7, but also with Vista Buiness, using administrator account, IE8, trusted sites, ActiveX enabled ...
Message: Virtual Passage Setup:
Error: Virtual Passage not installed. Please install as administrator.

thx for help, greetings,
Herbert Gerstbauer.

21 Replies 21

Te-Kai Liu
Rising star
Rising star

RVL200 Virtual Passage should work with Vista Business. If it does not work, please contact the Small Business Support team for further troubleshooting.

NO, it doesn't work with Vista Business.

how to contact the Small Business Support team?

please give us a link or mail address.



does someone got a response from Cisco support so far or does someone know if a new firmware is on it's way?

My first customers are also switching to Windows7 and are more than annoyed that the SSL-remote is not working anymore.

No firmware update available and the customer is not able to downgrade because of this.

From customer side view that looks very negative for Linksys/Cisco at the moment and of course they are treating me because I've sold them crab :-(

Best regards


Alejandro Gallego
Cisco Employee
Cisco Employee
  1. Open Internet Explorer.
  2. Click Tools.
  3. Click Internet Options.
  4. Click the Advanced tab.
  5. Select Use SSL 2.0 and Use SSL 3.0.
  6. Click the Security tab.
  7. Click Custom Level.
  8. Select Enable for the Active scripting, Allow paste operations via script, and Scripting of Java applets settings.
  9. Go to Internet Options > Privacy > Advanced
  10. Deselect (remove the checkmark from) Override automatic cookie handling.
  11. Click OK all the way back out.

Can you verify you have these settings already configured? Did I understand that everything was working fine with Vista but then stopped working?

When you connect to the webpage and click on the Lock, you obviously get the drop down box in IE asking you to install active X; when you click to allow do you get a pop up window with the buttons; "Install" and "Cancel"?

All settings are as you mentioned, when you click on the blue lock you get the following error, see image below


I get exactly the same error message.

After click on OK it follows: "Virtual Passage Driver uninstall Failed."

With Vista Business the problem could be solved by deactivating UAC (User Access Control) in user management during first installation.

With Windows 7 deactivating UAC does NOT work!

It's really time now that Cisco deliveres a solution for that!

H. Gerstbauer.

Wow, so far I used RVL200 with Firefox but now I tried again on my WinXP-Pro-SP3 and IE6!!

And it's also not working with the above method.

After pressing the blue lock I get the popup to install regardless of the signature and that was it.

In the bottom-left corner I get the error symbol with the error from the image.

So, I would swear that this worked sometime before. So it seems that something in whatever update makes it impossible now...




cindy toy
Rising star
Rising star


I suggest you call the Cisco Small Business Support Center to open a case so that they can help troubleshoot this for you.

The phone numbers in your area are located here:


Cindy Toy

Cisco Small Business Support

Community Manager

Regards, Cindy If my response answered your question, please mark the response as answered. Thank you!


It worked fine for me under 32-bit Vista Business, from IE or Firefox. It doesn't work on either under 32-bit Windows 7 Business.

Under IE, I get a message that the Active-X program cannot be installed because the publisher is unknown, I looked at the certificate, and it expired in 07/09.

Under Firefox I get a message that Virtual Passage is only supported under XP, Win 2003, etc. No mention of Windows 7.



That's unbelievable Cisco forgets the new Microsoft operating system. My client use Seven pro 64 and IE8. Impossible to start a SSL VPN connection. I’ve removed the RVL200.

I Have several Windows XP users that have lost the ability to log in to the office Network as they have upgraded to Windows 7 Pro, when are we going to see the new firmware to address this issue, it was promised before the end of first quarter 2010, which is just about here.

The Router is less than 5 weeks old, I just do not understand why the support issue is so lagging. In the interim I had them install RealVNC to access the network, but only as a temp fix, please Cisco lets have that new firmware.

Yes, I can just underline this demand!!!

As a Linksys/Cisco Partner I placed the RVL200 at customer's site and the customer stayed calm so far because I told him an update is in progress for March.

But now he is willing to push on me that I have sold him crab! :-(

He has the same problem having XP first and now some users with Windows 7 and they can't access any more!



I just installed new firmware v. Will report back after testing is done.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers