Showing results for 
Search instead for 
Did you mean: 

WRVS4400N is interfering with Windows7 HomeGroup (NetBIOS?) on wireless links(?)


I have been using Windows7 (64bit) on all my network computers for some years now. One main computer is connected directly to the LAN port, and 4 via WLAN. Three more LAN ports are used for some VoIP equipment (non-Microsoft). All the Windows7 computers were connected via HomeGroup and were working impeccably. This was true as long as I used my old Linksys WRT150N Wireless-N router.
I recently decided to upgrade it to WRVS4400N so I would be able to use VPN for remote access. For the simplicity of the migration, I configured the WRVS4400N to have the same SSID and the same IP ports assigned exactly as it was on the WRT150N. I set only the default VLAN (I plan to add a second VLAN for guests that will be allowed to access the internet only), and I enabled WMM on the wireless, as I also have wireless VoIP handsets.

The swap was easy, and except for an issue I had with the “SIP Application Layer Gateway” that caused the WRVS4400N to hang, I had no issues. (I disabled the ALG as it was not really required).

After some time I noticed that I do not see all the HomeGroup computers, and I fail to communicate with them even when I enter \\hostname in the explorer address box. It worked well for a short period after I restarted both computers, but after a while I started having problems again. I thought that it would be wise to re-establish the HomeGroup, as there must be something different on the new network after all, and the old HomeGroup is not handling it well. So I had all my computers leave the HomeGroup, and I setup a new HomeGroup on the main computer. Now none of the other computers could join the new HomeGroup.
I contacted Cisco support, and the support person had me ping the ports, and claimed that if I can ping the ports, I could pass any other type of messages. This caused me to come to the conclusion that I must have somehow corrupted the Windows HomeGroup by resetting it. Especially since the Windows error message said “Windows cannot set a HomeGroup on this computer”. I spent two days on the Windows forums and tried all the tricks they suggested to recover the HomeGroup, but all failed. The other computers would not connect to the new HomeGroup, and in some cases they did not even recognize that there is a HomeGroup already set on the other computer.
Finally it crossed my mind to try to connect the Windows computers back to the old WRT150N. Once the computers were connected back to the WRT150N it took me just seconds to have all the computers join the HomeGroup with no issue whatsoever.
So now I am back to square one. The computers are connected to the WRVS4400N and have trouble connecting with sometime after they are booted. And I also learned a few things:

  1. The Windows7 HomeGroup has no bugs I could blame.
  2. The WRVS4400N interfered with the messages that had to take place between the computers, and thus prevented them from joining the HomeGroup. The WRT150N handled these messages correctly.
  3. The WRVS4400N’s interference with these type of messages (NetBIOS?) is causing the computers to be unreachable after a while.
  4. I have not tried to connect more than one computer to the LAN port, so I don’t know that for sure, but from looking at many other discussions, this may be a problem that is unique to the wireless link of the router. I also learned from these forum messages, that my problem might be a common problem to more models, and even more makes of wireless routers.

So here is the question: what functionality is missing or got corrupted on the new models (such as my WRVS4400N) that the old models (such as the WRT150N) could handle correctly, and is there a setup configuration or parameter that need to be set, that could solve this issue. Your input and support would be appreciated.

21 Replies 21

I have intermittent issues with Bonjour working consistently all the time.

This is the same type of multicast discovery process and it's hit or miss frequently.  I'll have wired devices that usually find other wired and wireless devices but not always.  Some wireless devices that usually find other devices but not always.  Some wireless devices that will fail consistently, but if you shut off wifi, wait a few seconds then turn it back on, they'll find other devices again.  Some wireless devices whose visibility comes and goes at random.  Some wireless devices that even when they're visible to others, cannot be see any other devices.

Because I have all of the devices that need to be found at specific DHCP addesses set in the router, I can normally find them with a direct connection even when the Bonjour search fails to find them to see that they are up.  Which doesn't hlep when the application that needs to find them only support the Bonjour discovery that's not working.  Any times the direct connection also fails, is a time the wireless client has been dropped from the network, just because.

Every time it happens, I think about replacing the router now.

Hi Matthew,

I researched your issue and found only one other case that was very similar and it was resolved with an RMA of the device.

Please call us at 1-866-606-1866 with your serial number and we will be happy to assist. After an initial assessment of the issue and typical troubleshooting, we can get this resolved for you.

Thank you and have a great day!

It's not worth the effort and shipping cost to RMA the unit.

I've had other issues with it where connecting a Nook Color to the WiFi causes the router to crash every time.  Or at least it did on a prior version of the Nook Color software, we haven't tried again once the device was assigned to a different wireless network instead.

I've also had issues with a WAP4410N operating as a bridge in either Client mode or WDS bridge mode where it would often disconnect.  Other errors on the router's log would also show up intermittently when the WAP4410N was connected this way, sometimes causing the entire network to slow until the WAP4410N was power cycled.

I've tried many different settings and all of the work arounds others have posted for the two devices and both have the most current software.  I never found a combination that lasted more than a few days, frequently less, and frequently much less once the problems manifested after the initial set up.

I've already replaced the WAP4410N with a different wireless bridge instead.  The other product isn't as robust or fast as the WAP4410N when it's working.  But the other product works consistently and has never decided to just drop off the network and it was a fraction of the cost.

If new software comes out before I replace the router for either device, I'll try them again.  But, really I'm more likely to replace the router first and simply recommend others do the same instead of investing time in this one.  Especially based on the time between software updates that still don't fix the basic issues.

It may even be that the WAP4410N will make a good bridge in client mode connected to some other router.  I was never able to figure out which side of the WAP4410N - WRVS4400N connection was really the problem.

Hi Kobi- I see the case was escalated to level 2. I will contact the technician regarding the case in hopes you will have a resolution sooner. I apologize for the delay but I will see if I can get the ball rolling for you.

Has this ever been resolved or acknowledged by Cisco? I have the exact same problem with my RVS4400N and I am rsearching non Cisco routers at this point unless I can find a fix.


No. This has never been resolved. Though I have debugged this issue and proven beyond any doubt that this is a router issue (failure to comply with some broadcast specs), Cisco said that they will not fix it as this is end-of-life product.

If you cannot ship your Cisco router back for refund, you may consider using OpenWRT firmware on it. Of course you can always buy a non-Cisco product as you said.

Hi Kobi,

The information you have provided here has been great for me, so thank you (especially for the wireshark stuff and the different router insight you provided). That detailed information finally put me on a track towards looking closer at the RSTP/STP port settings and the upnp setting on the WRVS4400n to fix an almost identical problem I was having with a 5 PC/2 printer LAN setup at a small business (all running Win7Pro 64bit or Win8Pro 64bit) using a standard windows workgroup and Xp compatible 40bit/56 bit password encrypted sharing.

I believe at the heart of your problem (and the one I just fixed) is the step up from Fast Ethernet (half duplex) networking to Gigabit Ethernet (full duplex only) and the need for spanning tree protocol enabled on ports, and the router/PCs to use upnp to tweak values for optimum discovery.

Before doing anything else, I went to each of the machines and reconfigured the services on the PCs relevant to workgroups, setting them to “automatic start” to ensure they'd be running again even if they stopped and started any that weren't already running (as listed on the link below, as previously provided by Misty Williams)

With upnp being listed within those service, I decided to re-enable upnp in the router, and to verify I hadn't accidentally setup some VLANs (which I hadn't), so I then proceeded to the RSTP section.

The group changes I made to the RSTP settings are as follows:

Hello Time: 1

Max Age: 6

Forward Delay: 4

Force version: Compatibility

And then I enabled the protocol on each of the ports and rebooted the router and machines to see if it fixed the problem so that all systems could see all systems in the network list without manually typing UNC paths.

It fixed the long standing problem of devices randomly disappearing from the network list and even UNC paths temporarily becoming unavailable, so it might be worth trying these options on your setup and even on the netgear you mentioned to see if it is the same problem for you.

This had been an on going inconvenience for the small business I installed and configured the WRVS4400n and fileserver for and they'd continued to work around for 8months. After replacing all the network cables and countless other wild goose chases I'd began to suspected it was caused by Sage Line 50's data thrashing(like a DoS attack on the router), or the PC's internet security suite updates changing services and personal firewall settings, or a sporadic routing information issue with the unknown business park router that was the gateway for the WRVS4400n's WAN port (on the other side of the hardware firewall). So hopefully this is another mystery solved, and thanks again for the information.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers