Showing results for 
Search instead for 
Did you mean: 

WRVS4400N total waste of money ?

Level 1
Level 1

I have bought the WRVS4400N hoping for a good router with VPN support. What a disappointment...

Here are the issues I'm facing, after searching for answers on the Internet I have come to realized I'm not the only one with those.

I hope Cisco will listen and help... sorry I work for an SMB so ... no.. I don't have a Cisco contract number...

1. I bought two of those... one for the office and one for home

a) Office issue:  WRVS4400Nv2 latest firmware

Intermittent Wi-fi loss for our Mac users (+- 20) on Mac Book Prod. Windows users are unaffected (+-20). Mac users and Windows users are all within 40 feet from Router in open space.  I have found others with similar issues.. and no… changing channels hasn’t fixed anything.

b) Home issue: WRVS4400Nv2 latest firmware

Can’t connect to XBOX Live we using WPA2 on XBOX… worked like a charm with previous routers from LinkSys and (Dlink… even though that one was the worst ever)

c) Office and Home issues: QuickVPN

The reason why I got this router was for the VPN support… I have to admit Router to Router VPN (both WRVS4400N) works fine. QuickVPN on Windows 7 x64 Pro is a whole different story… I just can’t get the QuickVPN to establish the VPN when running Windows 7x64 (I have Pro)… I read about all kind of things. I check the Windows 7 Firewall logs.. no drop packets (yes I did enable logging).. I read about my <internet provider who may be blocking IPSec> … so I got my Windows XP CD and installed a VM of XP on my Windows 7. QuickVPN runs and establishes connections just fine under XP.  I read about multiple interfaces on my computer who could be causing the problem.. so.. I disabled all interfaces but my Wifi … no change… Some say.. run it as Vista SP2.. did it.. no change… others.. grant it Admin privileges.. no change…

So…. When can we expect a working QuickVPN for Windows 7x64?

Any help would be great.. and FYI I read pretty much all the threads I could find on the QuickVPN subject.

6 Replies 6

Level 6
Level 6


I agree you have many things going wrong but can everything be blamed on the router. You agree that windows pc’s works fine with the router on the other hand Mac users are having problems. I have read in many Mac forums and noticed that Mac books had a lot of trouble with WPA2 security. Yes you tried changing channels but what else has been done? Did you change the type of security for the SSID? I have seen Mac books not like wireless mode B/G/N mixed. Try adjusting this feature and let’s see if this makes any changes. With WPA2 you can choose TKIP & AES Many Pc have trouble with both are enabled. B) don’t have an Xbox but I would also check connection from the Xbox with above suggestions. C) I like this question even through it’s the toughest one for customer to understand. All Qvpn is a tool to quickly help you configure the WINDOWS IPSec Client. Hints the reason it’s (FREE). I have tested Qvpn on 32bit, 64bit XP – Vista – 7. I have run into road blocks as you have, Qvpn just don’t want to connect. This isn’t the router fault rather PC related issue. 80% of the time it’s generally firewall, Anti-virus, or another 3rd Party program. The other 20% usually includes the router at the remote location or the WRVS4400N. I had an engineer that went above and beyond support with his customer, just as you the customer couldn’t get Qvpn to connect( Always getting remote gateway not responding) Well this error means the ping reply coming back from the router is getting blocked by the pc’s firewall or 3rd party program. I advised the engineer to disable Windows Firewall (making sure IPSec & IKE service was still running within windows). The engineer attempted the connection and it worked. The customer then was upset that we had to disable his firewall for Qvpn to establish. We advised the customer; NO you shouldn’t have to disable the firewall but something with windows7 wouldn’t allow that ping inbound to the application. Not WRVS4400N fault or Qvpn fault rather could have been an update from windows- I know we all like Microsoft updates. Could be another program that your vendor installed like HP, DELL etc; all these major manufactures comes preinstalled with all sorts of programs. This is why so many different customers are affected, it’s not just 32bit or 64bit, and it’s not just windows7 or Vista or XP. I have seen other programs installed on the Windows machine that caused register errors which broke Qvpn and the customer choose to do a clean install without all those other programs and Qvpn works suggest fine. Cisco can’t be reliable to support 3rd party programs like firewalls, antivirus or even Microsoft registries errors.

Hope this gives a little more insight from an engineer point of view.


sorry for "kidnapping" the thread, but i've some problems which are definitly router (or better router OS) based.

it's easy to ignore IPv6 related problems right now, but there will be more and more WRVS4400n and RVS4000 users who will try the IPv6 features they expect and have paid in their cisco producs. and i'm pretty sure that many of them will come here and will see that you got informed of the (mis)behaviours of your products and didn't change anything.

i'm pretty sure that a "backport" of some of the underlying software versions of the rv220/r120/r110 (which are highly promoted as ipv6 ready, BUT our old routers got ipv6 on their feature list too!) would fix most of the problems. i haven't seen a end of sale, and i think that i have got the assurance to get software updates for bugs in the firmware for EOS + 3 years.

further description of IPv6 bugs on my wrvs4400n v2: and


Hello Jasbryan,

I'm not sure why you are making the distinction between the router and the QuickVPN. Neither why you say that Qvpn is Free ?!

I bought a boxed router from Cisco, namely the WRVS4400N router and it came with the QuickVPN software. I paid for the router and AFAIK the required to setup the VPN is not documented and one has to use the Qvpn software to perform the proper setup. Nowhere have I seen in the doc that one has to initiate a request to the router through some undocumented hidden pages the like of:


Your comment is the same as a car dealer telling me he is giving me the car keys for FREE once I bought the car.

Now to go back to my problems. It's true that Mac hardware works best with other Mac hardware (aka AirPort).. that said our previous router had no problem with our mixed environment Mac/PC but this Cisco router has and that's based on the same Wifi settings (WPA2 Personal, Mixed G/N, Channel 6 etc). Now the XBOX problem seems also related to the use of WPA2 ... so different companies having the same problem with that router. Who's guilty? Microsoft and Apple? Also it seems ( I need to validate) that older version of the Firmware worked with XBOX Wifi.
>>Yes you tried changing channels but what else has been done?  Did you change the type of security for the SSID?
I tried pretty much everything and no, I did not write in my initial post all that I had done. Also, I refuse to downgrade the Wifi security from WPA2 to WPA.
>>I have run into road blocks as you have,  Qvpn just don’t want to connect. This isn’t the router fault rather PC  related issue. 80% of the time it’s generally firewall, Anti-virus, or  another 3rd Party program.
I'm with you, so you know what ? I installed a clean Windows 7x64 SP1 on a brand new VM.. and you know what... it fails... I hope you will not tell me that VM are not officially supported ?
>> Not WRVS4400N fault or Qvpn fault rather could have been an  update from windows- I know we all like Microsoft updates.
Ok, I ear you, so where can I find the exact specification, OS Level, Service Pack level on which QVPN will work ? Or what MS Update not to install to not break QVPN?

Breaking news... yesterday we played with our office router to add another VLAN, secondary Wifi-network and other "I really need to find out what was changed" configuration and well QVPN works !?!!  ... with the same stack of 3rd party unsupported by Cisco software (AntiVirus, Windows FireWall, MS Patches etc...) on my laptop!


Fantastic on the breaking news ! Under you pc look at your updates and when they occurred for the time tamps.

Now i put together a some information about qvpn for better understanding, 

Please note: Qvpn isn’t an actual IPSec client (which some don’t understand). This is a free utility that quickly and easily helps end-users to setup Windows IPSec client/services to connect to our routers. Therefore Cisco can’t be responsible for every pc related problem that doesn’t allow Windows IPSec client to successfully connect. Many customer do have trouble configuring their firewalls, antivirus, and 3rd party programs to allow the Qvpn utility to quickly setup connection using Microsoft IPSec client and connect successfully. Many engineers go over support and still assist the customer (Even though it’s not our client) in getting this connection up. Maybe the product managers will see this influence of some customer’s problems and add an updated firmware to existing platforms to support the (PAID) Cisco vpn client that makes the connection. Right now only the SA500-SRP540 routers in SBSC product line support the Cisco vpn client. Cisco vpn client is the actual client that terminates the connection. So when you bring up the network connections you’ll see a new adapter created by the Cisco vpn client (which bypassed windows firewalls and other windows policies).

** Knowledge is power **

Also wanted to mention that the majority of customers who have Qvpn problems get the response, (Gateway not responding).

When you get the message gateway not responding the tunnel is fully up and a ping is sent across the tunnel to verify connectivity. If the PC programs (Firewalls or 3rd party programs) don’t allow the ping back into the pc then we get Gateway not responding. This right away tells us that another application or pc firewall is blocking the echo reply. So a 3rd party application needs to be altered/configured to allow this echo reply into pc application so the tunnel handshake will complete. Cisco can’t be responsible for other applications. An actual client (like Cisco vpn client) avoids all this mess it creates a new adapter that bypasses windows firewalls and 3rd party applications.

Hope this gives a better insight


>> Under you pc look at your updates and when they occurred for the time tamps.

I did, I looked under my PC (Laptop in my case) and found my desk! :-)

Joke aside. I’m almost done with finding a solution to my current (known) problems.

I have found the problem with QVPN … Forget about my last comment on having made some modifications to the router config… nothing to do with it… my problem was that ICS was enabled on my network adapter… once ICS was disabled it worked like a charm…  The prob.. I really need ICS…

Now can I hope to get support from Cisco on how to get ICS enabled and QVPN perform the proper setup? You know what? I’ll ask…  and see…

Hey! Cisco how do I go about getting ICS enabled and QVPN working?!

Regarding my XBOX issue.. I created a secondary SSID with just the XBOX in it and using WPA instead of WPA2.

For the PowerBooks at work… still working on it.


Correct with ICS (Internet connection sharing) you sharing this network adapter with other device on the network. Sounds like you need a site to site tunnel between two locations. Qvpn is really for clients that are mobile and need a secure way to connect back to home location. Since you're needing to share your network adapter Qvpn utility for Microsoft client isn't going to be a good solution for you. You need an actual client (Cisco vpn) that creates a secondary adapter for connection. Creating a second SSID on the router would have been exactly what i would have done to solve your xbox issue. Glad we are making some head way on your issues.

**Knowledge is power**