11-21-2012 05:13 AM - edited 03-04-2019 06:12 PM
hello
i have 2 dsl lines and need to make 10.24.0.0/20 use line 1 an 10.24.16.0/20 use line 2
i have made this before but on layer 3 switch with a router almost the same configuration as a topology but now i want to make this on only cisco router
so what could be the problem ?
now 10.24.0.0/20 have internet but 10.24.0.0/16 can't get redirected to line 2 but in the nat table every subnet nat to the correct destination
and this is the running configuration :
ip source-route
ip cef
!
interface GigabitEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
no ip address
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
encapsulation dot1Q 1 native
ip address 10.24.0.200 255.255.240.0
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/0.2
encapsulation dot1Q 4
ip address 10.24.48.1 255.255.240.0
!
interface GigabitEthernet0/0.3
encapsulation dot1Q 3
ip address 10.24.32.1 255.255.240.0
ip access-group Guest-IN in
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/0.4
encapsulation dot1Q 2
ip address 10.24.16.1 255.255.240.0
ip nat inside
ip virtual-reassembly
!
interface GigabitEthernet0/0.50
encapsulation dot1Q 50
ip address 192.168.50.1 255.255.255.0
ip nat outside
ip virtual-reassembly
!
interface GigabitEthernet0/1
ip address 41.32.183.81 255.255.255.248
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip nat inside source route-map Line1 interface GigabitEthernet0/1 overload
ip nat inside source route-map Line2 interface GigabitEthernet0/0.50 overload
ip route 0.0.0.0 0.0.0.0 x.x.x.x
ip route 0.0.0.0 0.0.0.0 y.y.y.y
ip access-list extended Line1
permit ip 10.24.0.0 0.0.15.255 any
permit ip 10.24.32.0 0.0.15.255 any
ip access-list extended Line2
permit ip 10.24.16.0 0.0.15.255 any
i
route-map Line2 permit 10
match ip address Line2
set ip next-hop y.y.y.y
!
route-map Line1 permit 10
match ip address Line1
set ip next-hop x.x.x.x
!
Solved! Go to Solution.
11-21-2012 05:48 AM
Hi,
can you try this:
ip access-list extended Line1
permit ip 10.24.0.0 0.0.15.255 any
permit ip 10.24.32.0 0.0.15.255 any
ip access-list extended Line2
permit ip 10.24.16.0 0.0.15.255 any
route-map PBR1 p 10
match ip address Line1
set ip next-hop x1.x1.x1.x1
route-map PBR2 p 10
match ip address Line2
set ip next-hop x2.x2.x2.x2
int G0/0.1
ip policy route-map PBR1
int G0/0.3
ip policy route-map PBR1
int G0/0.4
ip policy route-map PBR2
no route-map Line2
no route-map Line1
route-map Line2 permit 10
match ip address Line2
match interface G0/0.50
route-map Line1 permit 10
match ip address Line1
match interface G0/1
Regards.
Alain
Don't forget to rate helpful posts.
11-21-2012 05:43 AM
You could add "set interface g0/0.50" to route-map Line2 and "set interface g0/1" to route-map Line1.
HTH,
John
11-21-2012 05:55 AM
i try this before but it doesn't solve the problem and also it gives me this warning
%Warning:Use P2P interface for routemap set
interface clause
11-21-2012 05:59 AM
Youssef,
Alain has the answer below. I read through your config so quick that I didn't realize the policy wasn't applied to your internal interfaces. Follow what he stated and you should be good to go.
John
11-21-2012 05:48 AM
Hi,
can you try this:
ip access-list extended Line1
permit ip 10.24.0.0 0.0.15.255 any
permit ip 10.24.32.0 0.0.15.255 any
ip access-list extended Line2
permit ip 10.24.16.0 0.0.15.255 any
route-map PBR1 p 10
match ip address Line1
set ip next-hop x1.x1.x1.x1
route-map PBR2 p 10
match ip address Line2
set ip next-hop x2.x2.x2.x2
int G0/0.1
ip policy route-map PBR1
int G0/0.3
ip policy route-map PBR1
int G0/0.4
ip policy route-map PBR2
no route-map Line2
no route-map Line1
route-map Line2 permit 10
match ip address Line2
match interface G0/0.50
route-map Line1 permit 10
match ip address Line1
match interface G0/1
Regards.
Alain
Don't forget to rate helpful posts.
11-21-2012 05:55 AM
LOL! I didn't even notice the route-map wasn't even applied...go me... lol..
11-21-2012 06:00 AM
TX man that was missing .
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide