cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

292
Views
20
Helpful
9
Replies
Beginner

2911 ISR Routing

Hello,

I have configured an ISR and currently have wan connectivity. I can ping 8.8.8.8 and cisco.com directly from the router. I have several vlans that can pull dhcp addresses. So I believe I should be good to go as far as setting it up for routing and internet connectivity. I understand there are several options.

NASA(config)#router ?
  bgp       Border Gateway Protocol (BGP)
  eigrp     Enhanced Interior Gateway Routing Protocol (EIGRP)
  isis      ISO IS-IS
  iso-igrp  IGRP for OSI networks
  lisp      Locator/ID Separation Protocol
  mobile    Mobile routes
  odr       On Demand stub Routes
  ospf      Open Shortest Path First (OSPF)
  ospfv3    OSPFv3
  rip       Routing Information Protocol (RIP)

In this tutorial https://www.cisco.com/c/en/us/td/docs/routers/access/800M/software/800MSCG/routconf.html#24575

I can see rip is my primary option as far as the tutorial goes. Is this the best way to set this up? Is there anything else I need to know about?

 

Thank you,

Nate

---------------------
"Fortune favors the brave."
▊▊▊
1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advocate

Re: 2911 ISR Routing

Hi,

As I am looking at your router routing table output it is looking that there are no VLANs and all VLANs are configured on the Switch only. So you have to add some more configuration as:

1. Add route (Static) route on the router toward to Switch SVI for Internal VLANs on the switch.

2. Add VLANs subnet in the NATing.

I think it is better to share the Router configuration along with the network diagram so we can suggest you with proper commands.

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

9 REPLIES 9

Re: 2911 ISR Routing

Hi,

The choice of Routing protocol depends on the scenario. You want to configure Router between different locations or devices ?

 

Where are the VLANs terminated ?  

Re: 2911 ISR Routing

Scenarios with single site setup, static and default routes will be good enough to provide the Internet reachability to the VLANS you have.

Beginner

Re: 2911 ISR Routing

My vlans are trunked to a switch locally. Nothing complex at the moment. Just to the internet.

---------------------
"Fortune favors the brave."
▊▊▊

Re: 2911 ISR Routing

How about the VLAN interfaces/SVI's? Is  it configured on the switch or on the Router ?

Highlighted
Beginner

Re: 2911 ISR Routing

The vlans are configured on both?

 

I'm currently stuck configuring routing.

NASA#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 172.16.1.254 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 172.16.1.254
      172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.16.1.0/24 is directly connected, GigabitEthernet0/0
L        172.16.1.63/32 is directly connected, GigabitEthernet0/0
S        172.16.1.254/32 [254/0] via 172.16.1.254, GigabitEthernet0/0

My isp isn't giving me that R I am looking for? Even though I am trunking everything to my 2911 do I still need to manually configure routes on my switch?

---------------------
"Fortune favors the brave."
▊▊▊
VIP Advocate

Re: 2911 ISR Routing

Hi,

As I am looking at your router routing table output it is looking that there are no VLANs and all VLANs are configured on the Switch only. So you have to add some more configuration as:

1. Add route (Static) route on the router toward to Switch SVI for Internal VLANs on the switch.

2. Add VLANs subnet in the NATing.

I think it is better to share the Router configuration along with the network diagram so we can suggest you with proper commands.

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

Beginner

Re: 2911 ISR Routing

Router:

NASA#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 172.16.1.254 to network 0.0.0.0

S*    0.0.0.0/0 [254/0] via 172.16.1.254
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.1.0/24 is directly connected, GigabitEthernet0/0
L        172.16.1.63/32 is directly connected, GigabitEthernet0/0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback0
L        192.168.1.1/32 is directly connected, Loopback0
      192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.2.0/24 is directly connected, GigabitEthernet0/1.1
L        192.168.2.1/32 is directly connected, GigabitEthernet0/1.1
      192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.3.0/24 is directly connected, GigabitEthernet0/1.3
L        192.168.3.1/32 is directly connected, GigabitEthernet0/1.3
!         
router eigrp 109
 network 192.168.3.0
!         
router rip
 version 2
 network 192.168.3.0
 no auto-summary
!     

 

Switch:

JPL#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.2.0/24 is directly connected, Vlan1

https://community.cisco.com/t5/routing/basic-configuration-for-cisco-isr-4331/td-p/2744906

The part about " ip route 0.0.0.0 0.0.0.0 dhcp" where would I assign that?

https://community.cisco.com/t5/routing/cisco-4331-router-no-internet-access/td-p/3356391 

I also see "ip nat inside" are these things I HAVE to add to the vlans?

 

From the 2911 I can ping google.com. From the router I can ping 192.168.2.2(the switch).

I can directly connect to the switch and get a dhcp to a switchport vlan from a dhcp server over 802.1Q on the router. From my host I can ping 192.168.3.1 but I cannot figure out how to route to the internet. If I am connected over trunked vlans I dont need to adjust routing on the switch do i? Its the router that does the routing to the internet?

 

---------------------
"Fortune favors the brave."
▊▊▊
Beginner

Re: 2911 ISR Routing

!         
interface GigabitEthernet0/1.3
 encapsulation dot1Q 3
 ip address 192.168.3.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
 zone-member security INSIDE
 no cdp enable
!  

Is this what you mean by add vlan subnet?

---------------------
"Fortune favors the brave."
▊▊▊
Beginner

Re: 2911 ISR Routing

https://community.cisco.com/t5/routing/cannot-route-to-internet-from-switch/m-p/4011632#M327783

I'm stubborn. Defeated by the day.

---------------------
"Fortune favors the brave."
▊▊▊
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here