cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4218
Views
13
Helpful
16
Replies

2921 router interface shows up and up but unable to PING peer

STEVE FOWLER
Beginner
Beginner

I have a 2921 router directly connected to an Ethernet MPLS network, one of about 10 location all configured the same. This is a new install and has been tested by the LEC to be good however, even thought the interface below indicates to be up/up we are unable to PING the peer IP address or establish a BGP session. I have chaned the speed/duplex to every combination possible and tried makeing the VLAN ID 16 native but nothing works.

Does anyone know where I might start looking for the problem?

interface GigabitEthernet0/2

description descript Circuit ID:

bandwidth 5120

ip vrf forwarding main

no ip address

duplex auto

speed auto

no keepalive

no cdp enable

!

end

MPLS#sh run int g0/2.16

Building configuration...

Current configuration : 240 bytes

!

interface GigabitEthernet0/2.16

description

bandwidth 5120

encapsulation dot1Q 16

ip vrf forwarding main

ip address 10.70.0.149 255.255.255.252

no ip redirects

no ip proxy-arp

no cdp enable

end

MPLS#sh int g0/2

GigabitEthernet0/2 is up, line protocol is up

  Hardware is CN Gigabit Ethernet, address is c84c.7537.a592 (bia c84c.7537.a592)

  Description: descript Circuit ID:

  MTU 1500 bytes, BW 5120 Kbit/sec, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set

  Keepalive not set

  Full-duplex, 100Mb/s, media type is RJ45

  output flow-control is XON, input flow-control is XON

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:03, output 00:00:03, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     1058 packets input, 69805 bytes, 0 no buffer

     Received 6 broadcasts, 0 runts, 0 giants, 0 throttles

     4 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 2 multicast, 0 pause input

     0 input packets with dribble condition detected

     1054 packets output, 69405 bytes, 0 underruns

     0 output errors, 0 collisions, 6 interface resets

     2 unknown protocol drops

     0 babbles, 0 late collision, 0 deferred

     9 lost carrier, 0 no carrier, 0 pause output

     0 output buffer failures, 0 output buffers swapped out

MPLS#sh  int g0/2.16

GigabitEthernet0/2.16 is up, line protocol is up

  Hardware is CN Gigabit Ethernet, address is c84c.7537.a592 (bia c84c.7537.a592)

  Description: SPECTRUM_IF_ALIAS_145f500a

  Internet address is 10.70.0.149/30

  MTU 1500 bytes, BW 5120 Kbit/sec, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation 802.1Q Virtual LAN, Vlan ID  16.

  Keepalive set (10 sec)

  ARP type: ARPA, ARP Timeout 04:00:00

  Last clearing of "show interface" counters never

MPLS#sh ip bgp vpnv4 vrf main summ

BGP router identifier 199.160.108.231, local AS number 65007

BGP table version is 178, main routing table version 178

145 network entries using 20880 bytes of memory

285 path entries using 14820 bytes of memory

56/25 BGP path/bestpath attribute entries using 7392 bytes of memory

16 BGP AS-PATH entries using 560 bytes of memory

2 BGP community entries using 48 bytes of memory

10 BGP extended community entries using 1026 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 44726 total bytes of memory

139 received paths for inbound soft reconfiguration

BGP activity 351/192 prefixes, 704/390 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

10.70.0.150     4        21302       0       0        1    0    0 never    Active

MPLS#sh run | b router bgp

router bgp 65007

bgp router-id 199.160.108.231

bgp router-id vrf auto-assign

bgp log-neighbor-changes

!

address-family ipv4

  no synchronization

  network 10.34.3.0 mask 255.255.255.0

  network 10.34.17.0 mask 255.255.255.0

  network 10.34.24.0 mask 255.255.255.0

  network 10.34.90.0 mask 255.255.255.0

  network 10.34.100.0 mask 255.255.255.0

  network 10.34.125.0 mask 255.255.255.0

  no auto-summary

exit-address-family

!

  address-family ipv4 vrf main

  no synchronization

  network 10.34.3.0 mask 255.255.255.0

  network 10.34.17.0 mask 255.255.255.0

  network 10.34.24.0 mask 255.255.255.0

  network 10.34.90.0 mask 255.255.255.0

  network 10.34.100.0 mask 255.255.255.0

  network 10.34.125.0 mask 255.255.255.0

  network 10.70.0.36 mask 255.255.255.252

  network 199.160.108.231 mask 255.255.255.255

  redistribute static

  neighbor 10.70.0.37 remote-as 1803

  neighbor 10.70.0.37 activate

  neighbor 10.70.0.37 soft-reconfiguration inbound

  neighbor 10.70.0.150 remote-as 21302

  neighbor 10.70.0.150 local-as 64608 no-prepend replace-as

  neighbor 10.70.0.150 activate

exit-address-family

16 Replies 16

cadet alain
VIP Alumni
VIP Alumni

Hi,

did you use the vrf keyword in your ping command ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Thanks, but yes I did

Steve

Would you post the output of show arp? I wonder if you are seeing the neighbor at layer 2?

HTH

Rick

HTH

Rick

Thanks, but it doesn't see it at layer 2 either.

Stockholm-MPLS#sh ip arp vrf main

Protocol  Address          Age (min)  Hardware Addr   Type   Interface

Internet  10.34.100.1             -   c84c.7537.a590  ARPA   GigabitEthernet0/0

Internet  10.34.100.252          19   0013.21d7.b040  ARPA   GigabitEthernet0/0

Internet  10.34.100.253          18   0023.4764.c500  ARPA   GigabitEthernet0/0

Internet  10.34.100.254          27   0000.5e00.010f  ARPA   GigabitEthernet0/0

Internet  10.70.0.37             36   0017.e0ae.a112  ARPA   GigabitEthernet0/1.30

Internet  10.70.0.38              -   c84c.7537.a591  ARPA   GigabitEthernet0/1.30

Internet  10.70.0.149             -   c84c.7537.a592  ARPA   GigabitEthernet0/2.16

Internet  10.70.0.150             0   Incomplete      ARPA

Steve

Thanks for the additional information. It is at least a bit helpful. In your original post you asked where to start looking. Now we know that you should start looking for an issue probably at layer 2. If it were a layer 1 issue the interface would probably not show as up. But clearly it is something lower than layer 3.

HTH

Rick

HTH

Rick

Christopher Bell
Enthusiast
Enthusiast

Try a static arp entry. Also, does the other side see you with a show arp? Try clearing dynamic arp and possibly have the other side add a static arp for you?

Sent from Cisco Technical Support iPhone App

If this posts answers your question or is helpful, please consider rating it and/or marking as answered.

Thanks to all of you for the helpful replies however the provider has finally found the problem. The LEC equipment was cross connect was incorrectly connected to the wrong port on the provider side. They're working on getting that corrected now.

Steve

Steve

Thank you for posting back to the forum and letting us know that the problem has been identified. It is good to know that it was indeed a kind of layer 1/layer 2 problem.

HTH

Rick

HTH

Rick

shubhi013
Beginner
Beginner

Hi,

I am exactly facing the same problem and i have been asked to troubleshoot this and I have tried everything but nothing seems to be working. Any suggestions please?

I would really appreciate any kind of help.

surprisingly, it is the exact same issue that i have and the users at the remote location are not getting any connectivity due to this.

Kindly Help.

Regards,

Shubham

Shubham

You might try some of the same show commands that were used in the earlier part of this thread - I would especially suggest the show arp as a useful place to start. Since we know that the previous issue turned out to be mis-connected on the provider side, have you asked your provider to double check their connections?

HTH

Rick

HTH

Rick

Hi Richard,

Thank you for the advise. Yes, that might be a good idea because everything on the router seems just fine. Might be a provider issue but the only confusing thing is the other SSID set up on the same router but on a different interface seems to be woking just fine.

Any thoughts on that?

Sincerely,

Shubham

I too have the same issue and have tried fiddling with speed and duplex. Have also plugged a laptop into both the provider handoff and separately the router wan port and am able to ping the laptop from router and provider next hop successfully. I plug the router into the handoff and no ping / incomplete arp. I have tried configuring different router ports with same result. Have tried loopback cable with same result.  Provider insists problem is our equipment. Any suggestions / ideas?

did you ever resolve this issue?

This thread has discussions about 3 different problems. The first problem was in the original post from Steve in 2013. This problem was successfully resolved. A second problem was brought into the thread by Shubham in 2016. I made some suggestions and it is not clear whether that problem was resolved. A third problem was brought into the discussion earlier in 2018. I did not see that question and so did not respond. It is not clear whether that problem was ultimately resolved or not.

 

HTH

 

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: