cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1061
Views
0
Helpful
5
Replies
ubhnetworking
Beginner

2960x - High CPU (Very poor VoIP quality)

We have 2960X's running 15.2(3)E with high CPU usage (75%/27%) 

Switch Ports Model                     SW Version            SW Image
------ ----- -----                     ----------            ----------
*    1 52    WS-C2960X-48FPS-L         15.2(3)E              C2960X-UNIVERSALK9-M
     2 52    WS-C2960X-48FPS-L         15.2(3)E              C2960X-UNIVERSALK9-M

VoIP calls for anyone on this switch have clicks, delay, and often no dial tone. 

I see high CPU utilization seems to have been an issue for a couple years. We have several 2960x stacks but have only seen this issue on this stack. All 2960x switches are running 15.2(3)E.

 

 

 

 

 

 

 

 

 

 

5 REPLIES 5
Mark Malone
VIP Mentor

Can you post the show proc cpu sorted to see whats causing the cpu issue please

Here is a screen shot of the top 7 processes

 

hi yes seen that before on 3750s thats a bug , it effects 2960 as well , no workaround in Cisco bug but there is one in the link provided , whats your IOS version ?

https://tools.cisco.com/bugsearch/bug/CSCsi78581   3750 says its basically fictitious that it does not effect your hardware

https://heggel4.wordpress.com/2012/06/07/high-cpu-loads-cisco-2960/

2960 bug release

Hulc LED Process uses 6-15% CPU on Catalyst 2960/2960S 24/48-port switch

CSCtg86211
Symptom:

Hulc LED Process uses 10-15% CPU on Catalyst 2960/2960S 24 or 48-port switch.

Conditions:

The CPU utilization for Hulc LED Process will be in the 10-15% range for the
following switch models.

* WS-C2960-48PST-L
* WS-C2960-24LC-S
* WS-C2960-24PC-S
* WS-C2960-48PST-S
* WS-C2960S-48TS-S
* WS-C2960S-24TS-S
* WS-C2960S-24TS-L
* WS-C2960S-48TS-L

The is seen in 12.2(50)SE03 or later releases.

Workaround:

This is an expected behavior and there is no workaround.

Further Problem Description:

The "Hulc LED" process does following tasks:

- Check Link status on every port
- If the switch supports POE, it checks to see if there is a Power Device (PD)
detected
- Check the status of the transceiver
- Update Fan status
- Set Main LED and ports LEDs
- Update both Power Supplies and RPS
- Check on system temperature status

it does not look like that bug exists in the suggested IOS version release for your model below but there is a couple of other hulc bugs but you might not trigger them depending on your setup

 

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst2960x/software/15-0_2_EX/release_notes/OL30810.html

aidan_burnett
Beginner

Having this exact same problem with SW version 15.2(3)E2 and a stack of five WS-C2960X-48LPD-L. Please can you let me know if you found a fix for this?