Hello,
I have 3600 with 5 adsl ports. I try to config it to connect to the ISP but it doesn't work.
my configuration is:
ip vrf 6
!
ip vrf lan
rd 100:1
route-target import 200:1
route-target import 300:1
route-target import 400:1
route-target import 500:1
route-target import 600:1
!
ip vrf vrf1
rd 200:1
route-target export 100:1
!
ip vrf vrf2
rd 300:1
route-target export 100:1
!
ip vrf vrf3
rd 400:1
route-target export 100:1
!
ip vrf vrf4
rd 500:1
route-target export 100:1
!
ip vrf vrf5
rd 600:1
route-target export 100:1
!
interface ATM0/0/0
description FORWARDING_DIALER_01
no ip address
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
pppoe-client dial-pool-number 1
!
!
interface ATM0/1/0
description FORWARDING_DIALER_02
no ip address
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
pppoe-client dial-pool-number 2
!
!
interface ATM0/2/0
description FORWARDING_DIALER_03
no ip address
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
pppoe-client dial-pool-number 3
!
!
interface ATM0/3/0
description FORWARDING_DIALER_04
no ip address
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
pppoe-client dial-pool-number 4
!
!
interface ATM3/0/0
description FORWARDING_DIALER_05
no ip address
ip flow ingress
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
dialer pool-member 5
!
!
interface Dialer1
ip vrf forwarding vrf1
no ip address
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username ########## password 0 ##########
!
interface Dialer2
ip vrf forwarding vrf2
no ip address
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 2
dialer-group 2
ppp authentication pap callin
ppp pap sent-username ########## password 0 ##########
!
interface Dialer3
ip vrf forwarding vrf3
no ip address
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 3
dialer-group 3
ppp authentication pap callin
ppp pap sent-username ########## password 0 ##########
!
interface Dialer4
ip vrf forwarding vrf4
no ip address
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 4
dialer-group 4
ppp authentication pap callin
ppp pap sent-username ########## password 0 ##########
!
interface Dialer5
ip vrf forwarding vrf5
no ip address
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 5
dialer-group 5
ppp authentication pap callin
ppp pap sent-username ########## password 0 ##########
!
ip classless
ip route vrf lan 0.0.0.0 0.0.0.0 Dialer1
ip route vrf lan 0.0.0.0 0.0.0.0 Dialer2
ip route vrf lan 0.0.0.0 0.0.0.0 Dialer3
ip route vrf lan 0.0.0.0 0.0.0.0 Dialer4
ip route vrf lan 0.0.0.0 0.0.0.0 Dialer5
ip route vrf lan 192.168.0.0 255.255.0.0 192.168.201.1
!
ip http server
no ip http secure-server
ip nat inside source route-map adsl1 interface Dialer1 vrf lan overload
ip nat inside source route-map adsl2 interface Dialer2 vrf lan overload
ip nat inside source route-map adsl3 interface Dialer3 vrf lan overload
ip nat inside source route-map adsl4 interface Dialer4 vrf lan overload
ip nat inside source route-map adsl5 interface Dialer5 vrf lan overload
!
access-list 1 permit any
access-list 2 permit any
access-list 3 permit any
access-list 4 permit any
access-list 5 permit any
!
route-map adsl2 permit 10
match interface Dialer2
!
route-map adsl3 permit 10
match interface Dialer3
!
route-map adsl1 permit 10
match interface Dialer1
!
route-map adsl4 permit 10
match interface Dialer4
!
route-map adsl5 permit 10
match interface Dialer5
!
Thanking you in anticipation :)