cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
393
Views
0
Helpful
2
Replies
Highlighted
Beginner

3845 fails to route

Hello all,

I have a 3845 that will not let me ping to the internet from my PC.

On interface g0/0 I have a connection to a internet connection (another router), using DHCP to get it's address (it gives g0/0 IP 192.168.0.3).

On interface g0/1, I have a connection to my LAN (I assign the interface IP 10.10.1.1).

I can ping the router.  The router can ping the internet, do DNS resolution, etc.

I have ensured routing is enabled.  The only route I have configured is a default static route: 0.0.0.0 0.0.0.0 192.168.0.1.

Oddly, if I choose 0.0.0.0 0.0.0.0 g0/0, I cannot ping sites on the internet from the router.

I tried setting up ip nat inside for my LAN and ip nat outside for the WAN/internet uplink, but this did not help.

EDIT: This was the issue, I missed finishing the NAT setup.

Any ideas as to what else I can try? 

I can make the router ping out all day, and have my PCs ping the router, but getting the connection between the two is not working.

Please help!!!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

Hello Sagar,

NAT is the way to go because the private IP addresses need to be translated to go on the public internet. In your case the C3845 has to translate to the upstream interface that should be gi0/0 from your description..

However, you need a line to make NAT effective in addition to ip nat inside on internal LAN interface and ip nat outside on WAN facing interface

the line should be something like

access-list 11 permit 10.10.1.0 0.0.0.255

ip nat inside source list 11 interface gi0/0 overload

>> Oddly, if I choose 0.0.0.0 0.0.0.0 g0/0, I cannot ping sites on the internet from the router.

This is related to Proxy ARP disabled on the other device.

The use of this kind of static route is not recommended as it increases the ARP activity on the device and relies on settings on the other device.

With this static route the device has to send an ARP request for each seen destination in the Internet, the other device would answer only if Proxy ARP is enabled on its interface.

Your router should receive a default gateway in DHCP.

Hope to help

Giuseppe

View solution in original post

2 REPLIES 2
Highlighted
Hall of Fame Master

Hello Sagar,

NAT is the way to go because the private IP addresses need to be translated to go on the public internet. In your case the C3845 has to translate to the upstream interface that should be gi0/0 from your description..

However, you need a line to make NAT effective in addition to ip nat inside on internal LAN interface and ip nat outside on WAN facing interface

the line should be something like

access-list 11 permit 10.10.1.0 0.0.0.255

ip nat inside source list 11 interface gi0/0 overload

>> Oddly, if I choose 0.0.0.0 0.0.0.0 g0/0, I cannot ping sites on the internet from the router.

This is related to Proxy ARP disabled on the other device.

The use of this kind of static route is not recommended as it increases the ARP activity on the device and relies on settings on the other device.

With this static route the device has to send an ARP request for each seen destination in the Internet, the other device would answer only if Proxy ARP is enabled on its interface.

Your router should receive a default gateway in DHCP.

Hope to help

Giuseppe

View solution in original post

Highlighted

Hey Giuseppe,

You just freed me from hours of head scratching.

When re-doing my config for my new ISP, I accidentally deleted the 'ip nat inside source list 11 interface g0/0 overload' line.

I can't thank you enough.