cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
435
Views
0
Helpful
4
Replies
Highlighted
Beginner

3G router on MPLS network

Dear all,

I currently have a 150 nodes MPLS network.  My management is anxious to join some sites with 3G routers as their centres move around a lot.

My current MPLS site as 4 x Ps with lots of PEs linking to the 150 x CEs.  Is there a way to easily link up my 3G routers to my MPLS network? I have heard DMVPN may be a solution, but not sure how to implement.

Would be great if anyone can shed some light on this.

Cheers,

Hunt

4 REPLIES 4
Highlighted
Beginner

3G router on MPLS network

Hello.

Have a look at MPLS over mGRE. We use that with 1921 and 2901 and 3G/4G EHWICs as CE with MPLS to the edge.

Alternatively MPLS over mGRE over IPSEC if you are using public 3G networks. Eitherway you would need to lower the MTU on inside interface to allow for the added overhead that IPSEC, GRE and MPLS adds.

Using mGRE allows you to have dynamic ip addresses on enpoints in the CE side.

Highlighted
Beginner

3G router on MPLS network

Empreror2000,

Thanks heaps for your reply.

Just curious would you mind to share some "sample configs" on how to setup MPLS over mGRE for CE routers? As well as config on "one of the core" for accepting MPLS over mGRE connections?

I am completely new to this and would like to learn more and ensure i setup everything correctly on my corporate network.

Cheers

Highlighted
Beginner

3G router on MPLS network

Also, is MPLS over mGRE over IPSEC = DMVPN? And would it work over 3G / 4G EHWICs?

Highlighted
Beginner

Re: 3G router on MPLS network

Yea sure.

Core part. This is from 2951 acting as hub router.

interface Tunnel3

bandwidth 1000000

ip address

no ip redirects

ip pim sparse-dense-mode

ip nhrp authentication

ip nhrp map multicast dynamic

ip nhrp network-id 1

ip ospf network broadcast

ip ospf priority 10

mpls ip

tunnel source GigabitEthernet0/1.425

tunnel mode gre multipoint

  tunnel protection ipsec profile

tunnel key 1

CE part this is a 892F as spoke router.

interface Tunnel2

ip address

ip nhrp authentication

ip nhrp map

ip nhrp map multicast

ip nhrp network-id 1

ip nhrp nhs

ip ospf network point-to-multipoint

mpls ip

tunnel source GigabitEthernet0

tunnel destination

  tunnel protection ipsec profile

tunnel key 1

I dont have a configuration for mGRE over 3G/4G ehwics ive just tested ordinary MPLS o GRE o IPSEC on thoose interfaces but since that isnt an issue there shouldnt be an issue doing mGRE over inte either.