cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1531
Views
5
Helpful
29
Replies
Highlighted
Beginner

4500X VSL issue

Friends, I'm trying to configure VSS on a pair of 16 port 4500X.

 

However, whilst creating the VSL I'm getting below and Port-channel isn't coming up.

 

EC-5-CANNOT_BUNDLE2: Te1/1 is not compatible with Po5 and will be suspended (trunk mode of Te1/1 is dynamic, Po5 is trunk)

 

Please help!

29 REPLIES 29
Highlighted
VIP Mentor

Hi

It seems you have trunk dynamic configured on Te1/1.
Can you configure it like:
int te1/1
switchport mode trunk

and test it again?

Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Highlighted

Thanks Bro!!

 

I even tried that configuring the physical ports as trunks.

 

Below is my VSL configuration the Warning that I get when applying Port-channel on the Te interfaces

***** Also attached some show outputs of logical and physical interfaces*******

 

 

Switch(config)#switch virtual domain 165
Domain ID 165 config will take effect only
after the exec command 'switch convert mode virtual' is issued

Switch(config-vs-domain)#switch 1
Switch(config-vs-domain)#switch 1 priority 200
Switch(config-vs-domain)#exit
!
Switch(config)#int port-channel 39
Switch(config-if)#switchport
Switch(config-if)#switch virtual link 1
WARNING:Port channel number for VSL on both chassis should not be same

Switch(config)#int range te 1/1-2
Switch(config-if-range)#channel-group 39 mode on

 

WARNING: Interface TenGigabitEthernet1/1 placed in restricted config mode. All extraneous configs removed!
*Jan 28 05:14:15.787: %EC-5-CANNOT_BUNDLE2: Te1/1 is not compatible with Po39 and will be suspended (trunk mode of Te1/1 is dynamic, Po39 is trunk)
WARNING: Interface TenGigabitEthernet1/2 placed in restricted config mode. All extraneous configs removed!
*Jan 28 05:14:16.986: %EC-5-CANNOT_BUNDLE2: Te1/2 is not compatible with Po39 and will be suspended (trunk mode of Te1/2 is dynamic, Po39 is trunk)

 

 

Highlighted

Hi

 

retry removing all configs :

 

default interface te1/1

default interface te1/2

no int port-ch 39

!

nterface Port-channel39
description - VSL LINK -
no switchport
no ip address
switch virtual link 1

!

interface range Te1/1 - 2
description - VSL LINK -
no switchport
no ip address
no cdp enable
channel-group 39 mode on

 

Try that and let me know


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Highlighted

Thanks again Francesco for your prompt support.

 

But don't you think that by configuring  Po39 with no switchport command will create a L3 etherchannel, whereas a L2 port-channel is needed to create the Virtual Switching Links.

Highlighted

Sorry, I gave you a VSS config for 6k...

 

On 4k try that:

 

default interface te1/1

default interface te1/2

no int port-ch 39

!

interface Port-channel39
description - VSL LINK -
switchport
switchport mode trunk
switchport nonegotiate
switch virtual link 1

!

interface range Te1/1 - 2
description - VSL LINK -
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
no cdp enable
channel-group 1 mode on

 


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Highlighted

I don't know why below commands configured under the interfaces too:

interface range Te1/1 - 2
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
no cdp enable

As per port-channel rules, Port-Channel configuration will automatically apply to all members ports. there is no required to configure the ports too.

Regards,
Deepak Kumar
Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted

It's just to be sure interfaces are configured properly. This is not mandatory.
I asked to set interfaces as his issue is coming from misconfiguration.


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Highlighted

I even tried resetting all the configs which were automatically added to the interfaces when I created the VSL.

 

Here is the revised configs but the interfaces stay as suspended member of port-channel :(

*****************

Configuration

*****************

interface Port-channel39
switchport
switchport mode trunk
switchport nonegotiate
switch virtual link 1
!
interface TenGigabitEthernet1/1
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
no cdp enable
channel-group 39 mode on
service-policy output VSL-Queuing-Policy
!
interface TenGigabitEthernet1/2
switchport mode trunk
switchport nonegotiate
no lldp transmit
no lldp receive
no cdp enable
channel-group 39 mode on
service-policy output VSL-Queuing-Policy
!

 

*******************

Sh output

******************

sh int tenGigabitEthernet 1/1 sw
Switch#sh int tenGigabitEthernet 1/1 switchport
Name: Te1/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down (suspended member of bundle Po39)
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

 

Highlighted

And with that config you still getting the error message?
Can you share the output of sh etherchannel suma

Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question
Highlighted

Sure here it is...

 

Switch#sh etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port


Number of channel-groups in use: 1
Number of aggregators: 1

Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
39 Po39(SD) - Te1/1(w) Te1/2(w)

Highlighted

Can you do one thing for a testing?
Just create a new port-channel with any other number and try again.

Regards,
Deepak Kumar
Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted

The other switch that is planned to be paired with this one as VSS is having the same issues with different port-channel which is Po40

 

Same outputs from that switch as well.

 

I didn't do any additional configs just a normal way of making the VSS no idea why the VSL isn't coming up :(

 

Step 1

Switch 1
SW1(config)#switch virtual domain 165
SW1(config-vs-domain)#switch 1
SW1(config-vs-domain)#switch 1 priority 200
SW1(config-vs-domain)#exit
SW1(config)#
Switch 2
SW2(config)#switch virtual domain 165
SW2(config-vs-domain)#switch 2
SW2(config-vs-domain)#exit
SW2(config)#

Step 2
Switch 1
SW1(config)#int port-channel 39
SW1(config-if)#switchport
SW1(config-if)#switch virtual link 1
SW1(config-if)#no shut
SW1(config-if)#exit

 

Switch 2
SW2(config)#int port-channel 41
SW2(config-if)#switchport
SW2(config-if)#switch virtual link 2
SW2(config-if)#no shut
SW2(config-if)#exit
Step 3
Switch 1
SW2(config)#int range te 1/1-2
SW2(config-if-range)#channel-group 39 mode on
SW2(config-if-range)#exit
!

Switch 2
SW2(config)#int range te 1/1-2
SW2(config-if-range)#channel-group 41 mode on
SW2(config-if-range)#exit
!

Please note that both of my switches are straight out of the box and have no configs at all on them

 

Highlighted

Hi,
Please configure a command on both interfaces as physical and port-channel and check-
"switchport mode dynamic auto"

Regards,
Deepak Kumar
Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Highlighted

Do you think it's safe to configure VSL as dynamic auto, I mean in case of any link-flapping or VSS split brain switchports might flap to be working as Access Ports. 

In fact, the warning I'm getting doesn't say anything about dtp nonegotiation