cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
40100
Views
20
Helpful
39
Replies

4G LTE Configuration

therealcarbon
Level 1
Level 1

Hello all,

I am trying to get my 4g LTE setup working properly, but running into some issues-- below is my config // details on current situation:

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

!
!

chat-script lte"" "AT!CALL" TIMEOUT 60 "OK"
!
!
license udi pid CISCO2921/K9 sn FTX1731AMEX

boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
!
!
!
no ipv6 cef
multilink bundle-name authenticated

interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
access-list 1 permit any
access-list 2 permit 10.2.0.0 0.0.0.255
dialer-list 1 protocol ip permit

!

!

control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
modem InOut
no exec
!
scheduler allocate 20000 1000

Corp4G_1#sh cel 0/0/0 all
Hardware Information
====================
Modem Firmware Version = SWI9200X_03.05.10.02
Modem Firmware built = 2012/02/25 11:58:38
Hardware Version = 10
International Mobile Subscriber Identity (IMSI) = 310410767590990
International Mobile Equipment Identity (IMEI) = 359469040107280
Integrated Circuit Card ID (ICCID) = 89014104277675909901
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) = 15189519432

Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None
Username:
Password:

* - Default profile

Data Connection Information
===========================
Data Transmitted = 0 bytes, Received = 0 bytes
Profile 1, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 2, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 3, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 4, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 5, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 6, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 7, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 8, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 9, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 10, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 11, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 12, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 13, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 14, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 15, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 16, Packet Session Status = INACTIVE
Inactivity Reason = Unknown

Network Information
===================
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 410
Packet switch domain(PS) state = Attached
Registration(EMM) state = Registered

Radio Information
=================
Radio power mode = ON
Current RSSI = -53 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = LTE

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3

Error Information
=================

This command is not supported on 4G modems.


Modem Crashdump Information
===========================
Modem crashdump logging: off

Thanks!

1 Accepted Solution

Accepted Solutions

Hello,

looking at your chat script, I think you might be missing a space. Make sure it looks like this:

chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"

or use the one you originally configured:

chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"

Make sure there is a space between lte and the quotes:

lte ""

View solution in original post

39 Replies 39

Hello,

try to remove the 'OK' from your chat script:

chat-script lte"" "AT!CALL" TIMEOUT 60

or try and 'offload' the cellular configuration to a dialer:

chat-script lte"" "AT!CALL" TIMEOUT 60 "OK"
!
license udi pid CISCO2921/K9 sn FTX1731AMEX

boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
!
no ipv6 cef
multilink bundle-name authenticated

interface Cellular0/0/0
no ip address
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer pool-member 1
dialer-group 1
async mode interactive
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly im
encapsulation slip (or ppp)
dialer-pool 1
dialer idle-timeout0
dialer string lte
dialer persistent
dialer-group 1


ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit any
access-list 2 permit 10.2.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
control-plane
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
modem InOut
no exec
!
scheduler allocate 20000 1000

Hello,

'Broadband' actually seems to be the correct AT&T APN. Either way, try the chat script below:

chat-script lte"" "AT!CALL1" TIMEOUT 20 "OK"

Hello,

can you post the full configuration of your router ? You might be missing something else...

Sure---

hostname Corp4G_1
!
boot-start-marker
boot-end-marker
!

!
no aaa new-model
!
ip cef
!
!
!
ip dhcp excluded-address 10.2.0.1 10.2.0.14
ip dhcp excluded-address 172.16.0.1 172.16.0.10
!
ip dhcp pool DATA
network 10.2.0.0 255.255.255.192
default-router 10.2.0.1
dns-server 4.4.2.2 8.8.8.8
!
ip dhcp pool VOICE
network 172.16.0.0 255.255.255.224
default-router 172.16.0.1
dns-server 4.4.2.2 8.8.8.8
!
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
chat-script lte"" "AT!CALL1" TIMEOUT 20 "OK"
!
!
license udi pid CISCO2921/K9 sn FTX1731AMEX
!
!
!
controller Cellular 0/0
!
!
!
!
!
interface Loopback0
ip address 192.168.1.100 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description "DATA"
encapsulation dot1Q 10 native
ip address 10.2.0.1 255.255.255.192
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.20
description "VOICE"
encapsulation dot1Q 20
ip address 172.16.0.1 255.255.255.224
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
shutdown
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 1
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
access-list 1 permit any
access-list 2 permit 10.2.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
modem InOut
no exec
rxspeed 100000000
txspeed 50000000
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

Hello,

try the config below (I have removed the dialer interface and changed access list 2):

hostname Corp4G_1
!
boot-start-marker
boot-end-marker
!

!
no aaa new-model
!
ip cef
!
!
!
ip dhcp excluded-address 10.2.0.1 10.2.0.14
ip dhcp excluded-address 172.16.0.1 172.16.0.10
!
ip dhcp pool DATA
network 10.2.0.0 255.255.255.192
default-router 10.2.0.1
dns-server 4.4.2.2 8.8.8.8
!
ip dhcp pool VOICE
network 172.16.0.0 255.255.255.224
default-router 172.16.0.1
dns-server 4.4.2.2 8.8.8.8
!
!
!
no ipv6 cef
multilink bundle-name authenticated
!
!
chat-script lte"" "AT!CALL1" TIMEOUT 20 "OK"
!
!
license udi pid CISCO2921/K9 sn FTX1731AMEX
!
!
!
controller Cellular 0/0
!
!
!
!
!
interface Loopback0
ip address 192.168.1.100 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
description "DATA"
encapsulation dot1Q 10 native
ip address 10.2.0.1 255.255.255.192
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.20
description "VOICE"
encapsulation dot1Q 20
ip address 172.16.0.1 255.255.255.224
ip nat inside
ip virtual-reassembly in
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
access-list 1 permit any
access-list 2 permit 10.2.0.0 0.0.0.63
access-list 2 permit 172.16.0.0 0.0.0.31
access-list 2 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
modem InOut
no exec
rxspeed 100000000
txspeed 50000000
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

no luck on pinging out with that config as well--- some additional output:

Corp4G_1#sh int cellular 0/0/0
Cellular0/0/0 is down, line protocol is down
Hardware is 4G WWAN EHWIC - North America Multimode LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS
Internet address will be assigned dynamically by the network
MTU 1500 bytes, BW 50000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SLIP, loopback not set
Keepalive not supported
Last input 04:59:21, output 04:59:21, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/10 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
12 packets input, 1259 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
10 packets output, 657 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=down DSR=up DTR=down RTS=up CTS=up

International Mobile Subscriber Identity (IMSI) = 310410767590990
International Mobile Equipment Identity (IMEI) = 359469040107280
Integrated Circuit Card ID (ICCID) = 89014104277675909901
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) = 15189519432

Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None
Username:
Password:

* - Default profile

Data Connection Information
===========================
Data Transmitted = 657 bytes, Received = 1203 bytes
Profile 1, Packet Session Status = INACTIVE

Network Information
===================
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 410
Packet switch domain(PS) state = Attached
Registration(EMM) state = Registered

Radio Information
=================
Radio power mode = ON
Current RSSI = -55 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = LTE

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3

Error Information
=================

This command is not supported on 4G modems.


Modem Crashdump Information
===========================

off

Hello,

looking at your chat script, I think you might be missing a space. Make sure it looks like this:

chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"

or use the one you originally configured:

chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"

Make sure there is a space between lte and the quotes:

lte ""

Thanks so much! That was it!

Hello,

glad it is solved ! Little things often cause big problems...:)

Corp4G_1#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Jun 19 15:58:34.121: TTY0: pause timer type 1 (OK)
*Jun 19 15:58:34.125: Ce0/0/0 DDR: place call
*Jun 19 15:58:34.125: Ce0/0/0 DDR: Dialing cause ip (s=192.168.1.100, d=8.8.8.8)
*Jun 19 15:58:34.125: Ce0/0/0 DDR: Attempting to dial lte
*Jun 19 15:58:34.125: CHAT0/0/0: Attempting async line dialer script
*Jun 19 15:58:34.125: CHAT0/0/0: Dialing using Modem script: lte"" & System script: none
*Jun 19 15:58:34.125: CHAT0/0/0: process started
*Jun 19 15:58:34.125: CHAT0/0/0: Asserting DTR
*Jun 19 15.:58:34.125: CHAT0/0/0: Chat script lte"" started..
*Jun 19 15:58:39.125: CHAT0/0/0: Chat script lte"" finished, status = Connection timed out; remote host not responding
*Jun 19 15:58:39.125: TTY0/0/0: Line reset by "Async dialer"
*Jun 19 15:58:39.125: Ce0/0/0 DDR: disconnecting call
*Jun 19 15:58:39.125: TTY0/0/0: Modem: (unknown)->HANGUP
*Jun 19 15:58:39.125: TTY0/0/0: no timer type 0 to destroy
*Jun 19 15:58:39.125: TTY0/0/0: no timer type 1 to destroy
*Jun 19 15:58:39.125: TTY0/0/0: no timer type 3 to destroy
*Jun 19 15:58:39.125: TTY0/0/0: no timer type 4 to destroy
*Jun 19 15:58:39.125: TTY0/0/0: no timer type 10 to destroy
*Jun 19 15:58:39.125: TTY0/0/0: no timer type 2 to destroy
*Jun 19 15:58:39.129: TTY0/0/0: dropping DTR, hanging up
*Jun 19 15:58:39.129: tty0/0/0: Modem: HANGUP->(unknown)..
Success rate is 0 percent (0/5)

Still no luck-- 

The debug output shows that the source of the ping is 192.168.1.100.

Add the following to your access list 2:

access-list 2 permit 192.168.1.0 0.0.0.255

Paul Smith
Level 1
Level 1

Your profile is inactive. I noticed the APN is called 'Broadband'. Check with your ISP if that is the correct APN. If not edit the profile through the 'controller' command.

Thanks Paul-- all they provided was an APN IP-- how is that inserted?

Hello,

you might not need that. Try:

Router#cell 0 lte profile create 1

Did they provide CHAP username and password ?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card