cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
40106
Views
20
Helpful
39
Replies

4G LTE Configuration

therealcarbon
Level 1
Level 1

Hello all,

I am trying to get my 4g LTE setup working properly, but running into some issues-- below is my config // details on current situation:

version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption

!
!

chat-script lte"" "AT!CALL" TIMEOUT 60 "OK"
!
!
license udi pid CISCO2921/K9 sn FTX1731AMEX

boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip cef
!
!
!
no ipv6 cef
multilink bundle-name authenticated

interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 2 interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
access-list 1 permit any
access-list 2 permit 10.2.0.0 0.0.0.255
dialer-list 1 protocol ip permit

!

!

control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
modem InOut
no exec
!
scheduler allocate 20000 1000

Corp4G_1#sh cel 0/0/0 all
Hardware Information
====================
Modem Firmware Version = SWI9200X_03.05.10.02
Modem Firmware built = 2012/02/25 11:58:38
Hardware Version = 10
International Mobile Subscriber Identity (IMSI) = 310410767590990
International Mobile Equipment Identity (IMEI) = 359469040107280
Integrated Circuit Card ID (ICCID) = 89014104277675909901
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) = 15189519432

Profile Information
====================
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None
Username:
Password:

* - Default profile

Data Connection Information
===========================
Data Transmitted = 0 bytes, Received = 0 bytes
Profile 1, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 2, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 3, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 4, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 5, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 6, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 7, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 8, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 9, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 10, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 11, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 12, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 13, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 14, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 15, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
Profile 16, Packet Session Status = INACTIVE
Inactivity Reason = Unknown

Network Information
===================
Current Service Status = Normal
Current Service = Packet switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 410
Packet switch domain(PS) state = Attached
Registration(EMM) state = Registered

Radio Information
=================
Radio power mode = ON
Current RSSI = -53 dBm
LTE Technology Preference = AUTO
LTE Technology Selected = LTE

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3

Error Information
=================

This command is not supported on 4G modems.


Modem Crashdump Information
===========================
Modem crashdump logging: off

Thanks!

39 Replies 39

No auth provided- they said there is no need for a username or password, and the sim should be unlocked already--

EDIT--

 Is the problem that the APN =  broadband? I'm trying to find commands that can activate the profile:

Corp4G_1#sh cell 0/0/0 profile
Profile 1 = INACTIVE*
--------
PDP Type = IPv4
Access Point Name (APN) = Broadband
Authentication = None
Username:
Password:

* - Default profile

Who is your provider ?

AT&T

Hi, Did you ever get this working with AT&T if so can you post the solution, please?

 

I remember that question, there was a typo in the chat script.

 

If you have a similar problem, post the configuration of your router...

brett.stone
Level 1
Level 1

I had the same issue with an MC7700 Sierra card and it came down to a few things that Cisco TAC had to help me resolve.  The first thing was that under line 0/0/0, you need a script dialer LTE and a modem InOut command.  We also set up a watchdog and a dialer; although I'm unsure if its needed or not.  Here a full working config (bare minimum).

 

Current configuration : 2150 bytes
!
! Last configuration change at 17:56:07 UTC Fri Mar 1 2019
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISRG2_TEST
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 60 "OK"
!
!
voice-card 0
!
!
!
!
!
!
!
!
vxml logging-tag
license udi pid CISCO2901/K9 sn FTX18308506
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0/0
lte sim data-profile 1 attach-profile 1
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer watch-group 1
!
interface Cellular0/0/1
no ip address
encapsulation slip
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
!
!
!
control-plane
!
!
!
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
privilege level 15
logging synchronous
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
modem InOut
no exec
rxspeed 100000000
txspeed 50000000
line 0/0/1
no exec
rxspeed 100000000
txspeed 50000000
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Good information ! What ISR is that on ?

I'm having trouble on configuring 4G LTE connection following are the config. I'm not getting an IP Address

 

Current configuration : 1778 bytes
!
! Last configuration change at 11:53:25 UTC Wed Jun 12 2019
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!

*Jun 12 12:01:01.555: TTY0: pause timer t! )
!
!
!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script lte "" "ATDT*99#" TIMEOUT 60 "CONNECT"
!
!
license udi pid CISCO1941/K9 sn FGL192624RA
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0/0
lte sim data-profile 1 attach-profile 1
lte modem link-recovery disable
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
ip address 192.168.100.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
ipv6 address autoconfig
!
interface Cellular0/0/1
no ip address
encapsulation slip
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat source list NAT interface Cellular0/0/0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
ip access-list extended NAT
permit ip 192.168.100.0 0.0.0.255 any
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
!
!
!
control-plane
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line 0/0/0
script dialer lte
no exec
line 0/0/1
no exec
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

 

Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Jun 12 11:53:59.295: TTY0: resume timer type 1 (OK)
*Jun 12 11:53:59.311: TTY0: pause timer type 1 (OK)
*Jun 12 11:53:59.311: TTY0: resume timer type 1 (OK)
*Jun 12 11:53:59.327: TTY0: pause timer type 1 (OK)...
*Jun 12 11:54:05.083: Ce0/0/0 DDR: re-enable timeout
*Jun 12 11:54:05.327: Ce0/0/0 DDR: place call
*Jun 12 11:54:05.327: Ce0/0/0 DDR: Dialing cause ip (s=192.168.100.254, d=8.8.8.8)
*Jun 12 11:54:05.327: Ce0/0/0 DDR: Attempting to dial lte
*Jun 12 11:54:05.327: CHAT0/0/0: Attempting async line dialer script
*Jun 12 11:54:05.327: CHAT0/0/0: Dialing using Modem script: lte & System script: none
*Jun 12 11:54:05.327: CHAT0/0/0: process started
*Jun 12 11:54:05.327: CHAT0/0/0: Asserting DTR
*Jun 12 11:54:05.327: CHAT0/0/0: Chat script lte started
*Jun 12 11:54:05.327: CHAT0/0/0: Sending string: ATDT*99#
*Jun 12 11:54:05.327: CHAT0/0/0: Expecting string: CONNECT
*Jun 12 11:54:05.335: CHAT0/0/0: Completed match for expect: CONNECT
*Jun 12 11:54:05.335: CHAT0/0/0: Chat script lte finished, status = Success
*Jun 12 11:54:05.335: TTY0/0/0: no timer type 1 to destroy
*Jun 12 11:54:05.335: TTY0/0/0: no timer type 0 to destroy
*Jun 12 11:54:05.335: TTY0/0/0: no timer type 2 to destroy.
*Jun 12 11:54:07.335: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
*Jun 12 11:54:07.335: Ce0/0/0 DDR: Dialer statechange to up
*Jun 12 11:54:07.335: Ce0/0/0 DDR: Dialer call has been placed
*Jun 12 11:54:07.335: Ce0/0/0 DDR: dialer protocol up
*Jun 12 11:54:08.335: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/0/0, changed state to up.
Success rate is 0 percent (0/5)
Router#
*Jun 12 11:54:09.327: TTY0: resume timer type 1 (OK)
Router#
Router#
Router#sh ip int br
Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Embedded-Service-Engine0/0 unassigned YES unset administratively down down
GigabitEthernet0/0 192.168.100.254 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down down
Cellular0/0/0 unassigned YES TFTP up up
Cellular0/0/1 unassigned YES unset down down
NVI0 unassigned YES unset up up
Router#

 

 

Please do a show cellular 0/0/0 all command and paste the results so I can review.  There is a very specific IOS image which is needed for certain types of cellular cards.  Also, are you 100% positive you have a good known working SIM card because sometimes the issues are on the carrier side.

Thank you for your prompt response please find the out put below

 

Router#sh cell 0/0/0 all
Hardware Information
====================
Modem Firmware Version = SWI9X15C_05.05.58.00
Modem Firmware built = 2015/03/04 21:30:23
Hardware Version = 1.0
Device Model ID: MC7304
Package Identifier ID: 1102029_9903299_MC7304_05.05.58.00_00_Cisco_005.014_000
International Mobile Subscriber Identity (IMSI) = 505038314355128
International Mobile Equipment Identity (IMEI) = XXXXXXXXXXXXXXX
Integrated Circuit Card ID (ICCID) = 89610300003148755268
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Modem Status = Online
Current Modem Temperature = 17 deg C
PRI SKU ID = 1102029, PRI version = 005.026_000, Carrier = Generic
OEM PRI version = 05.14

Profile Information
====================

Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = live.vodafone.com
Authentication = PAP
Username:
Password:

Profile 16 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = live.vodafone.com
Authentication = PAP
Username:
Password:

* - Default profile
** - LTE attach profile


Data Connection Information
===========================
Profile 1, Packet Session Status = INACTIVE
Profile 2, Packet Session Status = INACTIVE
Profile 3, Packet Session Status = INACTIVE
Profile 4, Packet Session Status = INACTIVE
Profile 5, Packet Session Status = INACTIVE
Profile 6, Packet Session Status = INACTIVE
Profile 7, Packet Session Status = INACTIVE
Profile 8, Packet Session Status = INACTIVE
Profile 9, Packet Session Status = INACTIVE
Profile 10, Packet Session Status = INACTIVE
Profile 11, Packet Session Status = INACTIVE
Profile 12, Packet Session Status = INACTIVE
Profile 13, Packet Session Status = INACTIVE
Profile 14, Packet Session Status = INACTIVE
Profile 15, Packet Session Status = INACTIVE
Profile 16, Packet Session Status = INACTIVE

Network Information
===================
Current System Time = Fri Jun 21 0:57:33 2019
Current Service Status = No service
Current Service = Unknown
Current Roaming Status = Home
Network Selection Mode = Automatic
Network = vodafone AU
Mobile Country Code (MCC) = 505
Mobile Network Code (MNC) = 3
Packet switch domain(PS) state = Not attached
Location Area Code (LAC) = 0
Cell ID = 0
Network MTU is not Available

Radio Information
=================
Radio power mode = online
Channel Number = 0
Current Band = Unknown
Current RSSI(RSCP) = -78 dBm
Current ECIO = -9 dBm
Primary Scrambling Code = 0x0
Radio Access Technology(RAT) Preference = AUTO
Radio Access Technology(RAT) Selected = UMTS

Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3

GPS Information
==========================

GPS Info
-------------
GPS Feature: enabled
GPS Port Selected: Dedicated GPS port
GPS Status: GPS location cannot be acquired
GPS auto tracking status: disabled (Mode is not set)
GPS auto tracking config: disabled
GPS Mode Configured: not configured/unknown
Last Location Fix Error: Not Available [0x0]

SMS Information
===============
Incoming Message Information
----------------------------
SMS stored in modem = 0
SMS archived since booting up = 0
Total SMS deleted since booting up = 0
Storage records allocated = 25
Storage records used = 0
Number of callbacks triggered by SMS = 0
Number of successful archive since booting up = 0
Number of failed archive since booting up = 0

Outgoing Message Information
----------------------------
Total SMS sent successfully = 0
Total SMS send failure = 0
Number of outgoing SMS pending = 0
Number of successful archive since booting up = 0
Number of failed archive since booting up = 0
Last Outgoing SMS Status = SUCCESS
Copy-to-SIM Status = 0x0
Send-to-Network Status = 0x0
Report-Outgoing-Message-Number:
Reference Number = 0
Result Code = 0x0
Diag Code = 0x0 0x0 0x0 0x0 0x0

SMS Archive URL =

Error Information
=================

This command is not supported on this platform.


Modem Crashdump Information
===========================
WIC type is C00
Cellular0/0/0 is MC73xx based
Modem crashdump logging: off
Router#$

Yes It is 100% Working Sim issued by Vodafone Australia..

It looks like your config is fine, and you have the MC7304 Device Model which does not require a specific version of firmware; however you only have a really old IOS version 15.2 loaded and I would recommend upgrading to the latest 157-3m4b as that will flush out some bugs.  You are also missing some small code for a sub interface.  Please add this in.

 

interface Cellular0/0/1
no ip address
encapsulation slip

 

If you don't have smartnet and need access to the latest IOS, private message me and I'll provide you a link to download it.

at the moment I'm etting following on debug 

 

*Jun 24 13:49:07.723: CHAT0/0/0: Chat script lte finished, status = Connection timed out; remote host not responding
*Jun 24 13:49:07.723: Ce0/0/0 DDR: disconnecting call
*Jun 24 13:49:22.723: Ce0/0/0 DDR: re-enable timeout

 

 

I’m willing to bet it is a provisioning issue at this point.  If you take the SIM card out and place it in another device such as an Ipad, laptop, or similar, do you get service?

YES it is working sim
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card