cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1162
Views
0
Helpful
4
Replies

5921 dropped packets (eval license?)

jbize
Level 1
Level 1

Back in 2017, I started on an embedded router project, but shortly after, it was put on indefinite hold.  Recently however, it has started up again and I needed to run some performance tests on a DMVPN (using iperf3).  We had received an evaluation license back in 2017, but since we shut it down, the license says we still have a few weeks left. However, when running tests across the DMVPN (GRE tunnel), the first few packets go ok, then almost everything after gets dropped. 

 

So my question is, are the packet drops likely due to the license, or a configuration problem?

 

I've attached iperf results and license info:

 

.\iperf3.exe -c 192.168.8.101 -b 0
Connecting to host 192.168.8.101, port 5201
[  4] local 192.168.9.103 port 36454 connected to 192.168.8.101 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.01   sec   256 KBytes  2.09 Mbits/sec
[  4]   1.01-2.01   sec  0.00 Bytes  0.00 bits/sec
[  4]   2.01-3.01   sec  0.00 Bytes  0.00 bits/sec
[  4]   3.01-4.01   sec  0.00 Bytes  0.00 bits/sec
[  4]   4.01-5.00   sec  0.00 Bytes  0.00 bits/sec
[  4]   5.00-6.00   sec  0.00 Bytes  0.00 bits/sec
[  4]   6.00-7.01   sec   128 KBytes  1.05 Mbits/sec
[  4]   7.01-8.01   sec  0.00 Bytes  0.00 bits/sec
[  4]   8.01-9.01   sec   128 KBytes  1.05 Mbits/sec
[  4]   9.01-10.01  sec  0.00 Bytes  0.00 bits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.01  sec   512 KBytes   419 Kbits/sec                  sender
[  4]   0.00-10.01  sec   339 KBytes   277 Kbits/sec                  receiver

The license info is:

Router-1#show platform software license

Packet forwarding: Enabled

Current enforcement forwarding rate: 50 Mbps

Unique Device Identifier: CISCO5921-K9:....

License features supported:
       Feature              Rate     Status
  ---------------------   ---------  ------
  c5921-x86-default          8 Kbps    -
  c5921-x86-evaluation      50 Mbps  In Use
  c5921-x86-level0           5 Mbps    -
  c5921-x86-level1          10 Mbps    -
  c5921-x86-level2          25 Mbps    -
  c5921-x86-level3          50 Mbps    -
  c5921-x86-level4         100 Mbps    -
  c5921-x86-level5         200 Mbps    -
  c5921-x86-level6         500 Mbps    -


Router-1#show license all
License Store: Primary License Storage
StoreIndex: 0   Feature: c5921-x86-evaluation              Version: 1.0
        License Type: Evaluation
        License State: Active, In Use
            Evaluation total period: 8  weeks 4  days
            Evaluation period left: 5  weeks 1  day
            Period used: 3  weeks 2  days
            Expiry date: Jun 05 2019 13:52:54
        License Count: Non-Counted
        License Priority: Low
License Store: Built-In License Storage
StoreIndex: 0   Feature: c5921-x86-default                 Version: 1.0
        License Type: EvalRightToUse
        License State: Active, In Use
            Evaluation total period: 8  weeks 4  days
            Evaluation period left: 5  weeks 1  day
            Period used: 3  weeks 2  days
            Transition date: Jun 05 2019 13:49:38
        License Count: Non-Counted
        License Priority: Low

 

4 Replies 4

Hello,

 

in theory, the evaluation license should provide full functionality until the expiration date. Can you post the config of both hub and spoke of the DMVPN, in order to verify that those are ok ?

Thanks for your reply.

 

The Hub:

ip subnet-zero
no ip finger
ip dhcp excluded-address 192.168.8.1 192.168.8.100

ip dhcp pool insideDHCP
network 192.168.8.0 255.255.255.0
default-router 192.168.8.1
dns-server 8.8.8.8 8.8.4.4

ip classless
no ip http server
access-list 1 permit 192.168.8.0 0.0.0.255

interface Ethernet0/0
description WAN
ip address dhcp
ip nat outside
no shutdown
!
interface Ethernet0/1
description LAN
no ip address
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload

interface Ethernet0/2
description EMPTY
no ip address
shutdown
interface Ethernet0/3
description EMPTY
no ip address
shutdown

interface Ethernet1/0
description SD-100 BAD PORT - LAN E1/0
no ip address
shutdown

interface Ethernet1/1
description LAN E1/1
ip address 192.168.8.1 255.255.255.0
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload

interface Ethernet1/2
description LAN E1/2
no ip address
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload

interface Ethernet1/3
description LAN E1/3
no ip address
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload


interface tunnel0
ip address 192.168.4.1 255.255.255.0
bandwidth 50000
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
ip mtu 1400
ip tcp adjust-mss 1360
ip nhrp map multicast dynamic
ip nhrp network-id 5
ip nhrp shortcut
ip nhrp redirect
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 6
exit

router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary
ip route 192.168.9.0 255.255.255.0 192.168.4.2
end

And Spoke 1:

ip subnet-zero
no ip finger
ip dhcp excluded-address 192.168.9.1 192.168.9.100

ip dhcp pool insideDHCP
network 192.168.9.0 255.255.255.0
default-router 192.168.9.1
dns-server 8.8.8.8 8.8.4.4

interface Ethernet0/0
description WAN
ip address dhcp
ip nat outside
no shutdown

interface Ethernet0/1
description LAN
ip address 192.168.9.1 255.255.255.0
ip nat inside
no shutdown

ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
no ip http server

access-list 1 permit 192.168.9.0 0.0.0.255


interface Tunnel0
bandwidth 50000
ip address 192.168.4.2 255.255.255.0
ip mtu 1400
ip tcp adjust-mss 1360
ip nhrp map multicast 192.168.5.149
ip nhrp nhs 192.168.4.1
ip nhrp map 192.168.4.1 192.168.5.149
ip nhrp network-id 5
ip nhrp shortcut
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 6
exit

router eigrp 1
network 192.168.0.0 0.0.255.255
network 192.168.0.0
no auto-summary

ip route 192.168.8.0 255.255.255.0 192.168.4.1
end

Hello,

 

the configs look fine, just a few minor things(marked in bold).

 

When you issue the exec command:

 

show platform software license

 

What is the current enforcement forwarding rate ?

 

And what are your options with the command:

 

5921(config)#license platform throughput level ?

 

HUB

 

ip subnet-zero
no ip finger
ip dhcp excluded-address 192.168.8.1 192.168.8.100

ip dhcp pool insideDHCP
network 192.168.8.0 255.255.255.0
default-router 192.168.8.1
dns-server 8.8.8.8 8.8.4.4

ip classless
no ip http server
access-list 1 permit 192.168.8.0 0.0.0.255

interface Ethernet0/0
description WAN
ip address dhcp
ip nat outside
no shutdown
!
interface Ethernet0/1
description LAN
no ip address
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload

interface Ethernet0/2
description EMPTY
no ip address
shutdown
interface Ethernet0/3
description EMPTY
no ip address
shutdown

interface Ethernet1/0
description SD-100 BAD PORT - LAN E1/0
no ip address
shutdown

interface Ethernet1/1
description LAN E1/1
ip address 192.168.8.1 255.255.255.0
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload

interface Ethernet1/2
description LAN E1/2
no ip address
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload

interface Ethernet1/3
description LAN E1/3
no ip address
ip nat inside
no shutdown
ip nat inside source list 1 interface Ethernet0/0 overload


interface tunnel0
ip address 192.168.4.1 255.255.255.0
bandwidth 50000
no ip next-hop-self eigrp 1
no ip split-horizon eigrp 1
ip mtu 1400
ip tcp adjust-mss 1360
ip nhrp map multicast dynamic
ip nhrp network-id 5
--> no ip nhrp shortcut
ip nhrp redirect
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 6
exit

router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary
--> no ip route 192.168.9.0 255.255.255.0 192.168.4.2
end

 

Spoke 1:

 

ip subnet-zero
no ip finger
ip dhcp excluded-address 192.168.9.1 192.168.9.100

ip dhcp pool insideDHCP
network 192.168.9.0 255.255.255.0
default-router 192.168.9.1
dns-server 8.8.8.8 8.8.4.4

interface Ethernet0/0
description WAN
ip address dhcp
ip nat outside
no shutdown

interface Ethernet0/1
description LAN
ip address 192.168.9.1 255.255.255.0
ip nat inside
no shutdown

ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
no ip http server

access-list 1 permit 192.168.9.0 0.0.0.255


interface Tunnel0
bandwidth 50000
ip address 192.168.4.2 255.255.255.0
ip mtu 1400
ip tcp adjust-mss 1360
ip nhrp map multicast 192.168.5.149
ip nhrp nhs 192.168.4.1
ip nhrp map 192.168.4.1 192.168.5.149
ip nhrp network-id 5
ip nhrp shortcut
tunnel source Ethernet0/0
tunnel mode gre multipoint
tunnel key 6
exit

router eigrp 1
network 192.168.0.0 0.0.255.255
network 192.168.0.0
no auto-summary

--> no ip route 192.168.8.0 255.255.255.0 192.168.4.1

 

 

Thanks for the reply.

 

I removed the routes, but now my hosts at 192.168.8.101 and 192.168.9.101 can't see each other to run iperf.

 

The license info is:

Router-0#show platform software license

Packet forwarding: Enabled

Current enforcement forwarding rate: 50 Mbps

Unique Device Identifier: CISCO5921-K9:9SC7429A5CB

License features supported:
       Feature              Rate     Status
  ---------------------   ---------  ------
  c5921-x86-default          8 Kbps    -
  c5921-x86-evaluation      50 Mbps  In Use
  c5921-x86-level0           5 Mbps    -
  c5921-x86-level1          10 Mbps    -
  c5921-x86-level2          25 Mbps    -
  c5921-x86-level3          50 Mbps    -
  c5921-x86-level4         100 Mbps    -
  c5921-x86-level5         200 Mbps    -
  c5921-x86-level6         500 Mbps    -

Router-0#license platform throughput level ?
% Unrecognized command
Router-0#license platform throughput level
                  ^
% Invalid input detected at '^' marker.
Router-0#show platform software enforcement

License enforcement statistics:

Switched:
  1677559 packets, 529147177 bytes, rate 0 bps
Dropped:
  0 packets, 0 bytes, rate 0 bps
Total:
  1677559 packets, 529147177 bytes, rate 0 bps

Highest total rate: 15543000 bps (01:07:06.190 EST Sun May 5 2019)
Notification if traffic load reaches 100% of enforced rate

Statistics last cleared: never

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: