Showing results for 
Search instead for 
Did you mean: 
rishad ahammed

6509 rommon mode issue

hi,   my cisco 6509 switch is going to rommon mode on every rebooting. And I have to put the boot command manually to recover from rommon mode. I put my IOS image in external memory card, since I dont have enough space in internal flash.    And the external flash is reffered to as disk0: in the switch.  To solve this issue I tried to put boot variable But I failed. Because in the boot system command I have only option to flash not to disk0: . So can any one please tell me how to set this boot variable or how to fix this rommon mode issue. I have tried the following command to put the boot variable.

   boot system flash disk0:s72033-adventerprisek9_wan-mz.122-33.SXI13.bin.




paul driver
VIP Mentor


Sh version
Sh boot
Sh file systems



kind regards

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

Thank you for your reply, here is the show commands as you suggested


Router#sho vers
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVENTERPRISEK9_WAN-M), Version 12.2(33)SXI13, RELEASE SOFTWARE (fc3)
Technical Support:
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Tue 11-Mar-14 04:53 by prod_rel_team

ROM: System Bootstrap, Version 12.2(17r)S2, RELEASE SOFTWARE (fc1)

 Router uptime is 5 days, 15 hours, 19 minutes
Uptime for this control processor is 5 days, 15 hours, 20 minutes
Time since Router switched to active is 5 days, 15 hours, 19 minutes
System returned to ROM by  power cycle at 06:45:00 UTC Fri Jun 20 2014 (SP by power on)
System image file is "disk0:s72033-adventerprisek9_wan-mz.122-33.SXI13.bin"
Last reload reason: Reload Command


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:

If you require further assistance please contact us by sending email to

cisco WS-C6509-NEB-A (R7000) processor (revision 1.2) with 458720K/65536K bytes of memory.
Processor board ID FOX104504PA
SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache
Last reset from power-on
1 Virtual Ethernet interface
144 FastEthernet interfaces
66 Gigabit Ethernet interfaces
1917K bytes of non-volatile configuration memory.
8192K bytes of packet buffer memory.

65536K bytes of Flash internal SIMM (Sector size 512K).
Configuration register is 0x2102




#sho file systems
File Systems:

       Size(b)       Free(b)      Type  Flags  Prefixes
             -             -    opaque     rw   system:
             -             -    opaque     rw   tmpsys:
             -             -    opaque     ro   flexwan-fpd:
      65536000      65247408     flash     rw   bootflash:
*    256540672     137826304      disk     rw   disk0:#
     255799296     112422912      disk     rw   disk1:#
      65536000      65536000     flash     rw   sup-bootflash:
     108942482             0    opaque     ro   sup-microcode:
             0     184070176    opaque     wo   sup-image:
        129004        129004     nvram     rw   const_nvram:
       1964024       1948315     nvram     rw   nvram:
             -             -    opaque     rw   null:
             -             -    opaque     ro   tar:
             -             -   network     rw   tftp:
             -             -    opaque     wo   syslog:
             -             -   network     rw   rcp:
             -             -   network     rw   ftp:
             -             -   network     rw   http:
             -             -   network     rw   scp:
             -             -   network     rw   https:
             -             -    opaque     ro   cns:






Router#sho boot
BOOT variable = disk0:s72033-adventerprisek9_wan-mz.122-33.SXI13.bin,12;bootflash:s72033-adventerprisek9_wan-mz.122-33.SXI13.bin,1;sup-bootdisk:s72033-adventerprisek9_wan-mz.122-33.SXI13.bin,1;
CONFIG_FILE variable does not exist
BOOTLDR variable =
Configuration register is 0x2102

Standby not ready to show bootvar


rishad ahammed

can any one please help me on this