cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1030
Views
0
Helpful
3
Replies

819 - Cellular interface-Profile - going down after some time

sarathcisco2013
Level 1
Level 1

819 - Cellular interface interface - going down after some time.

do any body have solution for that.

Profile gone permanently down after an hour .

sh run

!
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script LTE "" "AT!CALL" TIMEOUT 20 "OK"
!
cts logging verbose 
!
controller Cellular 0

!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string hspa-R7
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface FastEthernet0
switchport access vlan 99
no ip address
duplex half
speed 100
spanning-tree portfast
!
interface FastEthernet1
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface FastEthernet2
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface GigabitEthernet0
ip address 10.1.98.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex half
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Wlan-GigabitEthernet0
no ip address
!
interface wlan-ap0
no ip address
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 10.1.99.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Cellular0 overload
ip nat inside source route-map internet interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip permit
!
route-map internet permit 10
match ip address 101
!
access-list 1 permit any
access-list 101 permit ip 10.1.98.0 0.0.0.255 any
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
exec-timeout 0 0
password cisco
script dialer hspa-R7
login
modem InOut
no exec
transport input all
line vty 0 5
password Cisc0123
login
transport input telnet
!
scheduler allocate 20000 1000
!
!
!
end

1 Accepted Solution

Accepted Solutions

Hello,

 

I have made some changes to your configuration (marked in bold):

 

sh run

!
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script LTE "" "AT!CALL" TIMEOUT 20 "OK"
!
cts logging verbose
!
controller Cellular 0
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string hspa-R7
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface FastEthernet0
switchport access vlan 99
no ip address
duplex half
speed 100
spanning-tree portfast
!
interface FastEthernet1
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface FastEthernet2
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface GigabitEthernet0
ip address 10.1.98.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex half
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Wlan-GigabitEthernet0
no ip address
!
interface wlan-ap0
no ip address
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 10.1.99.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
--> no ip nat inside source route-map internet interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip permit
!
--> no route-map internet permit 10
match ip address 101
!
--> no access-list 1 permit any
access-list 1 permit 10.1.98.0 0.0.0.255
access-list 1 permit 10.1.99.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
exec-timeout 0 0
password cisco
script dialer hspa-R7
login
modem InOut
no exec
transport input all
line vty 0 5
password Cisc0123
login
transport input telnet
!
scheduler allocate 20000 1000
!
end

View solution in original post

3 Replies 3

Hello,

 

I have made some changes to your configuration (marked in bold):

 

sh run

!
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script LTE "" "AT!CALL" TIMEOUT 20 "OK"
!
cts logging verbose
!
controller Cellular 0
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
load-interval 30
dialer in-band
dialer idle-timeout 0
dialer string hspa-R7
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface FastEthernet0
switchport access vlan 99
no ip address
duplex half
speed 100
spanning-tree portfast
!
interface FastEthernet1
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface FastEthernet2
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 99
no ip address
spanning-tree portfast
!
interface GigabitEthernet0
ip address 10.1.98.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex half
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Wlan-GigabitEthernet0
no ip address
!
interface wlan-ap0
no ip address
!
interface Vlan1
no ip address
!
interface Vlan99
ip address 10.1.99.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
--> no ip nat inside source route-map internet interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip permit
!
--> no route-map internet permit 10
match ip address 101
!
--> no access-list 1 permit any
access-list 1 permit 10.1.98.0 0.0.0.255
access-list 1 permit 10.1.99.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
exec-timeout 0 0
password cisco
script dialer hspa-R7
login
modem InOut
no exec
transport input all
line vty 0 5
password Cisc0123
login
transport input telnet
!
scheduler allocate 20000 1000
!
end

thanku,Georg Pauwen
i made the changes ,still cellular interface going down.
do i need to upgrade the modem firmware ,if so can u help me to find firmware.

Hello,

 

post the full config again including the changes you have applied...

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card