cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2763
Views
0
Helpful
15
Replies
Highlighted
Beginner

887VA VDSL2 configuration problem

Hi,

 

I have 887VA router and trying to configure VDSL internet connection.

VDSL is working, but no IP address is set.

In interface Ethernet0 I was trying to use

ip address negotiated

and also

ip address dhcp

but no one gives me IP.

Internet is working on another non-Cisco router

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Problem solved.

Only problem was the VLAN ID for VDSL LAN (not 101, but 2510). I found it on T-com pages: https://www.telekom.sk/wiki/internet/zakladne-nastavenia-siete

Correct config is attached.

Thanks for your help

View solution in original post

15 REPLIES 15
Highlighted
VIP Mentor

make default interface eth0

try below config and let us know.

interface Ethernet0
no ip address
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
no shutdown

 

interface Dialer1
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1452
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap ms-chap callin
ppp chap hostname pisarsuk66@dslbasic
ppp chap password 7 15020D04503A2F
ppp ipcp address accept
no cdp enable

 

 

BB
*** Rate All Helpful Responses ***
Highlighted
VIP Mentor

Hello,

 

try the configuration below (important parts marked in bold):

 

! Last configuration change at 21:36:32 CET Wed Jul 1 2020 by cisco
!
version 15.5
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ciscoR
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx.
enable password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
aaa new-model
!
aaa session-id common
ethernet lmi ce
memory-size iomem 10
clock timezone CET 1 0
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool LAN-POOL
network 192.168.1.0 255.255.255.0
default-router 192.168.1.220
dns-server 8.8.8.8 8.8.4.4
!
ip domain name my.home
ip name-server 8.8.8.8
ip cef
no ipv6 cef
!
license udi pid C887VA-K9 sn FCZ2019935X
license boot module c800 level advsecurity
!
vtp mode transparent
username cisco secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
controller VDSL 0
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
cdp enable
!
interface Ethernet0
no ip address
!
--> interface Ethernet0.101
--> encapsulation dot1Q 101
--> pppoe enable group global
--> pppoe-client dial-pool-number 1
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
description LAN
ip address 192.168.1.220 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
--> interface Dialer0
mtu 1492
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication pap chap ms-chap callin
ppp chap hostname pisarsuk66@dslbasic
ppp chap password 7 15020D04503A2F
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
ip http server
ip http secure-server
!
--> ip nat inside source list NAT interface Dialer0 overload
--> ip route 0.0.0.0 0.0.0.0 Dialer0
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
--> access-list 1 permit 192.168.1.0 0.0.0.255
!
dialer-list 1 protocol ip permit
!
snmp-server community public RO
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
password 7 13361B130807132B3921796166
no modem enable
line aux 0
line vty 0 1
password 7 107D0518061C050A1E017B7977
transport input ssh
line vty 2 4
password 7 107D0518061C050A1E017B7977
transport input none
!
scheduler allocate 20000 1000
ntp server 192.168.1.2
!
end

Highlighted

Hi,

 

I was trying both solutions, but no success - no IP was assigned. Yesterday I was finishing at 3:00AM, so I could miss something.

I will review configuration at Monday and give you feedback.

 

Thanks for your help.

Highlighted

Who is your ISP ? What country are you in ?

 

Post the configuration again with the changes implemented, so we can double check...

Highlighted

Country is Slovakia, provider T-Com.

Changes was applied.

Highlighted

Hello,

 

make the changes/additions marked in bold:

 

version 15.5
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ciscoR
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
enable password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
aaa new-model
!
aaa session-id common
ethernet lmi ce
memory-size iomem 10
clock timezone CET 1 0
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool LAN-POOL
network 192.168.1.0 255.255.255.0
default-router 192.168.1.220
dns-server 8.8.8.8 8.8.4.4
!
ip domain name jupi.home
ip name-server 8.8.8.8
ip cef
no ipv6 cef
!
license udi pid C887VA-K9 sn FCZ2019935X
license boot module c800 level advsecurity
!
vtp mode transparent
username jpi secret 5 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
controller VDSL 0
!
vlan 100
!
vlan 998
name native
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
cdp enable
!
interface Ethernet0
no ip address
!
interface Ethernet0.101
encapsulation dot1Q 101
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
description LAN
ip address 192.168.1.220 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1412
!
interface Dialer0
description Dialer for VDSL
mtu 1492
--> ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication pap chap ms-chap callin
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
ppp ipcp address accept
no cdp enable
!
ip forward-protocol nd
ip http server
ip http secure-server
!
--> ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
ip ssh time-out 60
ip ssh authentication-retries 2
ip ssh version 2
!
dialer-list 1 protocol ip permit
!
snmp-server community public RO
--> access-list 1 permit 192.168.1.0 0.0.0.255
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
no modem enable
line aux 0
line vty 0 1
password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
transport input ssh
line vty 2 4
password 7 xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
transport input none
!
scheduler allocate 20000 1000
ntp server 192.168.1.2
!
end

 

Highlighted

Still no IP

Highlighted

Hello,

 

make the changes below:

 

--> no vlan 100
!
--> no vlan 998
name native
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
cdp enable
!
interface Ethernet0
no ip address
!
interface Ethernet0.101
encapsulation dot1Q 101
--> no pppoe enable group global
pppoe-client dial-pool-number 1

Highlighted

I was trying also with

no pppoe enable group global

Still no IP assigned

Highlighted

Afterapplying

--> no pppoe enable group global

This line also dismissed:

pppoe-client dial-pool-number 1

Highlighted

Hello

Try the Following:

 

no interface Ethernet0.101

interface ATM0
no shut

interface ATM0.101 point-to-point
no ip address
pvc x/xx < ----isp provides this?
pppoe-client dial-pool-number 1

int dialer 0
shut

no shut



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted

Paul, I don't think, it's correct configuration. 

Please, correct me, if I'm wrong.

 

1. As I understand, ATM0 interface is only for ADSL connection. I'm using VDSL2 Annex-A.

Here is info about my connection from my old Asus router:

 

DSL ModulationITU G.993.2(VDSL2)
Regional ModeA
DSL Exchange(DSLAM)Infineon(Lantiq)
Current Profile17a

 

2. As I can see from my previous logs, VDSL2 link is correctly connected, but only IP address was not negotiated. Today I was checked that protocol is CHAP, I was set it manually.

 

 

Highlighted

Problem solved.

Only problem was the VLAN ID for VDSL LAN (not 101, but 2510). I found it on T-com pages: https://www.telekom.sk/wiki/internet/zakladne-nastavenia-siete

Correct config is attached.

Thanks for your help

View solution in original post

Highlighted

Odd...they have been using Vlan 101 for ages...

 

Glad that you got it resolved, I don't think anybody would have figured that one out...Vlan 2510.