cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
608
Views
5
Helpful
6
Replies

adding internet to network

dyekast
Level 1
Level 1

hello, I am trying to run my internet through my cisco 2650 routers... all I'm looking for is help pinging out to the web like google or something..i have cable internet, currently using my own arris Motorola surfboard sbg6700-ac  which I entered into bridge mode to disable routing features. on R1 I have my modem connected to my fastethernet 0/0 which is set to ip address dhcp. I want to be able to ping the web from R1.. until I set modem to bridge mode dhcp was giving an address of 192.18.0.2   now that I set modem to bridge mode it is giving an ip of  98.214.201.1 but I still cant ping out even using the interface as source.  so I unplugged Ethernet from r1 and plugged it into my pc.. I had to reboot modem but then it gave my pc an ip of 98.214.200.210 and I have full internet connectivity unplug from pc and put back to  r1...  nothing.. reboot modem and shut no shut the interface...  nothing...   

below and attached is my r1 config and the show ip int brief      any help would be greatly appreciated 

-----------------------------------------------

R1#sr

Building configuration...
Current configuration : 1301 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
no ip domain lookup
ip dhcp excluded-address 192.168.0.1 192.168.0.5
!
ip dhcp pool LAN
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
   dns-server 4.2.2.2
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 ip nat outside
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 256
 ip address 192.168.3.100 255.255.255.0
 ip nat inside
 clockrate 56000
 no fair-queue
!
interface Serial0/1
 bandwidth 256
 ip address 192.168.1.1 255.255.255.0
 shutdown
!
router eigrp 1
 redistribute connected
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 no auto-summary
!
ip nat inside source list 101 interface FastEthernet0/0 overload
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
access-list 101 permit ip 192.168.3.0 0.0.0.255 any
!
!
!
!
!
!
alias exec s show ip int br
alias exec sr show run
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
!
end
----------------------------------------------------------

R1(config-router)#do s

Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            98.214.201.1    YES DHCP   up                    up 
Serial0/0                  192.168.3.100   YES NVRAM  up                    up 
Serial0/1                  192.168.1.1     YES NVRAM  administratively down down
1 Accepted Solution

Accepted Solutions

Hello,

change the modem back to routed mode, then change the default route of R1 to the next hop, which is the IP address assigned to the modem. You might have to log in to the modem to see which address that is:

So, instead of:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Use:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (the I address assigned to the modem).

That said, do your clients get IP addresses from the pool you configured on your router ? I am just asking because the network you are assigning is not directly connected to R1, so you would need 'ip helper-address' commands on all the intermediate layer 3 interfaces.

Either way, I made a few changes to your config (marked in bold), give those a try. 

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
no ip domain lookup
ip dhcp excluded-address 192.168.0.1 192.168.0.5
!
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 8.8.8.8 8.8.8.4
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
bandwidth 256
ip address 192.168.3.100 255.255.255.0
ip nat inside
clockrate 56000
no fair-queue
!
interface Serial0/1
bandwidth 256
ip address 192.168.1.1 255.255.255.0
shutdown
!
router eigrp 1
redistribute connected
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip nat inside source route-map ISP interface FastEthernet0/0 overload
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
access-list 1 permit 192.168.3.0 0.0.0.255
!
route-map ISP permit 10
match ip address 1
match interface FastEthernet0/0
!
alias exec s show ip int br
alias exec sr show run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!

View solution in original post

6 Replies 6

Hello,

change the modem back to routed mode, then change the default route of R1 to the next hop, which is the IP address assigned to the modem. You might have to log in to the modem to see which address that is:

So, instead of:

ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Use:

ip route 0.0.0.0 0.0.0.0 x.x.x.x (the I address assigned to the modem).

That said, do your clients get IP addresses from the pool you configured on your router ? I am just asking because the network you are assigning is not directly connected to R1, so you would need 'ip helper-address' commands on all the intermediate layer 3 interfaces.

Either way, I made a few changes to your config (marked in bold), give those a try. 

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
no ip domain lookup
ip dhcp excluded-address 192.168.0.1 192.168.0.5
!
ip dhcp pool LAN
network 192.168.0.0 255.255.255.0
default-router 192.168.0.1
dns-server 8.8.8.8 8.8.8.4
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
bandwidth 256
ip address 192.168.3.100 255.255.255.0
ip nat inside
clockrate 56000
no fair-queue
!
interface Serial0/1
bandwidth 256
ip address 192.168.1.1 255.255.255.0
shutdown
!
router eigrp 1
redistribute connected
network 192.168.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
!
ip nat inside source route-map ISP interface FastEthernet0/0 overload
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
access-list 1 permit 192.168.3.0 0.0.0.255
!
route-map ISP permit 10
match ip address 1
match interface FastEthernet0/0
!
alias exec s show ip int br
alias exec sr show run
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!

Hello

"Ip route 0.0.0.0 0.0.0.0 x.x.x.x (the I address assigned to the modem)"

I would suggest NOT to specify the nexthop due to the fact your wan interface is dynamic assigned and could change

I would suggest to use 

ip route 0.0.0.0 0.0.0.0 dhcp

res

paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

it does not recognize ip route 0.0.0.0 0.0.0.0 dhcp

                                                                       ^

ip route 0.0.0.0 0.0.0.0 fa0/0 is recognized but does not allow me to get out from r1  

This worked using the IP and DNS that my modem provided. Thankyou! Now it's not getting distributed through eigrp or something. I can not ping from the other routers. I can ping across routers to fa0/0 on r1 from r3   but not out to net.  Attached is R3 config if you want to take a look.  R1 is the same as above minus my IP route and DNS.

problem solved I just needed to redistribute default route in eigrp and boom  thankyou

Glad to hear that you got it resolved !

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card