cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
563
Views
0
Helpful
2
Replies

ADSL for HTTP & BGP dual-home on single ISP for SMTP

cinmar1957
Level 1
Level 1

Hi,

I have 1 ADSL for HTTP and 2 Lease Line for SMTP on the same ISP.

I want to achieve HTTP traffic to be on ADSL while smtp traffic to the lease line. (BGP configuration on 2 lease line).

Please help on my current configuration.

!

interface Loopback0

description LOOPBACK INTERFACE FOR ROUTES

no ip address

!

interface Embedded-Service-Engine0/0

no ip address

shutdown

!

interface GigabitEthernet0/0

description ADSL

no ip address

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 10

!

interface GigabitEthernet0/1

description MAIN_LEASELINE

ip address 12.12.12.1 255.255.255.252

ip access-group 110 in

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface GigabitEthernet0/0/0

no ip address

!

interface GigabitEthernet0/0/1

switchport access vlan 2

no ip address

!

interface GigabitEthernet0/0/2

switchport access vlan 3

no ip address

!

interface GigabitEthernet0/0/3

switchport access vlan 4

no ip address

!

interface Vlan1

description VLAN PRIVATE NETWORK

ip address 192.168.5.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

ip policy route-map FOR_SMTP

!

interface Vlan2

description BACK_UP_PUBLIC

ip address 2.2.2.105 255.255.255.248

!

interface Vlan3

description BACKUP_LEALSE_LINE

ip address 21.21.21.1  255.255.255.252

ip access-group 111 in

ip nat outside

ip virtual-reassembly in

!

interface Vlan4

description MAIN_PUBLIC

ip address 1.1.1.193 255.255.255.248

!

interface Dialer1

ip address negotiated

ip nat outside

ip virtual-reassembly in max-fragments 64 max-reassemblies 512

encapsulation ppp

dialer pool 10

ppp authentication pap callin

ppp pap sent-username XXXX password 7 XXXX

ppp ipcp dns request accept

ppp ipcp route default

ppp ipcp address accept

!

router bgp 65204

bgp log-neighbor-changes

network 1.1.1.192 mask 255.255.255.248

network 2.2.2.104 mask 255.255.255.248

neighbor 12.12.12.2 remote-as 5384

neighbor 21.21.21.2 remote-as 5384

maximum-paths 2

!

ip forward-protocol nd

!

ip http server

ip http authentication local

ip http secure-server

!

ip dns server

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source static udp 192.168.5.55 3389 interface Vlan4 3389

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 1.1.1.192 255.255.255.248 Loopback0 10

ip route 2.2.2.104 255.255.255.248 Loopback0 10

!

access-list 1 permit any

access-list 101 permit tcp host 1.1.1.198 any eq smtp

access-list 101 permit tcp host 1.1.1.198 eq smtp any

access-list 101 permit esp any any

access-list 101 permit tcp any host 1.1.1.194 eq 3389

access-list 101 permit udp any host 1.1.1.194 eq 3389

access-list 101 deny   ip host 0.0.0.0 any

access-list 101 permit ahp any any

access-list 101 permit udp any any eq isakmp

access-list 101 permit udp any any eq non500-isakmp

access-list 101 permit udp any any eq biff

access-list 110 deny   tcp any host 12.12.12.1 eq echo

access-list 110 deny   tcp any host 12.12.12.1 eq telnet

access-list 110 deny   tcp any host 12.12.12.1 eq finger

access-list 110 deny   icmp any any redirect

access-list 110 deny   ip host 0.0.0.0 any

access-list 110 deny   udp any any eq snmp

access-list 110 permit ip any any

access-list 111 deny   tcp any host 21.21.21.1 eq echo

access-list 111 deny   tcp any host 21.21.21.1 eq telnet

access-list 111 deny   tcp any host 21.21.21.1 eq finger

access-list 111 deny   icmp any any redirect

access-list 111 deny   ip host 0.0.0.0 any

access-list 111 deny   udp any any eq snmp

access-list 111 permit ip any any

!

route-map FOR_SMTP permit 10

match ip address 101

set ip next-hop 12.12.12.1

set ip next-hop recursive 21.21.21.1

!

!

end

2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Cinmar1957,

if you want to divert SMTP traffic you should match on it

>>

route-map FOR_SMTP permit 10

match ip address 101

set ip next-hop 12.12.12.1

set ip next-hop recursive 21.21.21.1

!

access-list 101 permit ahp any any

access-list 101 permit udp any any eq isakmp

access-list 101 permit udp any any eq non500-isakmp

access-list 101 permit udp any any eq biff

where is SMTP in the ACL?

Hope to help

Giuseppe

Hello Giuseppe,

Thank you for the reply.

This is the ACL on the running-config:

access-list 101 permit ahp any any

access-list 101 permit tcp any any eq smtp

access-list 101 permit udp any any eq isakmp

access-list 101 permit udp any any eq non500-isakmp

access-list 101 permit udp any any eq biff

access-list 101 deny   ip host 0.0.0.0 any

I think I have a problem also about the routing. If the ADSL link goest down, it will not change to LeaseLine Gateway when I show route.

Regards,

Cinmar

Review Cisco Networking products for a $25 gift card