cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
333
Views
0
Helpful
2
Replies
Highlighted
Beginner

ADSL2 using NIM-VAB-A bridge mode for Meraki PPP

Hello all,

I've looked around and there seem to be very little info when configuring this, but apologies if I missed this, and this is also my first post so my bad if this is explained poorly but my goal is this:

- bt adsl terminating to 4321 with NIM-VAB-A, no ppp from the ISR but passing the l2 traffic straight to the MX on the gigabit port for PPP from the MX. (not sure if this can be done but worth a try)

 

Problem I have encountered is that there seem to not be any traffic passing, and the config of the ISR is simply :

 

controller vdsl I've left in mode auto (I did try also VDSL2 to force for g.993.2)

 

interface ATM0/1/0

no ip address

atm oversubscribe factor 2

no atm enable-ilmi-trap

 

and then:

 

interface ATM0/1/0.1 point-to-point

no atm enable-ilmi-trap

pvc 0/38

  encapsulation aal5mux ppp dialer

 

traditionally to establish ppp straight from the ISR the config would be the same except that I add the dialer config, so under "encapsulation" I would have:

 

dialer pool-member 1

 

and then in the dialer pool define the parameter similar to this:

 

interface Dialer0

ip address negotiated

ip nbar protocol-discovery

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname bthomehub@btinternet.com

ppp ipcp dns request

ppp ipcp wins accept

ppp ipcp route default

 

 

But I noticed since BT upgraded the line to vdsl (G_993_2_ANNEX_B), that neither configs work. And for bridging this is the configs used under the interfaces:

 

interface GigabitEthernet0/0/1

no ip address

negotiation auto

service instance 1 ethernet

  encapsulation dot1q 1

 

creating the bridge interface:

 

interface BDI 1

description bridge bt to mx

encapsulation dot1q 1

no shut

 

And then added also the ethernet interface to the same bridge with same config, but instead of using the dialer interface since its vdsl, it uses the ethernet interface? Not sure which is correct as there is quite allot of secrecy around the adsl structure, and would be grateful is someone could break it down because as far as I know, when using adsl, the ISR uses the controller for choosing the ADSL mode, the atm interface for the modulation and encapsulation settings, and the dialer interface for the ppp settings etc... when setting to vdsl mode does this remove the use of the atm interface and dialer and just uses the ethernet?

 

post with the complete config will follow but would be great to get some input on this as it would be great to see what engineers do out there :)

 

#HappyNetworking

 

    

2 REPLIES 2
Highlighted
VIP Expert

Hello,

 

I am probably way off here, but have a look at the example config linked below, is that something you could use ?

 

https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/bbdsl/configuration/xe-3s/bba-xe-3s-book/bba-atm-rbe-xe.html#GUID-F3508F0B-4CA8-479B-843D-411B95116E48

Highlighted

This looks interesting Georg and could work. 
However, the ultimate goal for Alex is to pass public IP to the downstream Meraki MX, WAN1 interface. In that case how to bridge that ATM interface with Gig0/2/0 (where MX is connected) using BDI? 

 

I was trying to help him before but I'm lost with it too.